Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1377566 - VM is flickering with 'autoresize VM with window' enabled
Summary: VM is flickering with 'autoresize VM with window' enabled
Keywords:
Status: CLOSED DUPLICATE of bug 1266484
Alias: None
Product: Fedora
Classification: Fedora
Component: spice
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Christophe Fergeau
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-09-20 06:22 UTC by Vít Ondruch
Modified: 2016-09-26 08:45 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-09-26 08:45:12 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Vít Ondruch 2016-09-20 06:22:27 UTC
Description of problem:
When I enable 'Auto resize VM with window' option in my virtmanager, the VM is flickering and is basically unusable. At the same time, I can see a lot of messages in my journal:

```
Sep 20 08:17:34 unused-4-175.brq.redhat.com kernel: input: spice vdagent tablet as /devices/virtual/input/input13
Sep 20 08:17:34 unused-4-175.brq.redhat.com gnome-shell[1106]: Could not release device 13,69: GDBus.Error:org.freedesktop.login1.DeviceNotTaken: Device not taken
Sep 20 08:17:34 unused-4-175.brq.redhat.com gnome-settings-[1358]: unable to get EDID for xrandr-Virtual-1: unable to get EDID for output
Sep 20 08:17:35 unused-4-175.brq.redhat.com gnome-settings-[1358]: unable to get EDID for xrandr-Virtual-1: unable to get EDID for output
Sep 20 08:17:36 unused-4-175.brq.redhat.com gnome-settings-[1358]: unable to get EDID for xrandr-Virtual-1: unable to get EDID for output
Sep 20 08:17:37 unused-4-175.brq.redhat.com gnome-settings-[1358]: unable to get EDID for xrandr-Virtual-1: unable to get EDID for output
```

It seems that the screen is flickering with the same frequency as this messages appear in the log.



Version-Release number of selected component (if applicable):
$ rpm -q spice-server 
spice-server-0.13.2-1.fc26.x86_64

$ rpm -q spice-vdagent 
spice-vdagent-0.16.0-3.fc24.x86_64

$ rpm -q gnome-settings-daemon 
gnome-settings-daemon-3.21.92.1-1.fc26.x86_64

$ uname -a
Linux unused-4-175.brq.redhat.com 4.8.0-0.rc6.git4.1.fc26.x86_64 #1 SMP Fri Sep 16 22:25:23 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux


How reproducible:


Steps to Reproduce:
1. Enable 'Auto resize VM with window' virt manager option.
2.
3.

Actual results:
The gnome-shell is flickering.


Expected results:
The gnome-shell is not flickering.


Additional info:
Disabling the 'auto resize' feature workaronds the issue.

Comment 1 Vít Ondruch 2016-09-26 08:45:12 UTC

*** This bug has been marked as a duplicate of bug 1266484 ***


Note You need to log in before you can comment on or make changes to this bug.