Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1378147 - gdb crashes on some inferior function call scripts
Summary: gdb crashes on some inferior function call scripts
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Developer Toolset
Classification: Red Hat
Component: gdb
Version: DTS 6.0 RHEL 7
Hardware: Unspecified
OS: Linux
unspecified
unspecified
Target Milestone: beta1
: 6.0
Assignee: Jan Kratochvil
QA Contact: Martin Cermak
URL:
Whiteboard:
Depends On:
Blocks: 1378143
TreeView+ depends on / blocked
 
Reported: 2016-09-21 15:17 UTC by Mark Wielaard
Modified: 2016-11-15 10:12 UTC (History)
11 users (show)

Fixed In Version: devtoolset-6-gdb-7.12-0.19.20160929.el7
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
Environment:
Last Closed: 2016-11-15 10:12:30 UTC
Target Upstream Version:
Embargoed:


Attachments (Terms of Use)
reproducer program source (deleted)
2016-09-21 15:17 UTC, Mark Wielaard
no flags Details
GDB stdin script (deleted)
2016-09-21 15:17 UTC, Mark Wielaard
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2737 0 normal SHIPPED_LIVE new packages: devtoolset-6-gdb 2016-11-15 14:49:23 UTC
Sourceware 20345 0 None None None 2019-01-02 07:35:07 UTC

Description Mark Wielaard 2016-09-21 15:17:11 UTC
Created attachment 1203366 [details]
reproducer program source

gdb crashes on the valgrind gdb_server integration tests causing the valgrind package build to hang in %check. For now the valgrind package has the gdb_server tests disabled with this valgrind.spec snippet:

echo ===============TESTING===================
# On arm the gdb integration tests hang for unknown reasons.
# When building a scl we might pick a bad gdb.
# Only run the main tools tests.
# Recent GDB crashes on the gdb_server tests. Disable everywhere for now.
#%ifarch %{arm}
./close_fds make nonexp-regtest || :
#%else
#  %if %{is_scl}
#    ./close_fds make nonexp-regtest || :
#  %else
#    ./close_fds make regtest || :
#  %endif
#%endif

The gdb crash isn't related to valgrind however. It can be triggered with the attached program and script (derived from the valgrind testcase):

$ gcc -g -O0 -o t t.c -lpthread
$ gdb ./t < gdb.input

Comment 1 Mark Wielaard 2016-09-21 15:17:53 UTC
Created attachment 1203367 [details]
GDB stdin script

Comment 2 Jan Kratochvil 2016-09-28 20:41:39 UTC
It does not crash on: gdb-7.11.1-75.fc24.x86_64
It does crash on: gdb-7.12-0.11.20160904.fc26.x86_64
That is a regression.

Comment 4 Jan Kratochvil 2016-09-29 02:56:23 UTC
It is now in upstream 7.12 branch so it does not really require 3ACK:
[pushed master+7.12] Fix PR 20345 - call_function_by_hand_dummy: Assertion `tp->thread_fsm == &sm->thread_fsm' failed
https://sourceware.org/ml/gdb-patches/2016-09/msg00404.html

Comment 5 Jan Kratochvil 2016-09-29 02:59:26 UTC
BTW its testfile is: gdb.base/infcall-input.exp

Comment 6 Martin Cermak 2016-09-29 10:31:30 UTC
Brian, would you mind pm_acking this one, please?

Comment 8 Fedora Update System 2016-09-29 15:21:22 UTC
gdb-7.12-0.19.20160929.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-cc57295873

Comment 10 Fedora Update System 2016-10-09 02:47:16 UTC
gdb-7.12-0.19.20160929.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Comment 13 errata-xmlrpc 2016-11-15 10:12:30 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2737.html


Note You need to log in before you can comment on or make changes to this bug.