Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1383995 - OpenIPMI-2.0.22-3.fc25 FTBFS: storage size of 'ctx' isn't known
Summary: OpenIPMI-2.0.22-3.fc25 FTBFS: storage size of 'ctx' isn't known
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: OpenIPMI
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Josef Ridky
QA Contact: Fedora Extras Quality Assurance
URL: http://apps.fedoraproject.org/koschei...
Whiteboard:
Depends On:
Blocks: 1383740
TreeView+ depends on / blocked
 
Reported: 2016-10-12 10:31 UTC by Jitka Plesnikova
Modified: 2016-10-17 12:48 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-10-17 12:48:52 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)
upstream patch (deleted)
2016-10-17 10:23 UTC, Josef Ridky
no flags Details | Diff

Description Jitka Plesnikova 2016-10-12 10:31:00 UTC
Description of problem:
Package OpenIPMI fails to build from source in Fedora Rawhide.

aes_cbc.c: In function 'aes_cbc_encrypt':
aes_cbc.c:89:20: error: storage size of 'ctx' isn't known
     EVP_CIPHER_CTX ctx;
                    ^~~
aes_cbc.c:89:20: warning: unused variable 'ctx' [-Wunused-variable]
aes_cbc.c: In function 'aes_cbc_decrypt':
aes_cbc.c:173:20: error: storage size of 'ctx' isn't known
     EVP_CIPHER_CTX ctx;
                    ^~~
aes_cbc.c:173:20: warning: unused variable 'ctx' [-Wunused-variable]


This is caused by upgrading openssl from 1:1.0.2j-1.fc26 to 1:1.1.0b-1.fc26.

Additional info:
This package is tracked by Koschei. See:
http://apps.fedoraproject.org/koschei/package/OpenIPMI

Comment 1 Fedora Admin XMLRPC Client 2016-10-14 09:38:50 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 2 Josef Ridky 2016-10-17 10:23:23 UTC
Created attachment 1211298 [details]
upstream patch

Comment 3 Josef Ridky 2016-10-17 12:48:52 UTC
fixed in rawhide only (older branches are not affected by this issue)


Note You need to log in before you can comment on or make changes to this bug.