Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1384534 - Dragging application from dash to new workspace does not open app window in new workspace
Summary: Dragging application from dash to new workspace does not open app window in n...
Keywords:
Status: CLOSED DUPLICATE of bug 1384440
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-shell
Version: 25
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Owen Taylor
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-10-13 13:35 UTC by Ankur Sinha (FranciscoD)
Modified: 2016-10-14 11:48 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-10-14 11:48:36 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)
Screenshot (deleted)
2016-10-13 13:35 UTC, Ankur Sinha (FranciscoD)
no flags Details

Description Ankur Sinha (FranciscoD) 2016-10-13 13:35:05 UTC
Created attachment 1210093 [details]
Screenshot

Description of problem:
As part of the wayland test day, I dragged an application from the dash to a new workspace. 

Version-Release number of selected component (if applicable):
rpm -q gtk3 gnome-shell mutter
gtk3-3.22.1-2.fc25.x86_64
gnome-shell-3.22.1-1.fc25.x86_64
mutter-3.22.1-2.fc25.x86_64


How reproducible:
Always

Steps to Reproduce:
1. In a wayland session with gnome3, drag an application from dash to new workspace
2.
3.

Actual results:
Creates new window in currently focussed workspace BUT does create a new workspace if you had selected the last one

Expected results:
Should create a window on workspace that the icon was dragged to. Should create new workspace if this was the last workspace (this part seems to work)

Additional info:

Comment 1 Ankur Sinha (FranciscoD) 2016-10-13 13:39:22 UTC
Probably a duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=1384440

Comment 2 Kamil Páral 2016-10-14 11:48:36 UTC

*** This bug has been marked as a duplicate of bug 1384440 ***


Note You need to log in before you can comment on or make changes to this bug.