Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1387860 - Error message when the atomic command is used with bash-completion
Summary: Error message when the atomic command is used with bash-completion
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: atomic
Version: 25
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Lokesh Mandvekar
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-10-22 17:02 UTC by Lukas Slebodnik
Modified: 2017-04-01 17:10 UTC (History)
7 users (show)

Fixed In Version: atomic-1.16.4-1.fc26
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-04-01 17:10:53 UTC
Type: Bug


Attachments (Terms of Use)

Description Lukas Slebodnik 2016-10-22 17:02:29 UTC
Description of problem:
The following error message is printed when the atomic command is used with bash-completion
"ls: cannot access '/var/lib/containers/atomic/': No such file or directory"

Version-Release number of selected component (if applicable):
sh$ rpm -q atomic
atomic-1.13.1-3.git5dfcaa9.fc25.x86_64

How reproducible:
Deterministic

Steps to Reproduce:
1. Try to use bash completion e.g.
atomic run <tab>

Actual results:
sh# atomic run ls: cannot access '/var/lib/containers/atomic/': No such file or directory

Expected results:
Either nothing or there should be a suggestion for running available containers.

Comment 1 Antonio Murdaca 2016-10-22 17:24:30 UTC
was this working with previous atomic versions? seems like atomic never shipped/owned this "directory" as part of %files in the atomic.spec

Comment 2 Lukas Slebodnik 2016-10-22 17:28:54 UTC
(In reply to Antonio Murdaca from comment #1)
> was this working with previous atomic versions? seems like atomic never
> shipped/owned this "directory" as part of %files in the atomic.spec

Previously, I did not see the error "ls: cannot access '/var/lib/containers/atomic/': No such file or directory"

Comment 3 Daniel Walsh 2016-10-23 10:14:51 UTC
Antonio could you add that directory to the atomic spec file.  We should create it on install and own it in the spec file.

Comment 4 Daniel Walsh 2016-10-23 10:16:14 UTC
I guess we should also own /var/lib/containers

Comment 6 Daniel Walsh 2016-10-23 10:32:00 UTC
Thanks, having that /var/lib/containers be owned by skopeo is probably better.

Comment 7 Antonio Murdaca 2016-10-23 12:40:49 UTC
Sure, at this point though, we'll have the following situation:

Skopeo-containers owns /var/lib/containers

Is it possible to ship /var/lib/containers/atomic as part of atomic.spec or does this need to be owned by skopeo-containers as well? I see no issues in having skopeo-containers ship that as well.

Comment 8 Giuseppe Scrivano 2016-10-24 09:43:34 UTC
I think the bash autocompletion should check that the directory exists before trying to access it.

I have submitted a PR to address it:

https://github.com/projectatomic/atomic/pull/722

Comment 9 Daniel Walsh 2016-10-24 13:15:17 UTC
Yes but atomic should own the directory.  We should ship with it.

skopeo should not know about this directory.

Comment 10 Daniel Walsh 2016-10-24 14:58:37 UTC
Lokesh I am about to create atomic-1.13.2, could you also fix the spec file when we ship this version.

Comment 11 Lukas Slebodnik 2016-12-22 23:23:33 UTC
Problematic directories are not owned by any package and they do not exist.

sh#  rpm -qf /var/lib/containers/atomic/
error: file /var/lib/containers/atomic: No such file or directory
sh#  rpm -qf /var/lib/containers/
error: file /var/lib/containers: No such file or directory

But I cannot reproduce issue with bash-completion with atomic-1.14.0-3.dev.git127d5a0.fc26.x86_64.

Could you set proper version into the field "Fixed In Version" and close the bug?

Comment 12 Daniel Walsh 2016-12-23 09:43:48 UTC
Fixed in atomic-1.14.0

Comment 13 Lokesh Mandvekar 2017-01-18 18:47:34 UTC
working on this now, so atomic should own /var/lib/containers and /var/lib/containers/atomic, correct?

Comment 14 Daniel Walsh 2017-01-18 19:07:25 UTC
Yes.

Comment 15 Fedora Update System 2017-02-08 14:47:10 UTC
atomic-1.15.3-2.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-1def5655ad

Comment 16 Fedora Update System 2017-02-09 22:20:54 UTC
atomic-1.15.3-2.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-1def5655ad

Comment 17 Fedora Update System 2017-03-09 20:58:24 UTC
atomic-1.16.3-1.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-2ad6948192

Comment 18 Fedora Update System 2017-03-11 14:26:02 UTC
atomic-1.16.3-1.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-2ad6948192

Comment 19 Fedora Update System 2017-03-16 16:02:25 UTC
atomic-1.16.4-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-e8cbc792c6

Comment 20 Fedora Update System 2017-03-17 02:20:06 UTC
atomic-1.16.4-1.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-e8cbc792c6

Comment 21 Fedora Update System 2017-04-01 17:10:53 UTC
atomic-1.16.4-1.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.