Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1398063 - OpenImageIO requires libpugixml.so.1.0()(64bit)
Summary: OpenImageIO requires libpugixml.so.1.0()(64bit)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: OpenImageIO
Version: epel7
Hardware: aarch64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Richard Shaw
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-11-24 02:39 UTC by Luya Tshimbalanga
Modified: 2016-12-12 21:51 UTC (History)
1 user (show)

Fixed In Version: OpenImageIO-1.5.24-3.el7.1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-12-12 21:51:30 UTC
Type: Bug


Attachments (Terms of Use)

Description Luya Tshimbalanga 2016-11-24 02:39:15 UTC
Description of problem:
The failure occured on aarch64 architectures when attempting to build Blender in epe7.

Version-Release number of selected component (if applicable):
1.5.24-3

How reproducible:
Always


Steps to Reproduce:
1. Use the build system for epel7
2.
3.

Actual results:
Failure to build due to incomplete requirement from libpugxml

Expected results:
Build should be successfull

Additional info:
Mock output from aarch64 build:
https://kojipkgs.fedoraproject.org//work/tasks/106/16590106/mock_output.log

Failed build:
http://koji.fedoraproject.org/koji/taskinfo?taskID=16590106

Comment 1 Richard Shaw 2016-11-25 20:44:24 UTC
1.5.24 is the current build that should be available and should have addressed this problem.

Comment 2 Luya Tshimbalanga 2016-11-26 10:05:03 UTC
(In reply to Richard Shaw from comment #1)
> 1.5.24 is the current build that should be available and should have
> addressed this problem.

The build seems fine on other architectures except aarch64. I attempt to build again Blender on epel7 with the same result =(

http://koji.fedoraproject.org/koji/getfile?taskID=16630514&name=mock_output.log&offset=-4000
http://koji.fedoraproject.org/koji/taskinfo?taskID=16630514

Comment 3 Richard Shaw 2016-11-26 16:57:34 UTC
Well there's a new release of pugixml, 1.8, so I might as well build it for epel7 first and then we'll try an OpenImageIO rebuild.

Comment 4 Luya Tshimbalanga 2016-11-26 22:14:50 UTC
(In reply to Richard Shaw from comment #3)
> Well there's a new release of pugixml, 1.8, so I might as well build it for
> epel7 first and then we'll try an OpenImageIO rebuild.

Excellent. Thank you for looking this report.

Comment 5 Fedora Update System 2016-11-27 00:14:14 UTC
OpenImageIO-1.5.24-3.el7.1 pugixml-1.8-1.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-1f6ab85599

Comment 6 Fedora Update System 2016-11-28 08:20:31 UTC
OpenImageIO-1.5.24-3.el7.1, pugixml-1.8-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-1f6ab85599

Comment 7 Fedora Update System 2016-12-12 21:51:30 UTC
OpenImageIO-1.5.24-3.el7.1, pugixml-1.8-1.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.