Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1399045 - k4dirstat crashes under wayland
Summary: k4dirstat crashes under wayland
Keywords:
Status: CLOSED DUPLICATE of bug 1392605
Alias: None
Product: Fedora
Classification: Fedora
Component: qt5
Version: 25
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Helio Chissini de Castro
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-11-28 07:11 UTC by Emmanuel Touzery
Modified: 2017-01-08 19:35 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-08 19:35:18 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Emmanuel Touzery 2016-11-28 07:11:47 UTC
Description of problem:

k4dirstat works fine under X11, but crashes on wayland when you open the "file open" dialog, or run it from the terminal.

Version-Release number of selected component (if applicable):
k4dirstat-3.1.2-1.fc25.x86_64

How reproducible:
every time

Steps to Reproduce:
1. start the app from the menus
2. click the "open" button

or:
1. start the app from the terminal

Actual results:
The app crashes


Additional info:

When run from the terminal, the output contains the line:
(k4dirstat:17707): Gdk-WARNING **: gdkwindow-x11.c:5554 drawable is not a native X11 window

Comment 1 Dmitrij S. Kryzhevich 2016-12-01 03:25:49 UTC
Well. I haven't machine with wayland.

Anyway, looks like for some reasons it calls gtk2 which lacks wayland support. At all. And looks like EVERY kf5 package linked with gtk2 as Qt5 is. That strange.

I suppose I can't do anything here for now.

Comment 2 Emmanuel Touzery 2016-12-01 07:40:11 UTC
maybe it tries to display the gtk2 file picker if it detects a gnome environment?

Comment 3 Dmitrij S. Kryzhevich 2016-12-05 08:23:39 UTC
That's correct. It does. And as Wayland is default for Gnome now k4dirstat fails to use X features and fall.

The workaround could be starting it as following:

GDK_BACKEND=x11 k4dirstat

Or to force usage of qt file picker. qgnomeplatform package could help here (or not, I can't test this, sorry).

Comment 4 Emmanuel Touzery 2016-12-14 12:23:19 UTC
Note that the same problem also affects qtcreator.

The GDK_BACKEND=x11 trick helps for both applications.

Comment 5 Emmanuel Touzery 2016-12-17 08:58:08 UTC
given that this happens with k4dirstat, qtcreator and also a custom-built Qt5 QML application of mine, I think this should be assigned to the "qt" component in general, not k4dirstat in particular.

Hopefully the maintainers there can do something about this, it's quite a serious problem...

Comment 6 Dmitrij S. Kryzhevich 2016-12-17 10:07:39 UTC
It's a GTK bug not Qt I suppose.

Comment 7 Christian Stadelmann 2017-01-08 19:17:20 UTC
This bug is probably a duplicate of bug #1392605.

Comment 8 Emmanuel Touzery 2017-01-08 19:35:18 UTC
I agree, closing as duplicate.

*** This bug has been marked as a duplicate of bug 1392605 ***


Note You need to log in before you can comment on or make changes to this bug.