Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1399085 - gnome-software on F23 not showing upgrade to F25
Summary: gnome-software on F23 not showing upgrade to F25
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-software
Version: 23
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Richard Hughes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-11-28 09:22 UTC by Matej
Modified: 2016-11-29 23:53 UTC (History)
2 users (show)

Fixed In Version: gnome-software-3.20.5-3.fc23
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-29 23:53:27 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)
gnome-software logs (deleted)
2016-11-28 09:22 UTC, Matej
no flags Details

Description Matej 2016-11-28 09:22:53 UTC
Created attachment 1225213 [details]
gnome-software logs

Description of problem:

Software app advertising an upgrade to F24 not F25 on F23 workstation.

Version-Release number of selected component (if applicable): 3.20.4


How reproducible: always

Steps to Reproduce:
1. run Software
2. hit refresh button

Actual results:

system upgrade to F24 shows up

Expected results:

system upgrade to F25 shows up


Additional info:

- gnome-software logs attached (no relevant info on upgrade found)
- F25 metadata cached in ~/.cache/gnome-software/3.20/upgrades/fedora.json 

    {
      "allow_retire": false,
      "branchname": "f25",
      "date_created": "2016-07-26 13:50:32",
      "date_updated": "2016-11-22 14:31:43",
      "dist_tag": ".fc25",
      "koji_name": "f25",
      "name": "Fedora",
      "status": "Active",
      "version": "25"
    },


↪ dconf dump /org/gnome/software/
[/]
first-run=false
check-timestamp=int64 1480320398
install-timestamp=int64 1467279390

↪ systemctl status packagekit.service
● packagekit.service - PackageKit Daemon
   Loaded: loaded (/usr/lib/systemd/system/packagekit.service; static; vendor preset: disabled)
   Active: active (running) since Pá 2016-11-25 10:31:56 CET; 2 days ago
 Main PID: 1324 (packagekitd)
   CGroup: /system.slice/packagekit.service
           └─1324 /usr/libexec/packagekitd

Comment 1 Kalev Lember 2016-11-28 10:51:45 UTC
Thanks. gnome-software-3.20.5-3.fc23 in updates-testing adds support to upgrading to F25.

Comment 2 Fedora Update System 2016-11-28 10:52:17 UTC
gnome-software-3.20.5-3.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-914e5c1df9

Comment 3 Fedora Update System 2016-11-29 23:53:27 UTC
gnome-software-3.20.5-3.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.