Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1400231 - compat-openssl10-devel Conflicts: openssl-devel
Summary: compat-openssl10-devel Conflicts: openssl-devel
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: compat-openssl10
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Tomas Mraz
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 1400196 1400233
TreeView+ depends on / blocked
 
Reported: 2016-11-30 17:32 UTC by Rex Dieter
Modified: 2016-12-01 15:28 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-12-01 11:22:12 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Rex Dieter 2016-11-30 17:32:00 UTC
I know compat-openssl10-devel mentions:

# The devel subpackage intentionally conflicts with main openssl-devel
# as simultaneous use of both openssl package cannot be encouraged.
# Making the packages non-conflicting would also require further
# changes in the dependent packages.
Conflicts: openssl-devel


kde-sig currently have (almost) our entire software stack of blocking on this currently.

Qt5 is (hopefully) fixed as of today, but much legacy software (including Qt4) still FTBFS against openssl-1.1.  Couple this with a few -devel items in the software stack that currently:
Requires: openssl-devel
(like mariadb-devel), and we have a much bigger FTBFS problem


Now, if this legacy compat package cannot or will not move headers, then maybe the newer openssl-1.1 one can and should.

Comment 1 Rex Dieter 2016-11-30 17:37:45 UTC
See also related mariadb bug #1400233

Comment 2 Tomas Mraz 2016-12-01 11:22:12 UTC
I am sorry, but no, I am not going to move the openssl-1.1 headers and promote the use of compat-openssl10.

Comment 3 Rex Dieter 2016-12-01 14:26:03 UTC
I'm sorry too, I didn't have to expect to raise this to FESCo

Comment 4 Rex Dieter 2016-12-01 14:27:02 UTC
Unless, do you have some other reasonable compromise for fixing all the not-yet-ported-to-openssl-1.1 packages?

Comment 5 Tomas Mraz 2016-12-01 15:00:06 UTC
Can you please come up with a list of the packages where the conflicts prevents them from rebuilding?

Comment 6 Tomas Mraz 2016-12-01 15:06:48 UTC
Also btw - without full namespacing of the API symbols in includes the -devel packages really conflict and just moving the files around does not really fix this conflict. Yes, in practice it might sometimes work but there is no guarantee.

Comment 7 Rex Dieter 2016-12-01 15:28:16 UTC
Currently the list includes only what
BuildRequires: mariadb-devel
(which includes qt and everything that depends on it), but that appears to be close to being resolved via bug #1400233


Note You need to log in before you can comment on or make changes to this bug.