Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1405117 - [abrt] texstudio: qt_message_fatal(): texstudio killed by SIGABRT
Summary: [abrt] texstudio: qt_message_fatal(): texstudio killed by SIGABRT
Keywords:
Status: CLOSED DUPLICATE of bug 1392605
Alias: None
Product: Fedora
Classification: Fedora
Component: texstudio
Version: 25
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Christian Dersch
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:a400fe6283a4e1a1ba1aea826f9...
: 1440248 (view as bug list)
Depends On: 1392605
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-12-15 16:13 UTC by NMueller
Modified: 2017-04-07 16:30 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-04-04 15:19:16 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)
File: backtrace (deleted)
2016-12-15 16:13 UTC, NMueller
no flags Details
File: cgroup (deleted)
2016-12-15 16:13 UTC, NMueller
no flags Details
File: core_backtrace (deleted)
2016-12-15 16:13 UTC, NMueller
no flags Details
File: dso_list (deleted)
2016-12-15 16:13 UTC, NMueller
no flags Details
File: environ (deleted)
2016-12-15 16:13 UTC, NMueller
no flags Details
File: limits (deleted)
2016-12-15 16:13 UTC, NMueller
no flags Details
File: maps (deleted)
2016-12-15 16:13 UTC, NMueller
no flags Details
File: mountinfo (deleted)
2016-12-15 16:13 UTC, NMueller
no flags Details
File: namespaces (deleted)
2016-12-15 16:13 UTC, NMueller
no flags Details
File: open_fds (deleted)
2016-12-15 16:13 UTC, NMueller
no flags Details
File: proc_pid_status (deleted)
2016-12-15 16:13 UTC, NMueller
no flags Details
File: texstudio_backtrace1.txt (deleted)
2016-12-15 16:13 UTC, NMueller
no flags Details
File: texstudio_backtrace3.txt (deleted)
2016-12-15 16:13 UTC, NMueller
no flags Details
File: var_log_messages (deleted)
2016-12-15 16:13 UTC, NMueller
no flags Details

Description NMueller 2016-12-15 16:13:27 UTC
Description of problem:
I clicked File->Open and Texstudio crashed. This is reproducible for me and also happens when I click File->Save as.

Version-Release number of selected component:
texstudio-2.11.0-1.fc25

Additional info:
reporter:       libreport-2.8.0
backtrace_rating: 4
cmdline:        texstudio
crash_function: qt_message_fatal
executable:     /usr/bin/texstudio
global_pid:     20041
kernel:         4.8.13-300.fc25.x86_64
pkg_fingerprint: 4089 D8F2 FDB1 9C98
pkg_vendor:     Fedora Project
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #2 qt_message_fatal at global/qlogging.cpp:1680
 #3 QMessageLogger::fatal at global/qlogging.cpp:793
 #4 Texstudio::recoverFromCrash at texstudio.cpp:10219
 #5 XChangeProperty at ChProp.c:46
 #6 XSetTransientForHint at SetHints.c:286
 #7 QGtk3Dialog::show at qgtk3dialoghelpers.cpp:133
 #8 QGtk3FileDialogHelper::show at qgtk3dialoghelpers.cpp:258
 #9 QDialogPrivate::setNativeDialogVisible at dialogs/qdialog.cpp:140
 #10 QFileDialog::setVisible at dialogs/qfiledialog.cpp:846
 #11 QDialog::exec at dialogs/qdialog.cpp:544

Comment 1 NMueller 2016-12-15 16:13:32 UTC
Created attachment 1232256 [details]
File: backtrace

Comment 2 NMueller 2016-12-15 16:13:33 UTC
Created attachment 1232257 [details]
File: cgroup

Comment 3 NMueller 2016-12-15 16:13:35 UTC
Created attachment 1232258 [details]
File: core_backtrace

Comment 4 NMueller 2016-12-15 16:13:36 UTC
Created attachment 1232259 [details]
File: dso_list

Comment 5 NMueller 2016-12-15 16:13:38 UTC
Created attachment 1232260 [details]
File: environ

Comment 6 NMueller 2016-12-15 16:13:39 UTC
Created attachment 1232261 [details]
File: limits

Comment 7 NMueller 2016-12-15 16:13:41 UTC
Created attachment 1232262 [details]
File: maps

Comment 8 NMueller 2016-12-15 16:13:42 UTC
Created attachment 1232263 [details]
File: mountinfo

Comment 9 NMueller 2016-12-15 16:13:43 UTC
Created attachment 1232264 [details]
File: namespaces

Comment 10 NMueller 2016-12-15 16:13:45 UTC
Created attachment 1232265 [details]
File: open_fds

Comment 11 NMueller 2016-12-15 16:13:46 UTC
Created attachment 1232266 [details]
File: proc_pid_status

Comment 12 NMueller 2016-12-15 16:13:47 UTC
Created attachment 1232267 [details]
File: texstudio_backtrace1.txt

Comment 13 NMueller 2016-12-15 16:13:48 UTC
Created attachment 1232268 [details]
File: texstudio_backtrace3.txt

Comment 14 NMueller 2016-12-15 16:13:50 UTC
Created attachment 1232269 [details]
File: var_log_messages

Comment 15 Christian Dersch 2016-12-15 16:19:28 UTC
Some comments:

1.) We have an update in updates-testing: https://bodhi.fedoraproject.org/updates/FEDORA-2016-eac332aa81 Please check if that fixes the issue

2.) There was a similar report #1392597 which links to #1392605 → Are you running Wayland?

Comment 16 NMueller 2016-12-15 16:25:01 UTC
Thanks for the quick reply. 

1) I just installed the updates-testing version. The issues still persists.

2) Yes, I'm running Wayland. I just tested it also in a Xorg session and the problem doesn't occur there. So it may be very well related to #1392605

Comment 17 Christian Dersch 2016-12-15 16:27:24 UTC
Thanks for testing, looks like we have to wait for a fix of bug 1392605 then.

Comment 18 NMueller 2016-12-15 16:30:06 UTC
I tried the workaround of comment 13 in #1392605 (installing the package "qgnomeplatform"). It solved the problem for me.

Comment 19 Christian Stadelmann 2017-04-04 14:47:32 UTC
Please close this bug as a duplicate of #1392605.

Comment 20 NMueller 2017-04-04 15:19:16 UTC

*** This bug has been marked as a duplicate of bug 1392605 ***

Comment 21 NMueller 2017-04-07 16:30:22 UTC
*** Bug 1440248 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.