Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1405127 - Switching with Alt+Tab from Firefox makes file menu appear for a short time
Summary: Switching with Alt+Tab from Firefox makes file menu appear for a short time
Keywords:
Status: CLOSED DUPLICATE of bug 1393336
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox
Version: 25
Hardware: x86_64
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Gecko Maintainer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-12-15 16:39 UTC by Dertarr
Modified: 2016-12-19 12:02 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-12-19 12:02:36 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Dertarr 2016-12-15 16:39:46 UTC
Description of problem:
Switching with Alt+Tab from Firefox makes file menu (with File, Edit, View... items) appear for a short time. Once I press and hold Alt+Tab, the menu appears and stays. When I release the combination (at least the tab), the application is switched and the menu is gone.

The issue doesn't appear with Super+Tab combination.


Version-Release number of selected component (if applicable):
Just updated the system.
Fedora 25 with GNOME (on Wayland) desktop
GNOME Shell 3.22.2
Firefox 50.0.2
I have installed "TopIcons Plus" and "No Topleft Hot Corner" gnome extensions. Also have Skype alpha for linux installed. Otherwise the system is pretty clean. 

How reproducible: 100%

Steps to Reproduce:
1. gsettings set org.gnome.desktop.wm.keybindings switch-applications "['<Super>Tab', '<Alt>Tab']"
2. Launch some application (say, gnome terminal) in a window mode (not maximized)
3. Launch firefox and maximize it
4. Press and hold Alt+Tab - notice the menu has appeared.
5. Release the Tab - notice the menu has dissapeared, and another application is active now.

Actual results:
The menu on Firefox appears during switch to another application.

Expected results:
The menu must not appear.

Additional info:
Isn't reproduced with Super+Tab

Comment 1 Dertarr 2016-12-15 16:44:34 UTC
PS. I have two monitors, the secondary one is turned 90 degrees.

Comment 2 Martin Stransky 2016-12-19 12:02:36 UTC

*** This bug has been marked as a duplicate of bug 1393336 ***


Note You need to log in before you can comment on or make changes to this bug.