Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1409285 - [abrt] gnome-terminal: _g_log_abort(): gnome-terminal-server killed by SIGTRAP
Summary: [abrt] gnome-terminal: _g_log_abort(): gnome-terminal-server killed by SIGTRAP
Keywords:
Status: CLOSED DUPLICATE of bug 1258818
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-terminal
Version: 25
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Matthias Clasen
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:d678a3eb62a9313a723dfef12cc...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-12-31 07:56 UTC by Hedayat Vatankhah
Modified: 2017-05-24 09:11 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-05-24 09:11:15 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)
File: backtrace (19.82 KB, text/plain)
2016-12-31 07:56 UTC, Hedayat Vatankhah
no flags Details
File: cgroup (276 bytes, text/plain)
2016-12-31 07:56 UTC, Hedayat Vatankhah
no flags Details
File: core_backtrace (3.26 KB, text/plain)
2016-12-31 07:56 UTC, Hedayat Vatankhah
no flags Details
File: dso_list (11.23 KB, text/plain)
2016-12-31 07:56 UTC, Hedayat Vatankhah
no flags Details
File: environ (1009 bytes, text/plain)
2016-12-31 07:56 UTC, Hedayat Vatankhah
no flags Details
File: limits (1.29 KB, text/plain)
2016-12-31 07:56 UTC, Hedayat Vatankhah
no flags Details
File: maps (54.04 KB, text/plain)
2016-12-31 07:56 UTC, Hedayat Vatankhah
no flags Details
File: mountinfo (3.46 KB, text/plain)
2016-12-31 07:56 UTC, Hedayat Vatankhah
no flags Details
File: namespaces (102 bytes, text/plain)
2016-12-31 07:56 UTC, Hedayat Vatankhah
no flags Details
File: open_fds (1.92 KB, text/plain)
2016-12-31 07:56 UTC, Hedayat Vatankhah
no flags Details
File: proc_pid_status (1.13 KB, text/plain)
2016-12-31 07:56 UTC, Hedayat Vatankhah
no flags Details
File: var_log_messages (28 bytes, text/plain)
2016-12-31 07:56 UTC, Hedayat Vatankhah
no flags Details

Description Hedayat Vatankhah 2016-12-31 07:56:19 UTC
Version-Release number of selected component:
gnome-terminal-3.22.1-2.fc25

Additional info:
reporter:       libreport-2.8.0
backtrace_rating: 4
cmdline:        /usr/libexec/gnome-terminal-server
crash_function: _g_log_abort
executable:     /usr/libexec/gnome-terminal-server
global_pid:     11934
kernel:         4.8.15-300.fc25.x86_64
pkg_fingerprint: 4089 D8F2 FDB1 9C98
pkg_vendor:     Fedora Project
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (8 frames)
 #0 _g_log_abort at gmessages.c:487
 #1 g_log_writer_default at gmessages.c:2382
 #2 g_log_structured_array at gmessages.c:1770
 #3 g_log_structured at gmessages.c:1597
 #4 gdk_event_source_prepare at gdkeventsource.c:66
 #5 g_main_context_prepare at gmain.c:3501
 #7 g_main_context_iteration at gmain.c:3990
 #8 g_application_run at gapplication.c:2381

Potential duplicate: bug 1394394

Comment 1 Hedayat Vatankhah 2016-12-31 07:56:26 UTC
Created attachment 1236171 [details]
File: backtrace

Comment 2 Hedayat Vatankhah 2016-12-31 07:56:28 UTC
Created attachment 1236172 [details]
File: cgroup

Comment 3 Hedayat Vatankhah 2016-12-31 07:56:30 UTC
Created attachment 1236173 [details]
File: core_backtrace

Comment 4 Hedayat Vatankhah 2016-12-31 07:56:32 UTC
Created attachment 1236174 [details]
File: dso_list

Comment 5 Hedayat Vatankhah 2016-12-31 07:56:34 UTC
Created attachment 1236175 [details]
File: environ

Comment 6 Hedayat Vatankhah 2016-12-31 07:56:36 UTC
Created attachment 1236177 [details]
File: limits

Comment 7 Hedayat Vatankhah 2016-12-31 07:56:40 UTC
Created attachment 1236180 [details]
File: maps

Comment 8 Hedayat Vatankhah 2016-12-31 07:56:42 UTC
Created attachment 1236182 [details]
File: mountinfo

Comment 9 Hedayat Vatankhah 2016-12-31 07:56:44 UTC
Created attachment 1236184 [details]
File: namespaces

Comment 10 Hedayat Vatankhah 2016-12-31 07:56:45 UTC
Created attachment 1236185 [details]
File: open_fds

Comment 11 Hedayat Vatankhah 2016-12-31 07:56:46 UTC
Created attachment 1236187 [details]
File: proc_pid_status

Comment 12 Hedayat Vatankhah 2016-12-31 07:56:48 UTC
Created attachment 1236189 [details]
File: var_log_messages

Comment 13 Alan Jenkins 2017-01-23 11:52:22 UTC
Similar problem has been detected:

rpm2cpio policycoreutils-2.5-19.fc25.src.rpm > cpio
cpio -o <cpio

crashes just like #1394154

reporter:       libreport-2.8.0
backtrace_rating: 4
cmdline:        /usr/libexec/gnome-terminal-server
crash_function: _g_log_abort
executable:     /usr/libexec/gnome-terminal-server
global_pid:     4536
kernel:         4.9.4-201.fc25.x86_64
package:        gnome-terminal-3.22.1-2.fc25
pkg_fingerprint: 4089 D8F2 FDB1 9C98
pkg_vendor:     Fedora Project
reason:         gnome-terminal-server killed by SIGTRAP
runlevel:       N 5
type:           CCpp
uid:            1000

Comment 14 Alan Jenkins 2017-01-23 11:53:42 UTC
Here is the file to reproduce my commands above:
https://dl.dropboxusercontent.com/u/49925445/bugzilla.redhat.com/1394154/policycoreutils-2.5-19.fc25.src.rpm

Comment 15 Gabriel PREDA 2017-01-31 10:51:28 UTC
Similar problem has been detected:

after I issued cat /dev/urandom in a terminal... al terminals opened crashed!

reporter:       libreport-2.8.0
backtrace_rating: 4
cmdline:        /usr/libexec/gnome-terminal-server
crash_function: _g_log_abort
executable:     /usr/libexec/gnome-terminal-server
global_pid:     3793
kernel:         4.9.5-200.fc25.x86_64
package:        gnome-terminal-3.22.1-2.fc25
pkg_fingerprint: 4089 D8F2 FDB1 9C98
pkg_vendor:     Fedora Project
reason:         gnome-terminal-server killed by SIGTRAP
runlevel:       N 5
type:           CCpp
uid:            1000

Comment 16 youjinuser 2017-03-01 08:27:45 UTC
Similar problem has been detected:

1. open vi [vim-improved latest version provided by the package manager]
2. record macro @b: ":tabe"
3. run ":100@b"
4. run ":1000@b"
5. run ":10000@b"

The ENTIRE OS hangs until it gets killed.

reporter:       libreport-2.8.0
backtrace_rating: 4
cmdline:        /usr/libexec/gnome-terminal-server
crash_function: _g_log_abort
executable:     /usr/libexec/gnome-terminal-server
global_pid:     2416
kernel:         4.9.12-200.fc25.x86_64
package:        gnome-terminal-3.22.1-2.fc25
pkg_fingerprint: 4089 D8F2 FDB1 9C98
pkg_vendor:     Fedora Project
reason:         gnome-terminal-server killed by SIGTRAP
runlevel:       N 5
type:           CCpp
uid:            1000

Comment 17 Patrick Truebe 2017-03-09 11:10:11 UTC
Similar problem has been detected:

gnome crashed on automatic login after startup

reporter:       libreport-2.8.0
backtrace_rating: 4
cmdline:        /usr/libexec/gnome-terminal-server
crash_function: _g_log_abort
executable:     /usr/libexec/gnome-terminal-server
global_pid:     4360
kernel:         4.9.13-200.fc25.x86_64
package:        gnome-terminal-3.22.1-5.fc25
pkg_fingerprint: 4089 D8F2 FDB1 9C98
pkg_vendor:     Fedora Project
reason:         gnome-terminal-server killed by SIGTRAP
runlevel:       N 5
type:           CCpp
uid:            1000

Comment 18 Piet Hawengah 2017-05-01 08:05:59 UTC
*** Bug 1447018 has been marked as a duplicate of this bug. ***

Comment 19 Arne 2017-05-03 01:02:13 UTC
*** Bug 1447488 has been marked as a duplicate of this bug. ***

Comment 20 aoellerer 2017-05-23 16:08:33 UTC
*** Bug 1454873 has been marked as a duplicate of this bug. ***

Comment 21 Debarshi Ray 2017-05-24 09:11:15 UTC

*** This bug has been marked as a duplicate of bug 1258818 ***


Note You need to log in before you can comment on or make changes to this bug.