Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
RHEL Engineering is moving the tracking of its product development work on RHEL 6 through RHEL 9 to Red Hat Jira (issues.redhat.com). If you're a Red Hat customer, please continue to file support cases via the Red Hat customer portal. If you're not, please head to the "RHEL project" in Red Hat Jira and file new tickets here. Individual Bugzilla bugs in the statuses "NEW", "ASSIGNED", and "POST" are being migrated throughout September 2023. Bugs of Red Hat partners with an assigned Engineering Partner Manager (EPM) are migrated in late September as per pre-agreed dates. Bugs against components "kernel", "kernel-rt", and "kpatch" are only migrated if still in "NEW" or "ASSIGNED". If you cannot log in to RH Jira, please consult article #7032570. That failing, please send an e-mail to the RH Jira admins at rh-issues@redhat.com to troubleshoot your issue as a user management inquiry. The email creates a ServiceNow ticket with Red Hat. Individual Bugzilla bugs that are migrated will be moved to status "CLOSED", resolution "MIGRATED", and set with "MigratedToJIRA" in "Keywords". The link to the successor Jira issue will be found under "Links", have a little "two-footprint" icon next to it, and direct you to the "RHEL project" in Red Hat Jira (issue links are of type "https://issues.redhat.com/browse/RHEL-XXXX", where "X" is a digit). This same link will be available in a blue banner at the top of the page informing you that that bug has been migrated.
Bug 1420069 - NFStest version 2.1.5 includes server-side copy tests
Summary: NFStest version 2.1.5 includes server-side copy tests
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: nfstest
Version: 7.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Steve Dickson
QA Contact: JianHong Yin
URL:
Whiteboard:
Depends On:
Blocks: 1422947
TreeView+ depends on / blocked
 
Reported: 2017-02-07 17:06 UTC by Jorge Mora
Modified: 2017-08-01 18:35 UTC (History)
2 users (show)

Fixed In Version: nfstest-2.1.5-0.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1422947 (view as bug list)
Environment:
Last Closed: 2017-08-01 18:35:36 UTC
Target Upstream Version:
Embargoed:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:1990 0 normal SHIPPED_LIVE nfstest bug fix and enhancement update 2017-08-01 18:10:15 UTC

Description Jorge Mora 2017-02-07 17:06:39 UTC
Description of problem:
Please include latest version of NFStest on RHEL-7.4.
Latest version of NFStest have a new script nfstest_ssc
for testing NFSv4.2 server-side copy.

Version-Release number of selected component (if applicable):
Version 2.1.5

How reproducible:
N/A

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 3 JianHong Yin 2017-03-01 04:09:47 UTC
Verified:

'''
[root@bkr-hv01-guest25 nfstest]# lsb_release -sir
RedHatEnterpriseWorkstation 7.4
[root@bkr-hv01-guest25 nfstest]# rpm -q nfstest
nfstest-2.1.5-0.el7.noarch
[root@bkr-hv01-guest25 nfstest]# rpm -ql nfstest | grep _ssc
/usr/bin/nfstest_ssc
/usr/share/man/man1/nfstest_ssc.1.gz
[root@bkr-hv01-guest25 nfstest]# nfstest_ssc -h | less
[root@bkr-hv01-guest25 nfstest]# nfstest_ssc -h | head
Usage: nfstest_ssc --server <server> [options]

Server side copy tests
======================
Verify correct functionality of server side copy

Copying a file via NFS the client reads the data from the source file and
then writes the same data to the destination file which is located in the
same server or it could be located in a different server. Either way the
file data is transferred twice, once for reading and the second for writing.

[root@bkr-hv01-guest25 nfstest]# nfstest_ssc --server   bkr-hv01-guest08.dsal.lab.eng.bos.redhat.com  --export /home/test

*** Verify intra server side COPY succeeds
...
'''

Comment 4 errata-xmlrpc 2017-08-01 18:35:36 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1990


Note You need to log in before you can comment on or make changes to this bug.