Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1422448 - 'stop' subcommand does not work on atomic-1.15.1-1.fc25.x86_64
Summary: 'stop' subcommand does not work on atomic-1.15.1-1.fc25.x86_64
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: atomic
Version: 25
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Brent Baude
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-15 11:22 UTC by Martin Babinsky
Modified: 2017-04-01 17:10 UTC (History)
6 users (show)

Fixed In Version: atomic-1.16.4-1.fc26
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-04-01 17:10:21 UTC
Type: Bug


Attachments (Terms of Use)

Description Martin Babinsky 2017-02-15 11:22:32 UTC
Description of problem:

When using recent version of atomic on Fedora 25 (atomic-1.15.1-1.fc25.x86_64), `atomic stop $CONTAINER_NAME` raises the following traceback in verbose mode:

{{{
# atomic --debug stop freeipa-server 
Namespace(_class=<class 'Atomic.stop.Stop'>, args=[], assumeyes=False, container='freeipa-server', debug=True, func='stop', opt1=None, opt2=None, opt3=None)
Can't convert 'list' object to str implicitly
Traceback (most recent call last):
  File "/bin/atomic", line 188, in <module>
    sys.exit(_func())
  File "/usr/lib/python3.5/site-packages/Atomic/stop.py", line 40, in stop
    cmd = self.gen_cmd(con_obj.stop_args + self.quote(self.args.args))
TypeError: Can't convert 'list' object to str implicitly

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
  File "/bin/atomic", line 210, in <module>
    sys.exit(1)
SystemExit: 1
}}}

Version-Release number of selected component (if applicable):

atomic-1.15.1-1.fc25.x86_64

How reproducible:

Always

Steps to Reproduce:
1. pull container image and install container using atomic
2. run the container using `atomic run`
3. stop the container using atomic stop

Actual results:

Atomic stop stops the running container

Expected results:

The command displays the following error:
TypeError: Can't convert 'list' object to str implicitly

In debug mode the traceback displayed above can be seen.

Additional info:

This seems to be a regression as the command works on my F25 Atomic Host: the version there is atomic-1.13.1-3.git5dfcaa9.fc25.x86_64.

Comment 1 Daniel Walsh 2017-02-16 14:52:23 UTC
Brent we need to have a test for this also, to make sure we don't have a regression in the future.

Comment 2 Brent Baude 2017-02-16 19:38:46 UTC
I believe this will fix the issue -> https://github.com/projectatomic/atomic/pull/899

Comment 3 Martin Babinsky 2017-02-22 12:54:26 UTC
Yes the referenced PR fixes the issue, thanks.

Comment 4 Daniel Walsh 2017-03-09 20:56:54 UTC
Fixed in atomic-1.16.3

Comment 5 Fedora Update System 2017-03-09 20:58:10 UTC
atomic-1.16.3-1.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-2ad6948192

Comment 6 Fedora Update System 2017-03-09 20:59:11 UTC
atomic-1.16.3-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-cf5944a771

Comment 7 Fedora Update System 2017-03-11 00:21:23 UTC
atomic-1.16.3-1.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-cf5944a771

Comment 8 Fedora Update System 2017-03-11 14:25:54 UTC
atomic-1.16.3-1.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-2ad6948192

Comment 9 Fedora Update System 2017-03-16 16:01:45 UTC
atomic-1.16.4-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-e8cbc792c6

Comment 10 Fedora Update System 2017-03-17 02:19:46 UTC
atomic-1.16.4-1.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-e8cbc792c6

Comment 11 Fedora Update System 2017-04-01 17:10:21 UTC
atomic-1.16.4-1.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.