Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1423956 - mod_auth_openidc: FTBFS in rawhide
Summary: mod_auth_openidc: FTBFS in rawhide
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: mod_auth_openidc
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: John Dennis
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1394947 (view as bug list)
Depends On:
Blocks: F26FTBFS
TreeView+ depends on / blocked
 
Reported: 2017-02-17 15:23 UTC by Fedora Release Engineering
Modified: 2017-02-28 13:44 UTC (History)
4 users (show)

Fixed In Version: mod_auth_openidc-1.8.10.1-3.fc26
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-18 00:40:51 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)
build.log (14.68 KB, text/plain)
2017-02-17 15:23 UTC, Fedora Release Engineering
no flags Details
root.log (89.84 KB, text/plain)
2017-02-17 15:23 UTC, Fedora Release Engineering
no flags Details
state.log (667 bytes, text/plain)
2017-02-17 15:23 UTC, Fedora Release Engineering
no flags Details

Description Fedora Release Engineering 2017-02-17 15:23:16 UTC
Your package mod_auth_openidc failed to build from source in current rawhide.

https://koji.fedoraproject.org/koji/taskinfo?taskID=17738936

For details on mass rebuild see https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild

Comment 1 Fedora Release Engineering 2017-02-17 15:23:22 UTC
Created attachment 1253184 [details]
build.log

Comment 2 Fedora Release Engineering 2017-02-17 15:23:26 UTC
Created attachment 1253185 [details]
root.log

Comment 3 Fedora Release Engineering 2017-02-17 15:23:29 UTC
Created attachment 1253186 [details]
state.log

Comment 4 Upstream Release Monitoring 2017-02-18 00:37:47 UTC
jdennis's mod_auth_openidc-1.8.10.1-3.fc26 completed http://koji.fedoraproject.org/koji/buildinfo?buildID=860045

Comment 5 John Dennis 2017-02-18 00:40:51 UTC
New openssl 1.1.x modified some structures (e.g. RSA) to be private and provide accessors to those structures. As such the source in the jose library would not build using the new openssl headers.

Upstream mod_open_openidc has deprecated their jose library as of release 2.x in favor of the Cisco cjose library. But prior to the library change over upstream fixed their jose library to work with the new openssl. They also made other bug fixes.

The jose.patch that resolves this bug rolls up all the fixes upstream made to their jose library prior to 2.x.

Comment 6 John Dennis 2017-02-28 13:44:03 UTC
*** Bug 1394947 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.