Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at
Bug 1424009 - ofono: FTBFS in rawhide
Summary: ofono: FTBFS in rawhide
Alias: None
Product: Fedora
Classification: Fedora
Component: ofono
Version: 26
Hardware: Unspecified
OS: Unspecified
Target Milestone: ---
Assignee: Rex Dieter
QA Contact: Fedora Extras Quality Assurance
Depends On:
Blocks: F26FTBFS
TreeView+ depends on / blocked
Reported: 2017-02-17 15:34 UTC by Fedora Release Engineering
Modified: 2018-01-29 14:59 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Last Closed: 2018-01-29 14:59:07 UTC
Type: ---

Attachments (Terms of Use)
build.log (226.43 KB, text/plain)
2017-02-17 15:34 UTC, Fedora Release Engineering
no flags Details
root.log (79.63 KB, text/plain)
2017-02-17 15:34 UTC, Fedora Release Engineering
no flags Details
state.log (607 bytes, text/plain)
2017-02-17 15:35 UTC, Fedora Release Engineering
no flags Details

Description Fedora Release Engineering 2017-02-17 15:34:52 UTC
Your package ofono failed to build from source in current rawhide.

For details on mass rebuild see

Comment 1 Fedora Release Engineering 2017-02-17 15:34:57 UTC
Created attachment 1253344 [details]

Comment 2 Fedora Release Engineering 2017-02-17 15:34:59 UTC
Created attachment 1253345 [details]

Comment 3 Fedora Release Engineering 2017-02-17 15:35:02 UTC
Created attachment 1253346 [details]

Comment 4 Fedora End Of Life 2017-02-28 11:52:48 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 26 development cycle.
Changing version to '26'.

Comment 5 Samuel Sieb 2018-01-28 23:41:41 UTC
I don't know what the problem is here.  I just tried building it on my F27 system and it worked.  The version in the repos is still F24!

Comment 6 Samuel Sieb 2018-01-28 23:44:09 UTC
Oh, I see.  I looked in that build.log and it's failing one of the tests.

ERROR:unit/test-idmap.c:81:test_alloc_next: assertion failed: (bit == 1)
/bin/sh: line 5: 13083 Aborted                 (core dumped) ${dir}$tst

Comment 7 Samuel Sieb 2018-01-29 00:18:17 UTC
I just tried building with the latest release 1.22 and it builds fine (just need to run "./bootstrap" before configure).  It also doesn't crash when answering a call like the current version does.

Comment 8 Rex Dieter 2018-01-29 14:26:32 UTC
Thanks for looking into this.

I'll see about updating to 1.22 to get this into better shape.

I will probably consider orphaning it in the hopes of getting into better hands at that point. I was primarily interested in this as a dependency for pulseaudio at one point, but then PA plans changed.

Comment 9 Rex Dieter 2018-01-29 14:59:07 UTC
Fix commited to git, will try building again as soon a gcc is unbroken in rawhide. :-/

Note You need to log in before you can comment on or make changes to this bug.