Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1424714 - RFE: Enable renderonly support for iMX SOC
Summary: RFE: Enable renderonly support for iMX SOC
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: mesa
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Peter Robinson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: ARMTracker
TreeView+ depends on / blocked
 
Reported: 2017-02-18 16:26 UTC by billiboy
Modified: 2017-07-01 15:33 UTC (History)
5 users (show)

Fixed In Version: mesa-17.1.0-0.3.rc2.fc27
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-07-01 15:33:38 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)
renderonly-enable.patch (841 bytes, patch)
2017-02-18 16:26 UTC, billiboy
no flags Details | Diff

Description billiboy 2017-02-18 16:26:40 UTC
Created attachment 1255270 [details]
renderonly-enable.patch

Description of problem:

RFE: Enable renderonly support for iMX SOC

Version-Release number of selected component (if applicable):

mesa-*-17.0.0-1.fc26.armv7hl

How reproducible:

Always with mesa-*-17.0.0-1.fc26.armv7hl

Steps to Reproduce:

Install recent mesa-*-mesa-17.0.0-1.fc26.armv7hl on iMX SOC device

Actual results:
weston.log content:
...
 GL version: OpenGL ES 2.0 Mesa 17.0.0
 GLSL version: OpenGL ES GLSL ES 1.0.16
 GL vendor: VMware, Inc.
 GL renderer: Gallium 0.4 on llvmpipe (LLVM 3.8, 128 bits)
...

==> No etnaviv support available

Expected results:
weston.log content:
...

 GL version: OpenGL ES 2.0 Mesa 17.0.0
 GLSL version: OpenGL ES GLSL ES 1.0.16
 GL vendor: etnaviv
 GL renderer: Gallium 0.4 on Vivante GC2000 rev 5108
...

==> Etnaviv support available (hardware accelerated display)

Additional info:

Since mesa-*-17.0.0-0.2.rc1.fc26.armv7hl etnaviv support is available but fedora does not provide a xorg-x11-drv-armada package for X Window on iMX SOC devices to use it. For Weston / Wayland the renderonly counterpart in mesa is not enabled.
Consider to apply renderonly-enable.patch at mesa.spec to have renderonly support enabled for iMX SOC so Weston at least is working out of the box.

Comment 1 Peter Robinson 2017-03-03 11:29:47 UTC
It's on my list for F-26 already, will review.

Comment 2 billiboy 2017-03-04 09:17:04 UTC
As mesa 17.0.1 with etnaviv improvements is around the corner anyway no special hurry is required.

Comment 3 Peter Robinson 2017-04-28 12:35:12 UTC
Thanks, now pushed to mesa-17.1.0-0.3.rc2.fc27, we'll land this in F-26 when 17.1 heads there which will likely be next week.

Comment 4 Fedora Update System 2017-05-26 10:05:40 UTC
bcc-0.3.0-2.fc26 beignet-1.3.1-2.fc26 castxml-0.1-0.17.20170301gitfab9c47.fc26 clang-4.0.0-3.fc26 compiler-rt-4.0.0-1.fc26 gnome-builder-3.24.2-2.fc26 ispc-1.9.1-14.git.20170324.a618ad4.fc26 iwyu-0.7-3.20130330git.23253ec.fc26 kdevelop-5.1.0-4.fc26 ldc-1.1.1-4.fc26 lld-4.0.0-1.fc26 llvm-4.0.0-2.fc26 mesa-17.1.1-1.fc26 pocl-0.14-2.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-3aa9e1fe13

Comment 5 Fedora Update System 2017-05-26 10:05:56 UTC
bcc-0.3.0-2.fc26 beignet-1.3.1-2.fc26 castxml-0.1-0.17.20170301gitfab9c47.fc26 clang-4.0.0-3.fc26 compiler-rt-4.0.0-1.fc26 gnome-builder-3.24.2-2.fc26 ispc-1.9.1-14.git.20170324.a618ad4.fc26 iwyu-0.7-3.20130330git.23253ec.fc26 kdevelop-5.1.0-4.fc26 ldc-1.1.1-4.fc26 lld-4.0.0-1.fc26 llvm-4.0.0-2.fc26 mesa-17.1.1-1.fc26 pocl-0.14-2.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-3aa9e1fe13

Comment 6 Fedora Update System 2017-05-26 19:34:39 UTC
bcc-0.3.0-2.fc26, beignet-1.3.1-2.fc26, castxml-0.1-0.17.20170301gitfab9c47.fc26, clang-4.0.0-3.fc26, compiler-rt-4.0.0-1.fc26, gnome-builder-3.24.2-2.fc26, ispc-1.9.1-14.git.20170324.a618ad4.fc26, iwyu-0.7-3.20130330git.23253ec.fc26, kdevelop-5.1.0-4.fc26, ldc-1.1.1-4.fc26, lld-4.0.0-1.fc26, llvm-4.0.0-2.fc26, mesa-17.1.1-1.fc26, pocl-0.14-2.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-3aa9e1fe13

Comment 7 Fedora Update System 2017-06-09 18:54:32 UTC
bcc-0.3.0-2.fc26, beignet-1.3.1-2.fc26, castxml-0.1-0.17.20170301gitfab9c47.fc26, clang-4.0.0-3.fc26, compiler-rt-4.0.0-1.fc26, gnome-builder-3.24.2-2.fc26, ispc-1.9.1-14.git.20170324.a618ad4.fc26, iwyu-0.7-3.20130330git.23253ec.fc26, kdevelop-5.1.0-4.fc26, ldc-1.1.1-4.fc26, lld-4.0.0-1.fc26, llvm-4.0.0-2.fc26, mesa-17.1.1-1.fc26, pocl-0.14-2.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Comment 8 billiboy 2017-06-25 10:16:36 UTC
FWIW, there are recent images were I`m interested in available again. The packages are already at mesa-*-17.1.3-2.fc26.armv7hl.
Weston / Wayland is working without further intervention. With xorg-x11-drv-armada and proper configuration dropped in the LXQt spin is working quite good. All fedora provided components are working out of the box without further intervention.

Comment 9 Peter Robinson 2017-07-01 15:33:38 UTC
Fixed in mesa 17.1.x


Note You need to log in before you can comment on or make changes to this bug.