Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1427699 - fawkes-plugin-laserht requires libfawkescore.so.0.5.0()(64bit), but none of the providers can be installed.
Summary: fawkes-plugin-laserht requires libfawkescore.so.0.5.0()(64bit), but none of t...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: fawkes
Version: 25
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Tim Niemueller
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 1423591
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-28 22:10 UTC by George R. Goffe
Modified: 2017-04-09 16:42 UTC (History)
3 users (show)

Fixed In Version: fawkes-1.0.1-2.fc26
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-04-09 16:42:39 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)
Add missing Provides/Obsoletes (deleted)
2017-03-20 01:22 UTC, Rich Mattes
no flags Details | Diff

Description George R. Goffe 2017-02-28 22:10:47 UTC
Description of problem:

dnf upgrade produces error messages relating to fawkes-plugin-laserht-0.5.0-30.fc25.x86_64... see below

Version-Release number of selected component (if applicable):
fawkes-plugin-laserht-0.5.0-30.fc25.x86_64

How reproducible:
always

Steps to Reproduce:
1.see below
2.
3.

Actual results:
see below

Expected results:
"normal" system upgrade

Additional info:

dnf -y --best --allowerasing --enablerepo=updates --enablerepo=updates-testing --exclude=ghdl'*' upgrade
Last metadata expiration check: 0:03:41 ago on Tue Feb 28 13:57:07 2017.
Error: package fawkes-plugin-laserht-0.5.0-30.fc25.x86_64 requires libfawkescore.so.0.5.0()(64bit), but none of the providers can be installed.

Comment 1 Till Hofmann 2017-02-28 22:33:35 UTC
The plugin was removed. I guess fawkes-plugin-laser-lines is missing Obsoletes: (and possibly Provides:) for fawkes-plugin-laserht.

Comment 2 Rich Mattes 2017-03-20 01:22:01 UTC
Created attachment 1264690 [details]
Add missing Provides/Obsoletes

I think this patch should take care of it.  If it looks good to you I'll take care of the rebuilds for f25-f27.

Comment 3 Fedora Update System 2017-04-05 02:15:14 UTC
fawkes-1.0.1-2.fc26 player-3.0.2-59.fc26 gazebo-8.0.0-1.fc26 ignition-transport-3.0.1-2.fc26 ignition-msgs-0.7.0-3.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-bc49252409

Comment 4 Fedora Update System 2017-04-05 21:54:53 UTC
fawkes-1.0.1-2.fc26, gazebo-8.0.0-1.fc26, ignition-msgs-0.7.0-3.fc26, ignition-transport-3.0.1-2.fc26, player-3.0.2-59.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-bc49252409

Comment 5 Fedora Update System 2017-04-09 16:42:39 UTC
fawkes-1.0.1-2.fc26, gazebo-8.0.0-1.fc26, ignition-msgs-0.7.0-3.fc26, ignition-transport-3.0.1-2.fc26, player-3.0.2-59.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.