Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1428695 - test failure on s390x
Summary: test failure on s390x
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: usbguard
Version: rawhide
Hardware: s390x
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Daniel Kopeček
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: ZedoraTracker 1395615
TreeView+ depends on / blocked
 
Reported: 2017-03-03 07:42 UTC by Dan Horák
Modified: 2017-06-08 09:39 UTC (History)
3 users (show)

Fixed In Version: usbguard-0.6.3-0.1.20170319gite528ff6.fc27 usbguard-0.6.3-0.1.20170319gite528ff6.fc26
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-04-01 17:15:10 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)
build.log (deleted)
2017-03-03 07:42 UTC, Dan Horák
no flags Details

Description Dan Horák 2017-03-03 07:42:52 UTC
Created attachment 1259419 [details]
build.log

Build of recent usbguard fails because of test failure on s390x. If the root cause is
[1488526261.352] (E) ERROR: loadFiles: /sys/bus/usb/devices: No such file or directory
then is it expected, there is no USB on the mainframe (and unlikely ever will be). Our preference is to still build userspace stuff like this, because it reduces the differences from user's and packager's point of view.

See build.log from https://s390.koji.fedoraproject.org/koji/taskinfo?taskID=2510629 in attachments.

Version-Release number of selected component (if applicable):
usbguard-0.6.3-0.1.20170301gitfcde518.fc27

Comment 1 Fedora Update System 2017-03-19 17:59:16 UTC
usbguard-0.6.3-0.1.20170319gite528ff6.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-adb1d83ec8

Comment 2 Dan Horák 2017-03-20 08:49:50 UTC
confirmed in https://s390.koji.fedoraproject.org/koji/buildinfo?buildID=481236

Please update F-26 branch too.

Comment 3 Daniel Kopeček 2017-03-20 09:12:17 UTC
(In reply to Dan Horák from comment #2)
> confirmed in
> https://s390.koji.fedoraproject.org/koji/buildinfo?buildID=481236
> 
> Please update F-26 branch too.

Update for F-26 is pending:

https://bodhi.fedoraproject.org/updates/FEDORA-2017-adb1d83ec8

Comment 4 Dan Horák 2017-03-20 09:22:06 UTC
(In reply to Daniel Kopeček from comment #3)
> (In reply to Dan Horák from comment #2)
> > confirmed in
> > https://s390.koji.fedoraproject.org/koji/buildinfo?buildID=481236
> > 
> > Please update F-26 branch too.
> 
> Update for F-26 is pending:
> 
> https://bodhi.fedoraproject.org/updates/FEDORA-2017-adb1d83ec8

yup, sorry for noise, it built too - https://s390.koji.fedoraproject.org/koji/taskinfo?taskID=2528177

Comment 5 Fedora Update System 2017-03-21 14:24:07 UTC
usbguard-0.6.3-0.1.20170319gite528ff6.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-adb1d83ec8

Comment 6 Fedora Update System 2017-04-01 17:15:10 UTC
usbguard-0.6.3-0.1.20170319gite528ff6.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.