Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1430177 - Kontact doesn't work after update
Summary: Kontact doesn't work after update
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kontact
Version: 24
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
Assignee: Rex Dieter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1430590 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-03-08 01:04 UTC by Steve Grubb
Modified: 2017-03-11 22:30 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-03-11 11:50:43 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Steve Grubb 2017-03-08 01:04:34 UTC
Description of problem:
I updated kontact today and now its asking me to set up my accounts. It was working fine until this update. I have 12 years of data in an account. Did this update lose all my information? Should it have migrated settings or something? Is it incompatible with previous kontact?

Version-Release number of selected component (if applicable):
kontact-16.08.3-2.fc24.x86_64
kmail-16.08.3-2.fc24.x86_64

Steps to Reproduce:
1. dny -y update
2. open kontact


Actual results:
My email

Expected results:
Being asked to setup an account.

Comment 1 Fedora Update System 2017-03-08 14:42:04 UTC
kdepim-16.12.2-3.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2017-81bed9e1d4

Comment 2 Steve Grubb 2017-03-08 23:56:54 UTC
OK. With the update mentioned, kontact does have my data again. However, its very unstable and still unusable. It segfaults starting up, akonadi segfaults when fetching mail, and then it loses connection with the imap server. 

Mar  8 18:46:15 x2 akonadi_imap_resource: org.kde.pim.akonadicore: The item sync is being rolled-back.
Mar  8 18:46:15 x2 akonadi_imap_resource: org.kde.pim.imapresource: Fetch job failed  "Connection to server lost."
Mar  8 18:46:15 x2 akonadi_imap_resource: org.kde.pim.imapresource: ""
Mar  8 18:46:47 x2 akonadi_imap_resource: org.kde.pim.kimap: Connection to server lost  0
Mar  8 18:46:47 x2 akonadi_imap_resource: org.kde.pim.imapresource: Session login cancelled

Kontact is so complex the only solution is to reboot the system. I can usually access 1 or 2 emails before it loses the session.

Comment 3 Rex Dieter 2017-03-09 11:36:31 UTC
*** Bug 1430590 has been marked as a duplicate of this bug. ***

Comment 4 Rex Dieter 2017-03-09 11:47:52 UTC
You can probably consider some variant of the following to avoid having to reboot or restart session:


(command line):

akonadictl restart

or even

akonadictl stop
(and it should restart itself on demand the next time you launch an akonadi client, like kmail or kontact)


Of course, the more pressing issue here is:
akonadi_imap_resource: org.kde.pim.kimap: Connection to server lost  0

Comment 5 Steve Grubb 2017-03-09 12:54:43 UTC
I filed several bz upstream about how unstable this new release is:

https://bugs.kde.org/show_bug.cgi?id=377399 kontact loses imap connections constantly

https://bugs.kde.org/show_bug.cgi?id=377393 /usr/bin/akonadiserver crashes

https://bugs.kde.org/show_bug.cgi?id=377395 Kontact is crashing during start up

I also see the retrace server starting to count up crashes.

Comment 6 kevin 2017-03-11 00:02:59 UTC
Still getting the following (Times are AEST):

Last metadata expiration check: 0:13:11 ago on Sat Mar 11 09:45:57 2017.
Dependencies resolved.
=========================================================================
 Package      Arch        Version     Repository    Size
=========================================================================
Skipping packages with broken dependencies:
 akregator         x86_64      16.12.2-1.fc24        updates      677 k
 akregator-libs    x86_64      16.12.2-1.fc24        updates      560 k
 gpgme             x86_64      1.8.0-10.fc24         updates      196 k
 kaddressbook      x86_64      16.12.2-1.fc24        updates       80 k
 kaddressbook-libs x86_64      16.12.2-1.fc24        updates      151 k
 kdepim-addons     x86_64      16.12.2-1.fc24        updates      1.0 M
 kdepim-apps-libs  x86_64      16.12.2-1.fc24        updates      159 k
 kf5-libkleo       x86_64      16.12.2-1.fc24        updates      364 k
 kf5-mailcommon    x86_64      16.12.2-1.fc24        updates      518 k
 kf5-messagelib    x86_64      16.12.2-1.fc24        updates      5.2 M
 kleopatra         x86_64      16.12.2-1.fc24        updates      1.4 M
 kleopatra-libs    x86_64      16.12.2-1.fc24        updates       93 k
 kmail             x86_64      16.12.2-1.fc24        updates      1.5 M
 kmail-libs        x86_64      16.12.2-1.fc24        updates      940 k
 knotes-libs       x86_64      16.12.2-1.fc24        updates      243 k
 kontact           x86_64      16.12.2-1.fc24        updates      766 k
 kontact-libs      x86_64      16.12.2-1.fc24        updates       92 k
 korganizer        x86_64      16.12.2-1.fc24        updates      732 k
 korganizer-libs   x86_64      16.12.2-1.fc24        updates      795 k

Transaction Summary
=========================================================================
Skip  19 Packages

Nothing to do.
Complete!

Comment 7 Fedora Update System 2017-03-11 11:50:43 UTC
kdepim-16.12.2-3.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 8 kevin 2017-03-11 22:30:17 UTC
KMail will not start because Akonadi will not start

$ akonadictl start
/usr/bin/mysqladmin: connect to server at 'localhost' failed

error: 'Can't connect to local MySQL server through socket '/tmp/akonadi-kmg.pbmcxO/mysql.socket' (111 "Connection refused")'

Check that mysqld is running and that the socket: '/tmp/akonadi-kmg.pbmcxO/mysql.socket' exists!


Note You need to log in before you can comment on or make changes to this bug.