Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1430590 - KMail will not start
Summary: KMail will not start
Keywords:
Status: CLOSED DUPLICATE of bug 1430177
Alias: None
Product: Fedora
Classification: Fedora
Component: kmail
Version: 24
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Rex Dieter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-03-09 02:45 UTC by kevin
Modified: 2017-03-09 13:08 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-03-09 11:36:31 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)

Description kevin 2017-03-09 02:45:16 UTC
User-Agent:       Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/56.0.2924.87 Safari/537.36
Build Identifier: 

KMail fails with

kmail: relocation error: /lib64/libKF5Gpgmepp-pthread.so.5: symbol gpgme_pubkey_algo_string, version GPGME_1.1 not defined in file libgpgme.so.11 with link time reference


Reproducible: Always

Steps to Reproduce:
1. Just type kmail
Actual Results:  
kmail: relocation error: /lib64/libKF5Gpgmepp-pthread.so.5: symbol gpgme_pubkey_algo_string, version GPGME_1.1 not defined in file libgpgme.so.11 with link time reference


Expected Results:  
n/a

Fully up-to-date software (dnf update performed just prior to last test)

Comment 1 kevin 2017-03-09 02:46:34 UTC
...and reboot after the "dnf update"

Comment 2 Frank Danapfel 2017-03-09 08:13:53 UTC
Having the same issue, looks like this is due to some broken dependencies:

$ cat /etc/redhat-release
Fedora release 24 (Twenty Four)

$ /usr/bin/kmail                                                                                                                                                                                
/usr/bin/kmail: relocation error: /lib64/libKF5Gpgmepp-pthread.so.5: symbol gpgme_pubkey_algo_string, version GPGME_1.1 not defined in file libgpgme.so.11 with link time reference

$ rpm -q gpgme
gpgme-1.6.0-3.fc24.x86_64

$ rpm -ql gpgme
/usr/lib64/libgpgme-pthread.so.11
/usr/lib64/libgpgme-pthread.so.11.14.0
/usr/lib64/libgpgme.so.11
/usr/lib64/libgpgme.so.11.14.0
/usr/share/doc/gpgme
/usr/share/doc/gpgme/AUTHORS
/usr/share/doc/gpgme/ChangeLog
/usr/share/doc/gpgme/NEWS
/usr/share/doc/gpgme/README
/usr/share/doc/gpgme/THANKS
/usr/share/doc/gpgme/TODO
/usr/share/doc/gpgme/VERSION
/usr/share/licenses/gpgme
/usr/share/licenses/gpgme/COPYING
/usr/share/licenses/gpgme/COPYING.LESSER

$ sudo dnf update -b gpgme
Last metadata expiration check: 0:00:57 ago on Thu Mar  9 08:48:03 2017.                                                                                                                                          
Error: package knode-libs-4.14.10-24.fc24.x86_64 requires libgpgme-pthread.so.11()(64bit), but none of the providers can be installed                                                                             
(try to add '--allowerasing' to command line to replace conflicting packages)                                                                                                                         

$ rpm -q knode-libs
knode-libs-4.14.10-24.fc24.x86_64

$ sudo dnf update -b knode-libs
[sudo] password for frank: 
Last metadata expiration check: 0:19:35 ago on Thu Mar  9 08:48:03 2017.
Dependencies resolved.
Nothing to do.
Complete!


Trying to update the kmail package itself leads to another set of dependency errors:                                                                                                                                                                                                                                  
$ sudo dnf update -b kmail
Last metadata expiration check: 0:00:39 ago on Thu Mar  9 08:48:03 2017.                                                                                                                                          
Error: package kmail-16.12.2-1.fc24.x86_64 requires akonadi-import-wizard >= 16.12, but none of the providers can be installed                                                                                    
(try to add '--allowerasing' to command line to replace conflicting packages)
                                 
$ rpm -q akonadi-import-wizard                                                                                                                                                                  
package akonadi-import-wizard is not installed 
                                                                                                                                                                
$ sudo dnf install akonadi-import-wizard
Last metadata expiration check: 0:01:50 ago on Thu Mar  9 08:48:03 2017.                                                                                                                                          
Error: package akonadi-import-wizard-16.12.2-1.fc24.x86_64 conflicts with kdepim-common < 16.12 provided by kdepim-common-16.08.3-2.fc24.x86_64                                                                   
(try to add '--allowerasing' to command line to replace conflicting packages)

$ rpm -q kdepim-common
kdepim-common-16.08.3-2.fc24.x86_64

$ sudo dnf update -b kdepim-common
Last metadata expiration check: 0:13:29 ago on Thu Mar  9 08:48:03 2017.
Dependencies resolved.
Nothing to do.
Complete!


There is currently a whole bunch of KDE packages that can't be updated on Fedora 24 due to dependency issues:                                                                                     
$ sudo dnf update
Dependencies resolved.
==================================================================================================================================================================================================================
 Package                                                 Arch                                         Version                                                 Repository                                     Size
==================================================================================================================================================================================================================
Skipping packages with broken dependencies:
 akregator                                               x86_64                                       16.12.2-1.fc24                                          updates                                       677 k
 akregator-libs                                          x86_64                                       16.12.2-1.fc24                                          updates                                       560 k
 gpgme                                                   x86_64                                       1.8.0-10.fc24                                           updates                                       196 k
 kaddressbook                                            x86_64                                       16.12.2-1.fc24                                          updates                                        80 k
 kaddressbook-libs                                       x86_64                                       16.12.2-1.fc24                                          updates                                       151 k
 kdepim-addons                                           x86_64                                       16.12.2-1.fc24                                          updates                                       1.0 M
 kdepim-apps-libs                                        x86_64                                       16.12.2-1.fc24                                          updates                                       159 k
 kf5-libkleo                                             x86_64                                       16.12.2-1.fc24                                          updates                                       364 k
 kf5-mailcommon                                          x86_64                                       16.12.2-1.fc24                                          updates                                       518 k
 kf5-messagelib                                          x86_64                                       16.12.2-1.fc24                                          updates                                       5.2 M
 kleopatra                                               x86_64                                       16.12.2-1.fc24                                          updates                                       1.4 M
 kleopatra-libs                                          x86_64                                       16.12.2-1.fc24                                          updates                                        93 k
 kmail                                                   x86_64                                       16.12.2-1.fc24                                          updates                                       1.5 M
 kmail-libs                                              x86_64                                       16.12.2-1.fc24                                          updates                                       940 k
 knotes-libs                                             x86_64                                       16.12.2-1.fc24                                          updates                                       243 k
 kontact                                                 x86_64                                       16.12.2-1.fc24                                          updates                                       766 k
 kontact-libs                                            x86_64                                       16.12.2-1.fc24                                          updates                                        92 k
 korganizer                                              x86_64                                       16.12.2-1.fc24                                          updates                                       732 k
 korganizer-libs                                         x86_64                                       16.12.2-1.fc24                                          updates                                       795 k

Transaction Summary
==================================================================================================================================================================================================================
Skip  19 Packages

Nothing to do.
Complete!

Comment 3 Than Ngo 2017-03-09 10:54:18 UTC
Rex, i think rebuild kf5-gpgmepp against gpgme should fix this issue.

Comment 4 Frank Danapfel 2017-03-09 11:15:50 UTC
(In reply to Ngo Than from comment #3)
> Rex, i think rebuild kf5-gpgmepp against gpgme should fix this issue.

Sorry, doesn't help: 
$ ll
total 128
-rw-rw-r--. 1 frank frank 129706 Mär  9 12:05 kf5-gpgmepp-16.08.3-4.fc24.x86_64.rpm

$ sudo dnf install kf5-gpgmepp-16.08.3-4.fc24.x86_64.rpm
Last metadata expiration check: 3:18:06 ago on Thu Mar  9 08:48:03 2017.
Dependencies resolved.
==================================================================================================================================================================================================================
 Package                                            Arch                                          Version                                               Repository                                           Size 
==================================================================================================================================================================================================================
Upgrading:                                                                                                                                                                                                        
 kf5-gpgmepp                                        x86_64                                        16.08.3-4.fc24                                        @commandline                                        127 k 
                                                                                                                                                                                                                  
Transaction Summary                                                                                                                                                                                               
==================================================================================================================================================================================================================
Upgrade  1 Package                                                                                                                                                                                                
                                                                                                                                                                                                                  
Total size: 127 k                                                                                                                                                                                                 
Is this ok [y/N]: y                                                                                                                                                                                               
Downloading Packages:                                                                                                                                                                                             
Running transaction check                                                                                                                                                                                         
Transaction check succeeded.                                                                                                                                                                                      
Running transaction test                                                                                                                                                                                          
Transaction test succeeded.                                                                                                                                                                                       
Running transaction                                                                                                                                                                                               
  Upgrading   : kf5-gpgmepp-16.08.3-4.fc24.x86_64                                                                                                                                                             1/2 
  Cleanup     : kf5-gpgmepp-16.08.3-3.fc24.x86_64                                                                                                                                                             2/2 
  Verifying   : kf5-gpgmepp-16.08.3-4.fc24.x86_64                                                                                                                                                             1/2 
  Verifying   : kf5-gpgmepp-16.08.3-3.fc24.x86_64                                                                                                                                                             2/2 
                                                                                                                                                                                                                  
Upgraded:                                                                                                                                                                                                         
  kf5-gpgmepp.x86_64 16.08.3-4.fc24                                                                                                                                                                               
                                                                                                                                                                                                                  
Complete!                                                                                                                                                                                                         

$ /usr/bin/kmail
/usr/bin/kmail: relocation error: /lib64/libKF5Gpgmepp-pthread.so.5: symbol gpgme_pubkey_algo_string, version GPGME_1.1 not defined in file libgpgme.so.11 with link time reference

$ rpm -q kf5-gpgmepp 
kf5-gpgmepp-16.08.3-4.fc24.x86_64

$ rpm -q kmail
kmail-16.08.3-2.fc24.x86_64

$ rpm -q gpgme
gpgme-1.6.0-3.fc24.x86_64

Comment 5 Rex Dieter 2017-03-09 11:34:31 UTC
What was included in the last update doesn't match the versioned you posted above, which is likely at least part of the problem here.

This update
https://bodhi.fedoraproject.org/updates/FEDORA-2017-9f83ba7048
includes:

gpgme-1.8.0-10.fc24
kf5-gpgmepp-16.08.3-3.fc24
kmail-16.12.2-1.fc24


Interestingly, you just manually installed a kf5-gpgmepp-16.08.3-4.fc24, which I'm not sure where that came from.

Comment 6 Rex Dieter 2017-03-09 11:36:31 UTC
Anyway, some users reported updates being held back, which should be resolved by the following 2 updates currently in -testing:

kdepim:
https://bodhi.fedoraproject.org/updates/FEDORA-2017-81bed9e1d4

kdepim4:
https://bodhi.fedoraproject.org/updates/FEDORA-2017-daa782e4a0

*** This bug has been marked as a duplicate of bug 1430177 ***

Comment 7 Frank Danapfel 2017-03-09 12:20:45 UTC
(In reply to Rex Dieter from comment #5)
> What was included in the last update doesn't match the versioned you posted
> above, which is likely at least part of the problem here.
> 
> This update
> https://bodhi.fedoraproject.org/updates/FEDORA-2017-9f83ba7048
> includes:
> 
> gpgme-1.8.0-10.fc24
> kf5-gpgmepp-16.08.3-3.fc24
> kmail-16.12.2-1.fc24

As mentioned before dnf refuses to install those updated versions, at least for gpgme and kmail due to broken dependencies.

> Interestingly, you just manually installed a kf5-gpgmepp-16.08.3-4.fc24,
> which I'm not sure where that came from.

Sorry, should have mentioned that I've been in contact with Than and he provided a scratch build of kf5-gpgmepp to test if this fixes the issue:
https://koji.fedoraproject.org/koji/taskinfo?taskID=18276533

Comment 8 Rex Dieter 2017-03-09 12:26:32 UTC
I'm guessing than's scratch build is "broken" the same as kf5-gpgmepp-16.08.3-3.fc24.  They're both built against gpgme-1.8.0, and essentially require gpgme-1.8.0, but you still have the older gpgme-1.6.0 installed.

Unfortunately, rpm's automatic rpm dependency generation doesn't enforce that properly in this case (and arguably gpgme upstream broke ABI).  I'll look into enforcing that via manual means.


In the meantime, the broken dependencies you mention should be fixed in the updates I referenced in comment #6

Comment 9 Frank Danapfel 2017-03-09 12:39:29 UTC
OK, after running the update again with the "updates-testing" repo enabled kmail is working again:

$ sudo dnf update --enablerepo=updates-testing kdepim*
Last metadata expiration check: 0:00:17 ago on Thu Mar  9 13:34:53 2017.
Dependencies resolved.
==================================================================================================================================================================================================================
 Package                                                      Arch                                    Version                                              Repository                                        Size
==================================================================================================================================================================================================================
Installing:
 akonadi-import-wizard                                        x86_64                                  16.12.2-1.fc24                                       updates                                          398 k
 gpgmepp                                                      x86_64                                  1.8.0-10.fc24                                        updates                                          102 k
 grantlee-editor                                              x86_64                                  16.12.2-1.fc24                                       updates                                          141 k
 grantlee-editor-libs                                         x86_64                                  16.12.2-1.fc24                                       updates                                           45 k
 kmail-account-wizard                                         x86_64                                  16.12.2-1.fc24                                       updates                                          454 k
 pim-data-exporter                                            x86_64                                  16.12.2-1.fc24                                       updates                                          140 k
 pim-data-exporter-libs                                       x86_64                                  16.12.2-1.fc24                                       updates                                          162 k
 pim-sieve-editor                                             x86_64                                  16.12.2-1.fc24                                       updates                                          390 k
 pim-storage-service-manager                                  x86_64                                  16.12.2-1.fc24                                       updates                                           97 k
 qgpgme                                                       x86_64                                  1.8.0-10.fc24                                        updates                                          212 k
Upgrading:
 akregator                                                    x86_64                                  16.12.2-1.fc24                                       updates                                          677 k
 akregator-libs                                               x86_64                                  16.12.2-1.fc24                                       updates                                          560 k
 gpgme                                                        x86_64                                  1.8.0-10.fc24                                        updates                                          196 k
 kaddressbook                                                 x86_64                                  16.12.2-1.fc24                                       updates                                           80 k
 kaddressbook-libs                                            x86_64                                  16.12.2-1.fc24                                       updates                                          151 k
 kdepim-addons                                                x86_64                                  16.12.2-1.fc24                                       updates                                          1.0 M
 kdepim-apps-libs                                             x86_64                                  16.12.2-1.fc24                                       updates                                          159 k
 kdepim-common                                                x86_64                                  7:16.12.2-3.fc24                                     updates-testing                                  7.8 k
     replacing  kdepim-libs.x86_64 7:16.08.3-2.fc24
 kf5-libkleo                                                  x86_64                                  16.12.2-1.fc24                                       updates                                          364 k
 kf5-mailcommon                                               x86_64                                  16.12.2-1.fc24                                       updates                                          518 k
 kf5-messagelib                                               x86_64                                  16.12.2-1.fc24                                       updates                                          5.2 M
 kleopatra                                                    x86_64                                  16.12.2-1.fc24                                       updates                                          1.4 M
 kleopatra-libs                                               x86_64                                  16.12.2-1.fc24                                       updates                                           93 k
 kmail                                                        x86_64                                  16.12.2-1.fc24                                       updates                                          1.5 M
 kmail-libs                                                   x86_64                                  16.12.2-1.fc24                                       updates                                          940 k
 knode                                                        x86_64                                  4.14.10-27.fc24                                      updates-testing                                  1.2 M
 knode-libs                                                   x86_64                                  4.14.10-27.fc24                                      updates-testing                                  4.1 M
 kontact                                                      x86_64                                  16.12.2-1.fc24                                       updates                                          766 k
 kontact-libs                                                 x86_64                                  16.12.2-1.fc24                                       updates                                           92 k
 korganizer                                                   x86_64                                  16.12.2-1.fc24                                       updates                                          732 k
 korganizer-libs                                              x86_64                                  16.12.2-1.fc24                                       updates                                          795 k

Transaction Summary
==================================================================================================================================================================================================================
Install  10 Packages
Upgrade  21 Packages

Total download size: 22 M
Is this ok [y/N]: y
...
Installed:
  akonadi-import-wizard.x86_64 16.12.2-1.fc24              gpgmepp.x86_64 1.8.0-10.fc24                   grantlee-editor.x86_64 16.12.2-1.fc24               grantlee-editor-libs.x86_64 16.12.2-1.fc24       
  kmail-account-wizard.x86_64 16.12.2-1.fc24               pim-data-exporter.x86_64 16.12.2-1.fc24        pim-data-exporter-libs.x86_64 16.12.2-1.fc24        pim-sieve-editor.x86_64 16.12.2-1.fc24           
  pim-storage-service-manager.x86_64 16.12.2-1.fc24        qgpgme.x86_64 1.8.0-10.fc24                   

Upgraded:
  akregator.x86_64 16.12.2-1.fc24          akregator-libs.x86_64 16.12.2-1.fc24      gpgme.x86_64 1.8.0-10.fc24               kaddressbook.x86_64 16.12.2-1.fc24    kaddressbook-libs.x86_64 16.12.2-1.fc24   
  kdepim-addons.x86_64 16.12.2-1.fc24      kdepim-apps-libs.x86_64 16.12.2-1.fc24    kdepim-common.x86_64 7:16.12.2-3.fc24    kf5-libkleo.x86_64 16.12.2-1.fc24     kf5-mailcommon.x86_64 16.12.2-1.fc24      
  kf5-messagelib.x86_64 16.12.2-1.fc24     kleopatra.x86_64 16.12.2-1.fc24           kleopatra-libs.x86_64 16.12.2-1.fc24     kmail.x86_64 16.12.2-1.fc24           kmail-libs.x86_64 16.12.2-1.fc24          
  knode.x86_64 4.14.10-27.fc24             knode-libs.x86_64 4.14.10-27.fc24         kontact.x86_64 16.12.2-1.fc24            kontact-libs.x86_64 16.12.2-1.fc24    korganizer.x86_64 16.12.2-1.fc24          
  korganizer-libs.x86_64 16.12.2-1.fc24   

Complete!

$ /usr/bin/kmail
this does not work on a KActionCollection containing actions!
"Tag 'a' is not defined in message {<__kuit_internal_top__>KMail has many powerful features that are described in th...}."
"Tag 'br' is not defined in message {<__kuit_internal_top__>Thank you,<br/>The KMail Team</__kuit_internal_top__>}."

Thanks a lot for the quick help with this!

Comment 10 Rex Dieter 2017-03-09 12:40:40 UTC
you're welcome (and sorry again for the broken deps in the first place)

Comment 11 Frank Danapfel 2017-03-09 13:08:37 UTC
(In reply to Rex Dieter from comment #10)
> you're welcome (and sorry again for the broken deps in the first place)

No worries! This gave me a chance to brush up on dnf, rpm dependencies etc, so it was a good learning experience :)


Note You need to log in before you can comment on or make changes to this bug.