Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1431374 - python-mwlib ftbfs on current rawhide
Summary: python-mwlib ftbfs on current rawhide
Keywords:
Status: CLOSED DUPLICATE of bug 1424168
Alias: None
Product: Fedora
Classification: Fedora
Component: python-mwlib
Version: 27
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Ian Weller
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-03-11 20:36 UTC by Zbigniew Jędrzejewski-Szmek
Modified: 2018-03-15 00:14 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-03-15 00:14:02 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Zbigniew Jędrzejewski-Szmek 2017-03-11 20:36:21 UTC
Description of problem:

+ PYTHONPATH=/builddir/build/BUILDROOT/python-mwlib-0.15.14-7.fc27.x86_64/usr/lib64/python2.7/site-packages
+ py.test-2.7 -v tests/ --ignore tests/test_nserve.py --ignore tests/test_redirect.py --ignore tests/test_zipwiki.py --ignore tests/test_nuwiki.py -k 'not test_codes and not test_time_minus_days'
============================= test session starts ==============================
platform linux2 -- Python 2.7.13, pytest-3.0.6, py-1.4.32, pluggy-0.4.0 -- /usr/bin/python2
cachedir: .cache
rootdir: /builddir/build/BUILD/mwlib-0.15.14, inifile: 
collecting ... collected 712 items / 2 errors

==================================== ERRORS ====================================
___________________ ERROR collecting tests/test_odfwriter.py ___________________
tests/test_odfwriter.py:49: in <module>
    odflint = _get_odflint_module()
tests/test_odfwriter.py:31: in _get_odflint_module
    assert exe is not None, "odflint not found"
E   AssertionError: odflint not found
E   assert None is not None
___________________ ERROR collecting tests/test_timeline.py ____________________
Using pytest.skip outside of a test is not allowed. If you are trying to decorate a test function, use the @pytest.mark.skip or @pytest.mark.skipif decorators instead.
============================ pytest-warning summary ============================
WC1 None pytest_funcarg__alarm: declaring fixtures using "pytest_funcarg__" prefix is deprecated and scheduled to be removed in pytest 4.0.  Please remove the prefix and use the @pytest.fixture decorator instead.
WC1 /builddir/build/BUILD/mwlib-0.15.14/tests/test_expander.py yield tests are deprecated, and scheduled to be removed in pytest 4.0
...
WC1 /builddir/build/BUILD/mwlib-0.15.14/tests/test_uniq.py yield tests are deprecated, and scheduled to be removed in pytest 4.0
WC1 /builddir/build/BUILD/mwlib-0.15.14/tests/test_uniq.py yield tests are deprecated, and scheduled to be removed in pytest 4.0
WC1 /builddir/build/BUILD/mwlib-0.15.14/tests/test_uniq.py yield tests are deprecated, and scheduled to be removed in pytest 4.0
!!!!!!!!!!!!!!!!!!! Interrupted: 2 errors during collection !!!!!!!!!!!!!!!!!!!!
============================= 46 tests deselected ==============================
========= 46 deselected, 296 pytest-warnings, 2 error in 1.31 seconds ==========



Version-Release number of selected component (if applicable):
python-mwlib-0.15.14-6.fc27.src.rpm

Comment 1 Jan Kurik 2017-08-15 08:27:44 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 27 development cycle.
Changing version to '27'.

Comment 2 Zbigniew Jędrzejewski-Szmek 2018-03-15 00:14:02 UTC

*** This bug has been marked as a duplicate of bug 1424168 ***


Note You need to log in before you can comment on or make changes to this bug.