Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1431404 - .docx files have started extracting instead of opening when double-clicked
Summary: .docx files have started extracting instead of opening when double-clicked
Keywords:
Status: CLOSED DUPLICATE of bug 1430928
Alias: None
Product: Fedora
Classification: Fedora
Component: nautilus
Version: 25
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Matthias Clasen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-03-12 04:50 UTC by Robert Hancock
Modified: 2017-03-14 10:04 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-03-14 10:04:32 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Robert Hancock 2017-03-12 04:50:45 UTC
Description of problem:
Recently when double-clicking on docx files it has started defaulting to extracting the .zip contents of the document rather than opening it in LibreOffice. I'm not sure if this is a LibreOffice problem, but it's the only thing that has updated recently that seems likely to be relevant as far as I can tell.

Version-Release number of selected component (if applicable):
libreoffice-writer-5.2.6.2-3.fc25.x86_64

How reproducible:
Every time

Steps to Reproduce:
1. Double-click a .docx file in Files (Nautilus)
2.
3.

Actual results:
Raw contents of .docx file are extracted into a folder

Expected results:
Document opens in LibreOffice

Additional info:
Under "Open With", it shows LibreOffice Writer as the default application but the top option when right-clicking the file, and the default when double-clicking, is still to extract it.

Comment 1 Caolan McNamara 2017-03-13 11:30:43 UTC
Works for me out of the box with libreoffice-5.2.6.2-3 and nautilus-3.22.3-1

Comment 2 Vincent Gournay 2017-03-14 02:06:40 UTC
I have the same problem. Maybe the file browser is looking at the mime type instead of the extension to find which application opens the file?
docx files contain a zip header

Comment 3 Caolan McNamara 2017-03-14 09:47:09 UTC
well, I can't reproduce it, lets move it to the application which is the one in question

Comment 4 Kalev Lember 2017-03-14 10:04:32 UTC
This regressed with gnome-autoar 0.2.1.

*** This bug has been marked as a duplicate of bug 1430928 ***


Note You need to log in before you can comment on or make changes to this bug.