Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1434380 - Fedora-Live-26 fails: dracut-pre-udev: rpcbind:/run/rpcbind/rpcbind.lock No such file or directory
Summary: Fedora-Live-26 fails: dracut-pre-udev: rpcbind:/run/rpcbind/rpcbind.lock No s...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: dracut
Version: 26
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: dracut-maint-list
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-03-21 12:08 UTC by Ralf Corsepius
Modified: 2017-09-06 20:59 UTC (History)
5 users (show)

Fixed In Version: rpcbind-0.2.4-5.fc25
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-09-06 20:59:32 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Ralf Corsepius 2017-03-21 12:08:06 UTC
Description of problem:

Testing Fedora-Workstation-Live-i386-26-20170320.n.0.iso
fails with 
dracut-pre-udev: rpcbind:/run/rpcbind/rpcbind.lock No such file or directory

Version-Release number of selected component (if applicable):
Fedora-Workstation-Live-i386-26-20170320.n.0.iso

How reproducible:
Always

Steps to Reproduce:
1. d/l Fedora-Workstation-Live-i386-26-20170320.n.0.iso and put it on a USB stick
2. boot from USB-stick
3. Select "Start Fedora 26 Workstation Live"

Actual results:
The message above is being printed out, then the system hangs.

Expected results:
Function.

Additional info:
- I only tried on an i386 system with BIOS. 
No idea if this also happens on x86_64 and/or UEFI systems.

- I have been observing this issue with previous Fedora-Workstation-Live-i386-26*.isos before.

- No idea about the actual origin of this defect - dracut, rpmbind, glibc or gcc?.

Comment 1 Fedora Update System 2017-03-21 17:25:39 UTC
rpcbind-0.2.4-5.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-66c84b1ba8

Comment 2 Fedora Update System 2017-03-21 17:26:18 UTC
rpcbind-0.2.4-6.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-5c5fcde1a0

Comment 3 Fedora Update System 2017-03-22 15:27:45 UTC
rpcbind-0.2.4-6.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-5c5fcde1a0

Comment 4 Fedora Update System 2017-03-22 20:21:44 UTC
rpcbind-0.2.4-5.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-66c84b1ba8

Comment 5 Fedora Update System 2017-03-24 18:56:07 UTC
rpcbind-0.2.4-5.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Comment 6 Ralf Corsepius 2017-03-25 04:54:30 UTC
No improvments.
Fedora-Workstation-Live-i386-26-20170324.n.0.iso still exposes this issue.

Comment 7 Steve Dickson 2017-03-25 21:55:14 UTC
(In reply to Ralf Corsepius from comment #6)
> No improvments.
> Fedora-Workstation-Live-i386-26-20170324.n.0.iso still exposes this issue.

Because dracut-pre-udev is broken! The script needs to do a
systemd-tmpfiles --create rpcbind.conf before it start rpcbind

but rpcbind-0.2.4-6.fc26 fixes the problem

Comment 8 Ralf Corsepius 2017-03-27 07:11:37 UTC
(In reply to Steve Dickson from comment #7)
> (In reply to Ralf Corsepius from comment #6)
> > No improvments.
> > Fedora-Workstation-Live-i386-26-20170324.n.0.iso still exposes this issue.
> 
> Because dracut-pre-udev is broken!
Why are you closing this BZ?

It could be true rpcbind-0.2.4-6.fc26 fixes this problem and it might be true dracut needs additional fixing, but all in all this bug is NOT fixed.

Fedora-Workstation-Live-i386-26-20170326.n.0.iso
still is exposes this issue.

Comment 9 Fedora Update System 2017-04-01 17:24:11 UTC
rpcbind-0.2.4-6.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Comment 10 Lukas Bezdicka 2017-09-06 13:26:43 UTC
Still hitting this on 1.5 isos from https://getfedora.org/en/workstation/download/

Fixing packages isn't enough, please respin.

Comment 11 Steve Dickson 2017-09-06 20:59:32 UTC
I'm think this problem is fixed with rpcbind-0.2.4-8.rc2


Note You need to log in before you can comment on or make changes to this bug.