Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1441497 - Please upgrade to upstream version
Summary: Please upgrade to upstream version
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: graphite-web
Version: epel7
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Piotr Popieluch
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-04-12 06:18 UTC by lionel.cons
Modified: 2017-05-13 02:20 UTC (History)
4 users (show)

Fixed In Version: graphite-web-0.9.16-1.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-05-03 02:25:43 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description lionel.cons 2017-04-12 06:18:19 UTC
New upstream versions have been released.

Could you please upgrade graphite-web to 1.0.0 if possible or to the last 0.x version (0.9.16) otherwise?

Thanks!

Comment 1 Piotr Popieluch 2017-04-13 09:46:42 UTC
I think it would take quite some effort to get 1.0.0 in epel7 because of the requirement on a newer Django. There have been some attempts to get a newer Django in epel7 but I think nobody has stepped up to actually do it as it would take quite some time and effort. EPEL's long support lifetime is also keeping packagers from adding a newer Django. Other way would be to release a 1.0.0 with reverted Django commits. I don't know if that would work and it feels a bit backwards.

Updating EPEL7 to 0.9.6 should be no problem. I'll try to get a build in testing this week.

FYI:
epel6: have not checked if we can update to 0.9.6
Fedora: is already on a version from master branch for quite some time, will update to 1.0.0

Comment 2 Piotr Popieluch 2017-04-13 09:55:05 UTC
(In reply to Piotr Popieluch from comment #1)
 
> Updating EPEL7 to 0.9.6 should be no problem. I'll try to get a build in
> testing this week.
> 
> FYI:
> epel6: have not checked if we can update to 0.9.6

Obviously, I meant 0.9.16.

Comment 3 Fedora Update System 2017-04-15 17:37:50 UTC
graphite-web-0.9.16-1.el7 python-carbon-0.9.16-1.el7 python-whisper-0.9.16-1.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-c73dcc4d2a

Comment 4 Fedora Update System 2017-04-15 18:02:54 UTC
python-carbon-0.9.16-1.el6 python-whisper-0.9.16-1.el6 graphite-web-0.9.16-1.el6 has been submitted as an update to Fedora EPEL 6. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-25ada57c8d

Comment 5 Fedora Update System 2017-04-16 00:17:38 UTC
graphite-web-0.9.16-1.el6, python-carbon-0.9.16-1.el6, python-whisper-0.9.16-1.el6 has been pushed to the Fedora EPEL 6 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-25ada57c8d

Comment 6 Fedora Update System 2017-04-16 00:19:47 UTC
graphite-web-0.9.16-1.el7, python-carbon-0.9.16-1.el7, python-whisper-0.9.16-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-c73dcc4d2a

Comment 7 Matthias Runge 2017-04-24 14:13:11 UTC
Version 1.0.0 requires django 1.9, which is not LTS. I would recommend not to upgrade to that version.

Comment 8 Piotr Popieluch 2017-04-24 16:15:54 UTC
(In reply to Matthias Runge from comment #7)
> Version 1.0.0 requires django 1.9, which is not LTS. I would recommend not
> to upgrade to that version.

Yep, noticed that. 

Would make more sense to get graphite-web working with 1.8 LTS and update Django to 1.8 in epel7.

Or make graphite-web work with Django 1.11 LTS and add a python-django1-dot-11 as a new package in epel7.

Anyway, I don't plan on doing either for now.

Comment 9 Fedora Update System 2017-05-03 02:25:43 UTC
graphite-web-0.9.16-1.el7, python-carbon-0.9.16-1.el7, python-whisper-0.9.16-1.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2017-05-13 02:20:22 UTC
graphite-web-0.9.16-1.el6, python-carbon-0.9.16-1.el6, python-whisper-0.9.16-1.el6 has been pushed to the Fedora EPEL 6 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.