Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1445286 - Urlwatch requires python3-minidb, but nothing provides it
Summary: Urlwatch requires python3-minidb, but nothing provides it
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: urlwatch
Version: rawhide
Hardware: All
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Fabian Affolter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: python-minidb
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-04-25 12:34 UTC by Göran Uddeborg
Modified: 2017-06-09 19:01 UTC (History)
2 users (show)

Fixed In Version: urlwatch-2.6-4.fc25 urlwatch-2.6-4.fc26
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-06-05 00:02:43 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Göran Uddeborg 2017-04-25 12:34:01 UTC
Description of problem:
I tried to install urlwatch on a F26 system, but dnf told me this:

  - nothing provides python3-minidb needed by urlwatch-2.6-3.fc26.noarch


Version-Release number of selected component (if applicable):
urlwatch-2.6-3.fc26.noarch


How reproducible:
Every time


Steps to Reproduce:
1. dnf install urlwatch


Actual results:
The above error message.


Expected results:
A successfully installed urlwatch, with any necessary dependencies.


Additional info:
I searched in bodhi and koji, but couldn't find any python3-minidb package or similar.  I tried to force the installation of urlwatch, with all other dependencies met.  But then i fails when it tries to import minidb, so the dependency is apparently real.

Comment 1 Andre Robatino 2017-05-06 09:27:34 UTC
Just noting that this is broken in both F26 and Rawhide. I changed the version to Rawhide since that's the highest broken version, and added FutureFeature to keep it from being automatically changed (hopefully it won't take that long to fix, presumably the F26 repo needs to be free of broken deps before release, I don't know exactly when that's supposed to happen).

Comment 2 Fedora Update System 2017-05-18 10:15:20 UTC
urlwatch-2.6-4.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-950d4fe647

Comment 3 Fedora Update System 2017-05-18 13:36:02 UTC
urlwatch-2.6-4.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-d20834bda7

Comment 4 Fedora Update System 2017-05-18 19:04:47 UTC
urlwatch-2.6-4.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-950d4fe647

Comment 5 Fedora Update System 2017-05-20 01:05:42 UTC
urlwatch-2.6-4.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-d20834bda7

Comment 6 Fedora Update System 2017-06-05 00:02:43 UTC
urlwatch-2.6-4.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Comment 7 Fedora Update System 2017-06-09 19:01:32 UTC
urlwatch-2.6-4.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.