Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1446927 - Review Request: rubygem-native-package-installer - Native packages installation helper
Summary: Review Request: rubygem-native-package-installer - Native packages installati...
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: Package Review
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: František Dvořák
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-04-30 15:16 UTC by Mamoru TASAKA
Modified: 2017-05-03 15:20 UTC (History)
2 users (show)

Fixed In Version: rubygem-native-package-installer-1.0.1-1.fc27
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-05-03 15:20:21 UTC
Type: ---
Embargoed:
valtri: fedora-review+


Attachments (Terms of Use)

Description Mamoru TASAKA 2017-04-30 15:16:36 UTC
Spec URL: https://mtasaka.fedorapeople.org/Review_request/gem-related/rubygem-native-package-installer.spec

SRPM URL: https://mtasaka.fedorapeople.org/Review_request/gem-related/rubygem-native-package-installer-1.0.0-1.fc.src.rpm

Description: 
Users need to install native packages to install an extension library
that depends on native packages. It bores users because users need to
install native packages and an extension library separately.
native-package-installer helps to install native packages on "gem install".
Users can install both native packages and an extension library by one action,
"gem install".

Fedora Account System Username: mtasaka

Koji scratch build:
F-27: https://koji.fedoraproject.org/koji/taskinfo?taskID=19324908
F-26: https://koji.fedoraproject.org/koji/taskinfo?taskID=19324905

Comment 1 František Dvořák 2017-05-03 10:53:13 UTC
Some cosmetics/questions:

* Package contains BuildRequires: ruby(release)

It is probably not needed? But it's OK - guidelines doesn't mention nor discourage it and it is generated by gem2rpm.

* New version 1.0.1 has been released right now

* Function is OK

ruby -rnative-package-installer -e 'p NativePackageInstaller::ExecutableFinder::new("service").find'

Package APPROVED!

Comment 2 Mamoru TASAKA 2017-05-03 12:50:10 UTC
Okay, thank you! I will update version later.

Comment 3 Gwyn Ciesla 2017-05-03 13:13:10 UTC
Package request has been approved: https://admin.fedoraproject.org/pkgdb/package/rpms/rubygem-native-package-installer

Comment 4 Mamoru TASAKA 2017-05-03 15:20:21 UTC
Thank you for review! Closing.


Note You need to log in before you can comment on or make changes to this bug.