Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1450641 - FTBFS: Test suite fails on arm
Summary: FTBFS: Test suite fails on arm
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnupg
Version: 26
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Brian Lane
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1423631 (view as bug list)
Depends On:
Blocks: F26FTBFS
TreeView+ depends on / blocked
 
Reported: 2017-05-14 10:24 UTC by Tomas Tomecek
Modified: 2017-07-25 00:24 UTC (History)
5 users (show)

Fixed In Version: gnupg-1.4.21-4.fc26 gnupg-1.4.22-1.fc26
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-07-24 19:22:10 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)
Test sute failure (4.17 KB, text/plain)
2017-05-14 10:24 UTC, Tomas Tomecek
no flags Details

Description Tomas Tomecek 2017-05-14 10:24:55 UTC
Created attachment 1278613 [details]
Test sute failure

https://koji.fedoraproject.org/koji/taskinfo?taskID=19537971

I checked latest build in koji and arm build succeeded so I'm not sure what's going on here. 


Snippet:

PASS: version.test
PASS: mds.test
PASS: decrypt.test
PASS: decrypt-dsa.test
MD5 SHA1 RIPEMD160 SHA256 SHA384 SHA512 SHA224 | PASS: sigs.test
PASS: sigs-dsa.test
FAIL: encrypt.test
FAIL: encrypt-dsa.test
FAIL: seat.test
PASS: clearsig.test
FAIL: encryptp.test
PASS: detach.test
PASS: armsigs.test
FAIL: armencrypt.test
FAIL: armencryptp.test
FAIL: signencrypt.test
FAIL: signencrypt-dsa.test
FAIL: armsignencrypt.test
PASS: armdetach.test
PASS: armdetachm.test
PASS: detachm.test
FAIL: genkey1024.test
IDEA 3DES CAST5 BLOWFISH AES AES192 AES256 TWOFISH CAMELLIA128 CAMELLIA192 CAMELLIA256 | PASS: conventional.test
IDEA 3DES CAST5 BLOWFISH AES AES192 AES256 TWOFISH CAMELLIA128 CAMELLIA192 CAMELLIA256 | PASS: conventional-mdc.test
PASS: multisig.test
PASS: verify.test
PASS: armor.test

Comment 1 Brian Lane 2017-05-15 15:22:35 UTC
This is being caused by bug 1424619 in GCC.

Comment 2 Brian Lane 2017-05-15 16:49:53 UTC
Fixed by building with -O1 on arm instead of -O2. I consider this a temporary fix, but until gcc has a solution it's all we have.

Comment 3 Brian Lane 2017-05-15 16:50:33 UTC
*** Bug 1423631 has been marked as a duplicate of this bug. ***

Comment 4 Tomas Tomecek 2017-05-16 11:42:20 UTC
Brian, thank you for taking care of this.

Comment 5 Fedora Update System 2017-07-20 18:26:36 UTC
gnupg-1.4.22-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-e0163c9e7d

Comment 6 Fedora Update System 2017-07-20 18:27:26 UTC
gnupg-1.4.22-1.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-e3b6342bde

Comment 7 Fedora Update System 2017-07-23 06:54:05 UTC
gnupg-1.4.22-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-ea3b1c1767

Comment 8 Fedora Update System 2017-07-23 06:56:24 UTC
gnupg-1.4.22-1.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-e3b6342bde

Comment 9 Fedora Update System 2017-07-23 09:58:03 UTC
gnupg-1.4.22-1.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-e0163c9e7d

Comment 10 Fedora Update System 2017-07-24 19:22:10 UTC
gnupg-1.4.22-1.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2017-07-25 00:24:24 UTC
gnupg-1.4.22-1.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.