Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1466675 - updates-testing is still enabled
Summary: updates-testing is still enabled
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: fedora-repos
Version: 26
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Dennis Gilmore
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker
Depends On:
Blocks: F26FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2017-06-30 08:38 UTC by Kamil Páral
Modified: 2017-07-06 22:51 UTC (History)
11 users (show)

Fixed In Version: fedora-repos-26-1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-07-06 22:51:55 UTC
Type: Bug


Attachments (Terms of Use)

Description Kamil Páral 2017-06-30 08:38:52 UTC
Description of problem:
Even though updates-testing should've been disabled shortly after Beta release, it seems it never was. When I boot latest Fedora Workstation Live nightly image, or when I upgrade F24/25->F26, updates-testing is still enabled.

Version-Release number of selected component (if applicable):
fedora-repos-26-0.9.noarch
Fedora-Workstation-Live-x86_64-26-20170628.n.1.iso

How reproducible:
always

Comment 1 Kamil Páral 2017-06-30 08:40:56 UTC
I'm quite sure this is a blocker, even though I don't see a particular criterion for it now. This one might be the closest one:
"A fedora-release package containing the correct names, information and repository configuration for a final Fedora release must be present on release-blocking images and the appropriately versioned generic-release package must be available in the release repository."
https://fedoraproject.org/wiki/Fedora_26_Final_Release_Criteria#Release_identification

Comment 2 Matthew Miller 2017-06-30 14:00:14 UTC
This does make testing that KDE updates-notifier bug easier :)

Comment 3 Matthew Miller 2017-06-30 14:06:03 UTC
I have a suggestion for the future (maybe not the change to make right now, though): maybe the sources should always have updates-testing enabled (because that's what should happen in rawhide and branched), but have a flag in the spec file which changes this with sed in the %build section?

That way, the flip would be a simple specfile update rather than error-prone manual changes to the repo files in source.

Comment 4 Stephen Gallagher 2017-06-30 14:22:22 UTC
+1 blocker

Comment 5 Kamil Páral 2017-06-30 14:41:35 UTC
+1 blocker

Comment 6 Mike Ruckman 2017-06-30 15:16:52 UTC
+1 blocker

Comment 7 Adam Williamson 2017-06-30 16:02:27 UTC
+1 blocker, indeed the criterion cited is exactly the one that covers this: "correct...repository configuration for a final Fedora release" certainly means "updates-testing should be disabled". That's +4, so accepting.

Comment 8 Fedora Update System 2017-06-30 20:51:34 UTC
generic-release-26-1 fedora-repos-26-1 fedora-release-26-1 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-459d827225

Comment 9 Fedora Update System 2017-07-01 20:54:45 UTC
fedora-release-26-1, fedora-repos-26-1, generic-release-26-1 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-459d827225

Comment 10 Matthew Miller 2017-07-02 15:58:53 UTC
I can confirm that in RC 1.3 in the Fedora Cloud Base image, updates-testing is no longer enabled.

Comment 11 Kamil Páral 2017-07-03 08:15:24 UTC
I can also confirm fixed with RC 1.3 Workstation Live.

Comment 12 Dennis Gilmore 2017-07-06 14:51:20 UTC
(In reply to Matthew Miller from comment #3)
> I have a suggestion for the future (maybe not the change to make right now,
> though): maybe the sources should always have updates-testing enabled
> (because that's what should happen in rawhide and branched), but have a flag
> in the spec file which changes this with sed in the %build section?
> 
> That way, the flip would be a simple specfile update rather than error-prone
> manual changes to the repo files in source.

rawhide has a compeletely different repo file thats enabled. in rawhide fedora, updates and updates-testing are disabled. if you tried to use any of them they would all fail.

the only place we have updates-testing enabled is branched before release.

Comment 13 Matthew Miller 2017-07-06 15:37:49 UTC
(In reply to Dennis Gilmore from comment #12)
> rawhide has a compeletely different repo file thats enabled. in rawhide
> fedora, updates and updates-testing are disabled. if you tried to use any of
> them they would all fail.
> 
> the only place we have updates-testing enabled is branched before release.

I think the same thing applies -- wouldn't it be easier to change enabled/disabled for all of these things as a flag in the spec file rather than updating and rebuilding the source tarball?

Comment 14 Fedora Update System 2017-07-06 22:51:55 UTC
fedora-release-26-1, fedora-repos-26-1, generic-release-26-1 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.