Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1468986 - Unable to scan images from my Samsung C480
Summary: Unable to scan images from my Samsung C480
Keywords:
Status: CLOSED DUPLICATE of bug 1530216
Alias: None
Product: Fedora
Classification: Fedora
Component: sane-backends
Version: 26
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Nils Philippsen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-07-10 07:44 UTC by bugzilla
Modified: 2018-01-02 12:51 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-01-02 12:51:25 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)
strace from simple scan (deleted)
2017-07-10 07:45 UTC, bugzilla
no flags Details

Description bugzilla 2017-07-10 07:44:56 UTC
Description of problem:
When i scan anything with simple-scan or xsane, i get no output. No pdf, no jpeg etc. 
When i use simple-scan from command line, i get this:
[oli@localhost ~]$ simple-scan 

** (simple-scan:3529): WARNING **: Couldn't connect to accessibility bus: Failed to connect to socket /tmp/dbus-VyBnaDskbT: Connection refused
Not a JPEG file: starts with 0x00 0x00

The same happens when i try it as root.
I assume it is a sane-backends bug, but i am not 100% sure if its a sane problem. 



Version-Release number of selected component (if applicable):
[root@localhost oli]# rpm -qa | grep sane
kf5-libksane-16.12.3-1.fc26.x86_64
xsane-common-0.999-21.fc26.x86_64
sane-backends-1.0.27-2.fc26.x86_64
sane-backends-libs-1.0.27-2.fc26.x86_64
sane-backends-drivers-scanners-1.0.27-2.fc26.i686
ksaneplugin-16.12.3-1.fc26.x86_64
sane-backends-daemon-1.0.27-2.fc26.x86_64
sane-frontends-1.0.14-24.fc26.x86_64
sane-backends-drivers-cameras-1.0.27-2.fc26.i686
sane-backends-drivers-cameras-1.0.27-2.fc26.x86_64
sane-backends-drivers-scanners-1.0.27-2.fc26.x86_64
libksane-15.08.3-4.fc26.x86_64
xsane-0.999-21.fc26.x86_64
sane-backends-libs-1.0.27-2.fc26.i686
[root@localhost oli]# rpm -qa | grep cups
cups-filters-libs-1.13.4-2.fc26.x86_64
cups-libs-2.2.2-6.fc26.i686
cups-pk-helper-0.2.6-2.fc26.x86_64
cups-filters-1.13.4-2.fc26.x86_64
python3-cups-1.9.72-11.fc26.x86_64
cups-client-2.2.2-6.fc26.x86_64
cups-2.2.2-6.fc26.x86_64
bluez-cups-5.45-1.fc26.x86_64
cups-filesystem-2.2.2-6.fc26.noarch
cups-libs-2.2.2-6.fc26.x86_64
gutenprint-cups-5.2.12-4.fc26.x86_64
[root@localhost oli]# rpm -qa | grep dbus
dbusmenu-qt-0.9.3-0.12.20150604.fc26.x86_64
libdbusmenu-gtk3-16.04.0-2.fc26.x86_64
libdbusmenu-gtk2-16.04.0-2.fc26.i686
dbus-libs-1.11.14-1.fc26.i686
libdbusmenu-16.04.0-2.fc26.i686
libdbusmenu-gtk3-16.04.0-2.fc26.i686
python3-dbus-1.2.4-6.fc26.x86_64
dbus-glib-0.108-2.fc26.x86_64
jack-audio-connection-kit-dbus-1.9.10-8.fc26.x86_64
dbus-libs-1.11.14-1.fc26.x86_64
python3-slip-dbus-0.6.4-6.fc26.noarch
abrt-dbus-2.10.3-1.fc26.x86_64
dbusmenu-qt5-0.9.3-0.12.20150604.fc26.x86_64
libdbusmenu-16.04.0-2.fc26.x86_64
dbus-x11-1.11.14-1.fc26.x86_64
qt5-qdbusviewer-5.7.1-5.fc26.x86_64
dbus-python-1.2.4-6.fc26.x86_64
libdbusmenu-gtk2-16.04.0-2.fc26.x86_64
dbus-1.11.14-1.fc26.x86_64
kf5-kdbusaddons-5.35.0-1.fc26.x86_64


How reproducible:
Start a scan with Samsung C480W

Steps to Reproduce:
1. Input a paper 
2. Start a scan
3. Nothing will be saved to the filesystem, the applications are not able to handle the output of the scanner

Actual results:
No image in xsane nor simple-scan, nothing to save

Expected results:
a preview which i can save to filesystem

Additional info:
In windows its working as expected with drivers from Samsung

Comment 1 bugzilla 2017-07-10 07:45:31 UTC
Created attachment 1295721 [details]
strace from simple scan

Comment 2 Zdenek Dohnal 2018-01-02 12:51:25 UTC

*** This bug has been marked as a duplicate of bug 1530216 ***


Note You need to log in before you can comment on or make changes to this bug.