Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1475749 - weasyprint 47 is available
Summary: weasyprint 47 is available
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: weasyprint
Version: 31
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Felix Schwarz
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 1524986 1526200 1704917 1765322 1770018
Blocks: 1685649 1731545
TreeView+ depends on / blocked
 
Reported: 2017-07-27 09:12 UTC by Felix Schwarz
Modified: 2019-12-19 01:23 UTC (History)
4 users (show)

Fixed In Version: weasyprint-47-1.fc31
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-12-19 01:23:14 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Felix Schwarz 2017-07-27 09:12:14 UTC
weasyprint in Fedora is currently at 0.22 (released in Mai 2014) which is really outdated.

Is there any reason not to update the package using the latest release (v0.39, https://github.com/Kozea/WeasyPrint/releases/tag/v0.39)?

Comment 1 Jan Kurik 2017-08-15 09:48:08 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 27 development cycle.
Changing version to '27'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Releases/27/HouseKeeping#Rawhide_Rebase

Comment 2 Felix Schwarz 2017-12-12 12:03:29 UTC
At the mean time there is weasyprint 0.41 (https://pypi.python.org/pypi/WeasyPrint/0.41).

I have an updated spec file but the new weasyprint depends on other python packages which are outdated in Fedora as well...

Comment 3 Felix Schwarz 2017-12-12 12:09:54 UTC
WeasyPrint 0.41 depends on
- pdfrw >= 0.4 (bug 1524986)
- cssselect2 >= 0.1 (not packaged yet!)
- tinycss2 >= 0.5 (not packaged yet!)

WeasyPrint 0.39 (my original request) seems to be a bit easier to package right now (according to install.rst) as there is no pdfrw dependency and cssselect>=0.6 is enough.

Comment 4 Felix Schwarz 2017-12-12 15:01:24 UTC
Just fyi: I created a pull request with some changes to ease transition to 0.39 (https://src.fedoraproject.org/rpms/weasyprint/pull-request/1)

Also I created a package for python-tinycss2. If someone likes to submit this to Fedora please do :-) I really lack the time to be a good maintainer but I can co-maintain if desired.
 - https://github.com/FelixSchwarz/fedora-python-tinycss2
 - https://copr.fedorainfracloud.org/coprs/fschwarz/python-tinycss2/packages/

Comment 5 Felix Schwarz 2017-12-14 22:53:24 UTC
fyi: I created a review request for python-tinycss2 (bug 1526200).

Comment 6 Felix Schwarz 2017-12-16 18:38:35 UTC
Ok, python-tinycss2 is in rawhide now (co-maintainers welcome!). I built it for rawhide only as the only real user is likely weasyprint.

What do you think about updating WeasyPrint to 0.39 first (maybe even push that for F27) and going for 0.41 in rawhide (as we need cssselect2 and an updated python-pdfrw)?

Comment 7 Fedora End Of Life 2018-02-20 15:34:47 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 28 development cycle.
Changing version to '28'.

Comment 8 Pablo Rodríguez 2018-10-30 20:11:45 UTC
Latest stable can be found https://github.com/Kozea/WeasyPrint/releases/latest, although the pre-release (https://github.com/Kozea/WeasyPrint/releases/latest) removes the dependency from pdfrw.

Would it be possible to have latest stable in Fedora 28?

Comment 9 Pablo Rodríguez 2018-10-30 20:20:00 UTC
Sorry, pre-release is to be found at https://github.com/Kozea/WeasyPrint/releases/tag/v43rc1.

Comment 10 Andreas Gruenbacher 2019-01-01 12:36:56 UTC
Meanwhile, weasyprint is at version 44 and the version in Fedora is still 0.22 from May 2014.  The last real activity here was over a year ago, so could weasyprint please be upgraded really soon now?  If not, the package should probably be removed.

(I only discovered this by running into issue https://github.com/Kozea/WeasyPrint/issues/334, which should long since be resolved.)

Comment 11 Ben Cotton 2019-02-19 17:11:51 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 30 development cycle.
Changing version to '30.

Comment 12 Audrey Yeena Toskin 2019-04-24 21:00:07 UTC
Eric, are you still maintaining this package? The latest upstream version of WeasyPrint is now 47.

Comment 13 Audrey Yeena Toskin 2019-04-24 21:07:18 UTC
Also, the packaged WeasyPrint 0.22 has not actually worked in Fedora in a long time. See Bug #1560147.

Comment 14 Eric Smith 2019-04-30 18:02:59 UTC
Version 0.39 pushed to rawhide and f30-testing. As Felix pointed out, we can't yet use newer versions due to the requirement for cssselect2.

Comment 15 Eric Smith 2019-04-30 19:22:33 UTC
A review request has been created for cssselect2, necessary for newer vresions of weasyprint:
https://bugzilla.redhat.com/show_bug.cgi?id=1704917

Comment 16 Ben Cotton 2019-08-13 16:54:30 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 31 development cycle.
Changing version to '31'.

Comment 17 Ben Cotton 2019-08-13 18:54:44 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 31 development cycle.
Changing version to 31.

Comment 18 Felix Schwarz 2019-11-05 08:20:34 UTC
Just FYI: I started updating WeasyPrint and building is easy (now that all requirements are packaged in Fedora) but I noticed that the RPM does not run WeasyPrint's test suite as part of the build process. Unfortunately the test suite does not pass as I get ~40 test failures.

- Anyone interested in figuring out why the test suite fails? I'd push my changes to some git repo so we could collaborate on that.

- Anyone against updating WeasyPrint from 0.39 to something current in F31 even though it is a "major" update? (I think most users would just see many bugs fixed)

- With F31 versions we can only ship WeasyPrint 47 (latest is 50). I would have to push the major python-cairosvg update (1.0 -> 2.4) from rawhide to F31. Only dnfdragora depends on python-cairosvg so this might be fine. Comments?

Comment 19 Felix Schwarz 2019-11-20 09:28:26 UTC
All dependencies should be up-to-date now. Some test cases have been fixed while there are still some failing tests. I'll try to fix as many as possible before pushing this to rawhide.

Unfortunately the Fedora weasyprint stack did not see a lot of updates in the last years so I had to push quite a few major updates. Therefore the up-to-date weasyprint will likely only ship in F32.

Comment 20 Felix Schwarz 2019-12-01 00:00:48 UTC
WeasyPrint 50 is in rawhide now. I'll check if I can get WeasyPrint 47 to build for F31 (I still get test failures there while everything passes in rawhide).

Comment 21 Fedora Update System 2019-12-10 23:39:30 UTC
FEDORA-2019-e7a35878eb has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2019-e7a35878eb

Comment 22 Fedora Update System 2019-12-11 01:42:00 UTC
weasyprint-47-1.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-e7a35878eb

Comment 23 Fedora Update System 2019-12-19 01:23:14 UTC
weasyprint-47-1.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.