Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at
Bug 1478131 - qt5-qtwebkit package dependencies broken after RHEL 7.4 update
Summary: qt5-qtwebkit package dependencies broken after RHEL 7.4 update
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: qt5-qtwebkit
Version: epel7
Hardware: Unspecified
OS: Unspecified
Target Milestone: ---
Assignee: Than Ngo
QA Contact: Fedora Extras Quality Assurance
: 1481792 1488362 1489522 (view as bug list)
Depends On:
TreeView+ depends on / blocked
Reported: 2017-08-03 16:08 UTC by Victor Schulz
Modified: 2017-09-14 07:59 UTC (History)
9 users (show)

Fixed In Version: qt5-qtwebkit-5.6.2-1.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Last Closed: 2017-08-31 15:19:11 UTC
Type: Bug

Attachments (Terms of Use)
Output of 'yum install qt5-qtwebkit' (deleted)
2017-08-03 16:08 UTC, Victor Schulz
no flags Details

Description Victor Schulz 2017-08-03 16:08:08 UTC
Created attachment 1308788 [details]
Output of 'yum install qt5-qtwebkit'

Description of problem:
When trying to install the qt5-qtwebkit package (in my particular case as a dependency of the nextcloud-client package), there are broken dependencies. As far as I can tell, this is related to the now available qt5 packages on the rhel-7-server-rpms repository, which are newer than what the qt5-qtwebkit package in epel expects.

Version-Release number of selected component (if applicable):

How reproducible:
The bug affects Red Hat Enterprise Linux Server release 7.4 (Maipo)
Current CentOS (7.3.1611) is not affected due to the 7.4 packages have not reached yet the repositories.

Steps to Reproduce:
1. Simply running 'yum install qt5-qtwebkit' is enough.

Actual results:
Current qt5-qtwebkit requires 'qt5-qtbase(x86-64) = 5.6.1' and 'qt5-qtdeclarative(x86-64) = 5.6.1' but the version installed on the system is qt5-qtbase-5.6.2-1.el7.x86_64 and qt5-qtdeclarative-5.6.2-1.el7.x86_64.

Expected results:
qt5-qtwebkit has no broken dependencies an can be installed.

Additional info:
Attached is the yum command output.

Comment 1 Rex Dieter 2017-08-04 14:23:41 UTC
Looks like epel buildroots still include qt5-qtbase-5.7.1 as of today.  We'll have to wait for that before this can be fixed.

Comment 2 Rex Dieter 2017-08-04 14:23:54 UTC
sorry, make that 5.6.1

Comment 3 Victor Schulz 2017-08-04 17:45:36 UTC
Thanks for looking into it.

As a workaround, I was able to downgrade the qt5 packages to the versions available on EPEL, and installed the packages that depend on them with the rhel-7-server-rpms repository temporarily disabled. I'll be holding the update of these packages until this can be fixed.

Comment 4 Oliver Ilian 2017-08-10 07:56:09 UTC
This bug also prevents a successful upgrade from RHEL 7.3 to 7.4, as the qt5-qtwebkit package is expected to be version 5.6.2-1

A quick fix would be highly appreciated, as I am in the process to prepare the upgrade for ~3000 systems, and I have no idea how many users have qt5-qtwebkit installed.

Comment 5 Rex Dieter 2017-08-10 15:13:54 UTC
epel buildroots are not yet updated it seems :(

Latest attempt,

Comment 6 Rex Dieter 2017-08-12 17:32:04 UTC
Currently blocking on,
(pending next epel7 repo push, hopefully real soon now)

Comment 7 Fedora Update System 2017-08-15 02:24:31 UTC
qt5-qtquick1-5.6.2-1.64faeb0git.el7 qt5-qtquickcontrols2-5.6.2-1.el7 qt5-qtstyleplugins-5.0.0-15.el7 qt5-qtwebkit-5.6.2-1.el7 has been submitted as an update to Fedora EPEL 7.

Comment 8 Rex Dieter 2017-08-15 19:35:03 UTC
*** Bug 1481792 has been marked as a duplicate of this bug. ***

Comment 9 Fedora Update System 2017-08-15 21:50:41 UTC
qt5-qtquick1-5.6.2-1.64faeb0git.el7, qt5-qtquickcontrols2-5.6.2-1.el7, qt5-qtstyleplugins-5.0.0-15.el7, qt5-qtwebkit-5.6.2-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See for
instructions on how to install test updates.
You can provide feedback for this update here:

Comment 10 Victor Schulz 2017-08-16 19:07:55 UTC
I tried doing the update to the testing package, but now the qt-creator package is blocking the update, as it is still depends on qt5-qtbase 5.6.1, which is supposed to be updated to the 5.6.2 version.

I temporarily removed the qt-creator package to test the qt5-qtwebkit testing update and it installed correctly with no problems so far.

So, in short, qt-creator package should be also updated so that it is compatible with the new qt5-qtbase 5.6.2 package.

Comment 11 Rex Dieter 2017-08-16 19:30:35 UTC
See separate qt-creator update,

Comment 12 Rex Dieter 2017-08-16 19:31:18 UTC
and related bug #1481978

Comment 13 Victor Schulz 2017-08-19 05:07:12 UTC
I just installed the testing version of qt-creator, now everything is working. Thanks for the excellent work!

Comment 14 Fedora Update System 2017-08-31 15:19:11 UTC
qt5-qtquick1-5.6.2-1.64faeb0git.el7, qt5-qtquickcontrols2-5.6.2-1.el7, qt5-qtstyleplugins-5.0.0-15.el7, qt5-qtwebkit-5.6.2-1.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.

Comment 15 Rex Dieter 2017-09-05 12:09:44 UTC
*** Bug 1488362 has been marked as a duplicate of this bug. ***

Comment 16 Rex Dieter 2017-09-08 03:57:27 UTC
*** Bug 1489522 has been marked as a duplicate of this bug. ***

Comment 17 Daniel_Stm 2017-09-13 11:14:57 UTC
Altough I managed to install qt5-qtwebkit-5.6.2-1.el7 on CentOS7 now, I'm unable to achieve it on RHEL 7.3 and RHEL 7.4 (both recently set up just for testing this).

It misses several Qt dependencies, (libQt5{Qml,Quick,Positioning,WebChannel}).
Prominently, it misses qt5-qtdeclarative(x86_64) = 5.6.2.
Attempts to install qt5-qtdeclarative say it does not exist.
I have tried this over and over for weeks in the hope it is temporary.
yum --enablerepo="*" install qt5-qtdeclarative
=> No package qt5-qtdeclarative available

Should this package exist or is it provided by a different package? And in which repository should it be found?

I noticed that the desktop-extras repo contains zero packages, which I find odd.
I have had this consistently on both installations, no matter how often I clear/refresh the cache. I'd be thankful if somebody could point out whether this is
* normal/expected
* related to my issue (in the sense that it should contain the missing deps)
* a known issue
* if so, how to debug/resolve this

Output of yum repolist: (minus repo name colum)
repo id                                     status
epel/x86_64                                 11898
rhel-7-desktop-extras-rpms/x86_64               0
rhel-7-desktop-optional-rpms/7Client/x86_64 14435
rhel-7-desktop-rpms/7Client/x86_64          13789
repolist: 40122

Comment 18 Rex Dieter 2017-09-13 13:08:15 UTC
One rhel box I have access to at the moment includes qt5-qtdeclarative in rhel-7-server-rpms

Comment 19 Daniel_Stm 2017-09-14 07:59:30 UTC
Thanks a lot. I concluded and confirmed that qt5-qtwebkit can ultimately not be installed with a Desktop subscription, but Workstation and Server.

Note You need to log in before you can comment on or make changes to this bug.