Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1482648 - Update "Minimum required RAM" for RHEL installation over HTTP, HTTPS, or FTP
Summary: Update "Minimum required RAM" for RHEL installation over HTTP, HTTPS, or FTP
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: doc-Installation_Guide
Version: 7.4
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: rc
: ---
Assignee: Marc Muehlfeld
QA Contact: ecs-bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-08-17 19:36 UTC by Yash Mankad
Modified: 2019-03-06 00:40 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-10-20 14:44:04 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Yash Mankad 2017-08-17 19:36:04 UTC
Document URL: 
https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux/7/html/Installation_Guide/sect-installation-planning-disk-space-memory-x86.html

Section Number and Name:
5.5. Disk Space and Memory Requirements

Describe the issue:
Minimum required RAM for HTTP, HTTPS, or FTP network installation is listed as 1 GiB.

Suggestions for improvement:
It should be set to 4 GiB

Additional information:
When running an install test to create a RHEL VM from a qcow2 image using an internal URL, the test fails when memory is set to 1 GiB with the error "printf: write error: No space left on device"

We are using the Avocado testing framework ( http://avocado-framework.readthedocs.io/en/53.0/Introduction.html), with Avocado-VT (http://avocado-vt.readthedocs.io/en/latest/Introduction.html) to run an unattended install test to create a RHEL guest. We recently fixed this issue upstream when guest installation was failing because of insufficient memory, 
https://github.com/avocado-framework/avocado-vt/pull/1085

Comment 2 Marc Muehlfeld 2017-08-21 10:14:25 UTC
We recently updated the docs with the latest values. They are the results of several tests Martin Kolman ran to figure out the minimum RAM for RHEL 7.4. See BZ#1410948#22.

Is it possible that your unattended install contains additional commands (%pre/%pre-inst/%post scripts)? They can cause that the installer requires more RAM. See the paragraph right after the table:
https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux/7/html/Installation_Guide/sect-installation-planning-disk-space-memory-x86.html

> Installing Red Hat Enterprise Linux using a Kickstart file has the
> same minimum RAM requirements as a manual installation. However, if
> you use a Kickstart file that runs commands which require additional
> memory or write data to the RAM disk, additional RAM might be necessary.

If you don't use any scripts in your unattended install, can you please provide me more details or the Kickstart file? Then I will talk with the developers to figure out if there are more situations that require more RAM and which should be mentioned in the docs.

Comment 4 Cleber Rosa 2017-08-24 19:21:46 UTC
Actually the ppc64 section is correct, and documents that at least 1.664 MiB are required:

https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux/7/html/Installation_Guide/sect-installation-planning-disk-space-memory-ppc.html

While the x86_64 section documents 1 GiB:

https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux/7/html/Installation_Guide/sect-installation-planning-disk-space-memory-x86.html

Our mistake was to read the x86_64 section and assume it was for Power.

Comment 5 Cleber Rosa 2017-08-24 20:02:48 UTC
Although Yash brought to my attention that the values given here:

https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux/7/html/Installation_Guide/sect-installation-planning-disk-space-memory-ppc.html

Are, strictly speaking, representing < 2 MiB.  The issue is with the decimal separator, that should be "," instead of ".".

Comment 7 Fedora Update System 2017-10-13 12:53:34 UTC
kernel-4.13.6-200.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-74d659e9da

Comment 8 Fedora Update System 2017-10-13 12:58:56 UTC
kernel-4.13.6-100.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-521bb0d538

Comment 9 Fedora Update System 2017-10-13 22:23:36 UTC
kernel-4.13.6-100.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-521bb0d538

Comment 10 Fedora Update System 2017-10-13 22:24:18 UTC
kernel-4.13.6-200.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-74d659e9da

Comment 11 Fedora Update System 2017-10-13 23:24:05 UTC
kernel-4.13.6-300.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-e1dc7351db

Comment 12 Petr Bokoc 2017-10-17 16:11:56 UTC
This seems to have been moved by accident.

Comment 13 Fedora Update System 2017-10-18 22:20:22 UTC
kernel-4.13.8-300.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-aa9927961f

Comment 14 Fedora Update System 2017-10-18 22:21:46 UTC
kernel-4.13.8-200.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-c110ac0eb1

Comment 15 Fedora Update System 2017-10-18 22:27:45 UTC
kernel-4.13.8-100.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-cafcdbdde5

Comment 16 Fedora Update System 2017-10-19 20:52:09 UTC
kernel-4.13.8-100.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-cafcdbdde5

Comment 18 Fedora Update System 2017-10-25 21:20:07 UTC
kernel-4.13.8-100.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.