Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1484122 - Kernel 4.12.5-300 unstable on core2
Summary: Kernel 4.12.5-300 unstable on core2
Keywords:
Status: CLOSED DUPLICATE of bug 1482249
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 26
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-08-22 18:18 UTC by Luca Giuzzi
Modified: 2017-08-23 18:22 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-23 18:22:51 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)
Output of lshw (deleted)
2017-08-22 18:18 UTC, Luca Giuzzi
no flags Details
output of lsusb -v (deleted)
2017-08-22 18:22 UTC, Luca Giuzzi
no flags Details
output of lspci -vvvn (deleted)
2017-08-22 18:23 UTC, Luca Giuzzi
no flags Details

Description Luca Giuzzi 2017-08-22 18:18:48 UTC
Created attachment 1316725 [details]
Output of lshw

Description of problem:
 I have several problems with kernel 4.12.5-300.fc26.x86_64.
 In particular, kvm-intel does not work and the module for a webcam causes a BUG

Version-Release number of selected component (if applicable):
 4.12.5-300

Version 4.11.8 is fine.

How reproducible:
The computer is an old HP with a core2 cpu.
I have just reinstalled fedora 26 from scratch; the installation kernel works
fine; I have found some problems with 4.12.5-300.
In particular
a) kvm-intel cannot be loaded with "input/output error"
b) executing cheese causes a bug warning

I have reinstalled the system from scratch since I had a serious corruption on the root (which is a btrfs filesystem). I do not know if this might be a different aspect of the same issue or unrelated.


Steps to Reproduce:
1. boot the machine
2. execute sudo modprobe kvm-intel
3. execute cheese

Actual results:
 kvm-intel is not loaded
 cheese freezes and in dmesg there is a BUG notification

Expected results:
 everything works

Additional info:

Trace caused by cheese

[  115.162544] ------------[ cut here ]------------
[  115.162548] kernel BUG at ./include/linux/gfp.h:393!
[  115.162554] invalid opcode: 0000 [#1] SMP
[  115.162583] Modules linked in: dm_crypt rfcomm fuse xt_CHECKSUM ipt_MASQUERADE nf_nat_masquerade_ipv4 tun nf_conntrack_netbios_ns nf_conntrack_broadcast xt_CT ip6t_rpfilter ip6t_REJECT nf_reject_ipv6 xt_conntrack ip_set nfnetlink ebtable_nat ebtable_broute bridge stp llc ip6table_nat nf_conntrack_ipv6 nf_defrag_ipv6 nf_nat_ipv6 ip6table_mangle ip6table_raw ip6table_security iptable_nat nf_conntrack_ipv4 nf_defrag_ipv4 nf_nat_ipv4 nf_nat nf_conntrack libcrc32c iptable_mangle iptable_raw iptable_security ebtable_filter ebtables ip6table_filter ip6_tables cmac bnep sunrpc coretemp kvm gpio_ich iTCO_wdt iTCO_vendor_support irqbypass hp_wmi sparse_keymap mei_wdt gspca_zc3xx ppdev gspca_main v4l2_common ir_lirc_codec acpi_cpufreq lirc_dev videodev lpc_ich tpm_infineon rtl8xxxu r820t arc4 media rtl2832
[  115.162934]  i2c_mux btusb btrtl btbcm btintel rtl8192cu rtl_usb rtl8192c_common bluetooth rtlwifi mac80211 ecdh_generic dvb_usb_rtl28xxu cfg80211 dvb_usb_v2 rfkill dvb_core rc_core snd_hda_codec_realtek snd_hda_codec_generic snd_hda_codec_hdmi snd_hda_intel snd_hda_codec wmi snd_hda_core snd_hwdep parport_pc snd_seq snd_seq_device parport snd_pcm tpm_tis mei_me mei shpchp tpm_tis_core snd_timer snd soundcore tpm analog gameport joydev binfmt_misc hid_sony ff_memless uas usb_storage btrfs xor raid6_pq amdkfd amd_iommu_v2 radeon serio_raw i2c_algo_bit drm_kms_helper ttm drm e1000e ptp pps_core
[  115.163203] CPU: 0 PID: 2805 Comm: v4l2src0:src Not tainted 4.12.5-300.fc26.x86_64 #1
[  115.163239] Hardware name: Hewlett-Packard HP Compaq dc7700 Small Form Factor/0A54h, BIOS 786E1 v01.16 08/17/2011
[  115.163285] task: ffff8b90ffd0a480 task.stack: ffff9ae4439a4000
[  115.163318] RIP: 0010:__alloc_pages_nodemask+0x220/0x280
[  115.163343] RSP: 0018:ffff9ae4439a7ae0 EFLAGS: 00010202
[  115.163369] RAX: 0000000000000001 RBX: 00000000014002c6 RCX: 0000000000000006
[  115.163401] RDX: 0000000000000006 RSI: 0000000000000000 RDI: ffff8b9197fd6080
[  115.163433] RBP: ffff9ae4439a7b38 R08: ffff8b9197c1d740 R09: ffff8b9192402f00
[  115.163466] R10: ffffffffffffffff R11: ffff8b9192402f00 R12: 0000000000000000
[  115.163498] R13: 00000000014002c6 R14: 0000000000000000 R15: ffff8b90ffd0a480
[  115.163531] FS:  00007ff53ffff700(0000) GS:ffff8b9197c00000(0000) knlGS:0000000000000000
[  115.163569] CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
[  115.163595] CR2: 00007ff5a7efce10 CR3: 00000000a8df6000 CR4: 00000000000006f0
[  115.163627] Call Trace:
[  115.163644]  ? __get_vm_area_node+0x7f/0x160
[  115.163667]  alloc_pages_current+0x93/0x150
[  115.163687]  __vmalloc_node_range+0x20e/0x2c0
[  115.163709]  vmalloc_32+0x3e/0x40
[  115.163729]  ? vidioc_reqbufs+0x16a/0x300 [gspca_main]
[  115.163755]  vidioc_reqbufs+0x16a/0x300 [gspca_main]
[  115.163790]  v4l_reqbufs+0x43/0x50 [videodev]
[  115.163815]  __video_do_ioctl+0x364/0x370 [videodev]
[  115.163844]  ? v4l_enum_fmt+0x12f0/0x12f0 [videodev]
[  115.163872]  video_usercopy+0x2ae/0x5d0 [videodev]
[  115.163898]  ? do_futex+0x4ec/0xac0
[  115.163919]  video_ioctl2+0x15/0x20 [videodev]
[  115.163944]  v4l2_ioctl+0x7e/0xe0 [videodev]
[  115.163967]  do_vfs_ioctl+0xa5/0x600
[  115.163987]  ? security_file_ioctl+0x43/0x60
[  115.164008]  SyS_ioctl+0x79/0x90
[  115.164026]  do_syscall_64+0x67/0x140
[  115.164047]  entry_SYSCALL64_slow_path+0x25/0x25
[  115.164070] RIP: 0033:0x7ff5a1cea559
[  115.164088] RSP: 002b:00007ff53fffe468 EFLAGS: 00000246 ORIG_RAX: 0000000000000010
[  115.164123] RAX: ffffffffffffffda RBX: 0000000000000000 RCX: 00007ff5a1cea559
[  115.164156] RDX: 00007ff53fffe8c0 RSI: 00000000c0145608 RDI: 0000000000000018
[  115.164188] RBP: 00007ff53fffe8c0 R08: 0000000000000000 R09: 00000000c0145608
[  115.164221] R10: 000000000000001c R11: 0000000000000246 R12: 00000000c0145608
[  115.165645] R13: 00007ff5688a9000 R14: 00007ff53ffff698 R15: 0000000000000018
[  115.167026] Code: ff e8 e5 0d 08 00 85 c0 0f 84 0c ff ff ff 4c 89 ff 44 89 e6 45 31 ff e8 bf d9 ff ff e9 f9 fe ff ff e8 75 b3 01 00 e9 c9 fe ff ff <0f> 0b 0f ff e9 60 fe ff ff 65 48 8b 04 25 40 d3 00 00 8b 40 1c 
[  115.169881] RIP: __alloc_pages_nodemask+0x220/0x280 RSP: ffff9ae4439a7ae0
[  115.177208] ---[ end trace 6c1049d2a4baad39 ]---

Comment 1 Luca Giuzzi 2017-08-22 18:22:45 UTC
Created attachment 1316726 [details]
output of lsusb -v

Comment 2 Luca Giuzzi 2017-08-22 18:23:29 UTC
Created attachment 1316727 [details]
output of lspci -vvvn

Comment 3 Luca Giuzzi 2017-08-22 19:22:02 UTC
I have checked the RAM with memtest+ and it appears to be sane.
This bug, for what concers v4l, is a duplicate of 1483174 and 1482570.
(so it is probably not due to the cpu as I first assumed)
The issue with kvm is perhaps different.

Comment 4 Laura Abbott 2017-08-23 18:22:51 UTC
The v4l2 backtrace is a known issue with a fix pending in tree but not yet built. Please file a separate bug for the kvm-intel issue.

*** This bug has been marked as a duplicate of bug 1482249 ***


Note You need to log in before you can comment on or make changes to this bug.