Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1484295 - akmods warns - systemctl not found
Summary: akmods warns - systemctl not found
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: akmods
Version: el6
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Sergio Basto
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-08-23 08:22 UTC by nicolas.vieville
Modified: 2018-02-06 15:29 UTC (History)
6 users (show)

Fixed In Version: akmods-0.5.6-12.fc26 akmods-0.5.6-12.fc27
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-02-06 10:49:11 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)
akmods-001_rhel6.patch (deleted)
2017-08-23 08:22 UTC, nicolas.vieville
no flags Details | Diff
akmods-001_rhel6.patch (deleted)
2017-08-23 09:46 UTC, nicolas.vieville
no flags Details | Diff

Description nicolas.vieville 2017-08-23 08:22:33 UTC
Created attachment 1316986 [details]
akmods-001_rhel6.patch

Description of problem:

While trying to install broadcom-wl and akmod-wl packages build from rawhide sources of rpmfusion repository (SPEC modified for el7) on CentOS-6.9-x86_64, the process fails saying that 'systemctl' is not found.

Version-Release number of selected component (if applicable):

akmods-0.5.6-11.el6.noarch.rpm from /epel/testing/6/x86_64/ repository

How reproducible:

- Fresh install of CentOS-6.9-x86_64
- Install epel-release-latest-6.noarch.rpm
- Enable epel-testing repository for akmods and kmodtool packages only 
  (includepkgs=kmodtool akmods)
- Install akmods and kmodtool
- Install broadcom-wl and akmod-wl packages (build specially - not provided)
- Launch command akmods --kernel 2.6.32-696.6.3.el6.x86_64 (this supposes that 
  you use a patched version of kmodtool - see #1484293 bug report)

Steps to Reproduce:
1.
2.
3.

Actual results:

Warning

Expected results:

No message

Additional info:

Patch for akmods provided to correct the issue on CentOS-6.9-x86_64 (not sure it will work with RHEL6 - haven't tested because no RHEL6 available in my environment). The patched akmods works on CentOS-6 and CentOS-7.

I remain available for any questions about it

Cordially,


-- 
NVieville

Comment 1 Nicolas Chauvet (kwizart) 2017-08-23 08:31:53 UTC
Thx, I've only looked into this earlier today.
I will apply, but only with a little modification to avoid a call to which. (using -f /usr/bin/systemctl instead).

If you can send a git am version of the patch, it would be fine.

Comment 2 nicolas.vieville 2017-08-23 09:46:31 UTC
Created attachment 1317033 [details]
akmods-001_rhel6.patch

(In reply to Nicolas Chauvet (kwizart) from comment #1)
> Thx, I've only looked into this earlier today.
> I will apply, but only with a little modification to avoid a call to which.
> (using -f /usr/bin/systemctl instead).
> 
> If you can send a git am version of the patch, it would be fine.

Hello Nicolas,

Here is the modified patch. 

Hope it will match your request (early git user ;-) )

These modification have been tested on my CentOS-6.9 VM, and worked correctly.

Cordially,


-- 
NVieville

Comment 3 Sergio Basto 2017-11-22 23:52:34 UTC
I also may apply this one , bug is assigned to me ?

Comment 4 Fedora Update System 2018-01-26 18:15:26 UTC
akmods-0.5.6-12.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2018-97ee67cf09

Comment 5 Fedora Update System 2018-01-26 18:15:45 UTC
akmods-0.5.6-12.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2018-c5b163a57d

Comment 6 Fedora Update System 2018-01-28 22:34:28 UTC
akmods-0.5.6-12.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-c5b163a57d

Comment 7 Fedora Update System 2018-01-28 23:04:14 UTC
akmods-0.5.6-12.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-97ee67cf09

Comment 8 Fedora Update System 2018-02-06 10:49:11 UTC
akmods-0.5.6-12.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2018-02-06 15:29:55 UTC
akmods-0.5.6-12.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.