Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1489040 - nut needs to be rebuilt for the freeipmi update on F26
Summary: nut needs to be rebuilt for the freeipmi update on F26
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: nut
Version: 26
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Michal Hlavinka
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-09-06 15:47 UTC by Alexander Ploumistos
Modified: 2017-09-30 06:29 UTC (History)
2 users (show)

Fixed In Version: nut-2.7.4-14.fc26 nut-2.7.4-13.fc25 nut-2.7.4-13.fc27
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-09-29 13:19:01 UTC
Type: Bug


Attachments (Terms of Use)

Description Alexander Ploumistos 2017-09-06 15:47:38 UTC
For the past 2-3 weeks at least, it has been impossible to update freeipmi when nut is installed, because of a dependency:

 Problem: package nut-2.7.4-9.fc26.x86_64 requires libipmimonitoring.so.5()(64bit), but none of the providers can be installed
  - cannot install both freeipmi-1.5.7-1.fc26.x86_64 and freeipmi-1.5.6-1.fc26.x86_64
  - cannot install both freeipmi-1.5.6-1.fc26.x86_64 and freeipmi-1.5.7-1.fc26.x86_64
  - cannot install both freeipmi-1.5.5-1.fc26.x86_64 and freeipmi-1.5.7-1.fc26.x86_64
  - cannot install the best update candidate for package freeipmi-1.5.6-1.fc26.x86_64
  - problem with installed package nut-2.7.4-9.fc26.x86_64

I noticed there have been updated builds in koji for F27 & F28, but not for F26, so could you please take care of that?

Also, is there a reason why no updates have been sent to bodhi for almost a year?

Comment 1 Michal Hlavinka 2017-09-07 06:27:31 UTC
I'll do the update for F26. I did F27 & F28, because I've been told by freeipmi maintainer that only these are needed. Seems he was wrong.

Version 2.7.4 is latest version available. Other changes were not important enough to justify the waste of the bandwidth and other resources.

Comment 2 Fedora Update System 2017-09-07 07:00:52 UTC
nut-2.7.4-12.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-11e24ba7c5

Comment 3 Fedora Update System 2017-09-07 07:00:57 UTC
nut-2.7.4-12.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-6f4cfb0182

Comment 4 Fedora Update System 2017-09-07 07:01:01 UTC
nut-2.7.4-12.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-c488ffc9ae

Comment 5 Alexander Ploumistos 2017-09-07 12:16:10 UTC
(In reply to Michal Hlavinka from comment #1)
> I'll do the update for F26. I did F27 & F28, because I've been told by
> freeipmi maintainer that only these are needed. Seems he was wrong.

Thank you for taking care of this so quickly.

> Version 2.7.4 is latest version available. Other changes were not important
> enough to justify the waste of the bandwidth and other resources.

That's understandable.


However, the freeipmi update still refuses to install:


 Problem: package nut-2.7.4-12.fc26.x86_64 requires libipmimonitoring.so.5()(64bit), but none of the providers can be installed
  - cannot install both freeipmi-1.5.7-1.fc26.x86_64 and freeipmi-1.5.6-1.fc26.x86_64
  - cannot install both freeipmi-1.5.6-1.fc26.x86_64 and freeipmi-1.5.7-1.fc26.x86_64
  - cannot install both freeipmi-1.5.5-1.fc26.x86_64 and freeipmi-1.5.7-1.fc26.x86_64
  - cannot install the best update candidate for package freeipmi-1.5.6-1.fc26.x86_64
  - problem with installed package nut-2.7.4-12.fc26.x86_64


Any ideas where the problem might lie?

Comment 6 Fedora Update System 2017-09-07 14:33:25 UTC
nut-2.7.4-12.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-c488ffc9ae

Comment 7 Fedora Update System 2017-09-08 00:24:28 UTC
nut-2.7.4-12.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-11e24ba7c5

Comment 8 Fedora Update System 2017-09-08 01:21:53 UTC
nut-2.7.4-12.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-6f4cfb0182

Comment 9 Fedora Update System 2017-09-14 07:19:34 UTC
nut-2.7.4-14.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-de0f8ded67

Comment 10 Fedora Update System 2017-09-14 07:19:41 UTC
nut-2.7.4-13.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-eb06adc94f

Comment 11 Fedora Update System 2017-09-14 07:19:47 UTC
nut-2.7.4-13.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-4bfecd56f8

Comment 12 Michal Hlavinka 2017-09-14 07:20:32 UTC
Seems freeipmi package was not in buildroot yet. I've asked the freeipmi maintainer to create buildroot override and rebuilt nut once more. It should be ok now.

Comment 13 Alexander Ploumistos 2017-09-14 09:14:44 UTC
That did the trick, thanks!

Comment 14 Fedora Update System 2017-09-14 18:22:31 UTC
nut-2.7.4-13.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-4bfecd56f8

Comment 15 Fedora Update System 2017-09-15 04:50:20 UTC
nut-2.7.4-13.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-eb06adc94f

Comment 16 Fedora Update System 2017-09-15 04:52:12 UTC
nut-2.7.4-14.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-de0f8ded67

Comment 17 Fedora Update System 2017-09-28 19:54:42 UTC
nut-2.7.4-14.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Comment 18 Fedora Update System 2017-09-28 23:52:27 UTC
nut-2.7.4-13.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Comment 19 Andre Robatino 2017-09-29 13:14:27 UTC
I experienced a broken dep trying to update nut on F26, so I removed both nut and freeipmi, and tried to reinstall, and failed.

[root@lenovo-pc ~]# yum-deprecated --skip-broken install nut
Yum command has been deprecated, use dnf instead.
See 'man dnf' and 'man yum2dnf' for more information.

Resolving Dependencies
--> Running transaction check
---> Package nut.x86_64 0:2.7.4-14.fc26 will be installed
--> Processing Dependency: libipmimonitoring.so.6()(64bit) for package: nut-2.7.4-14.fc26.x86_64
--> Processing Dependency: libfreeipmi.so.17()(64bit) for package: nut-2.7.4-14.fc26.x86_64
--> Running transaction check
---> Package freeipmi.x86_64 0:1.5.6-1.fc26 will be installed
---> Package nut.x86_64 0:2.7.4-14.fc26 will be installed
--> Processing Dependency: libipmimonitoring.so.6()(64bit) for package: nut-2.7.4-14.fc26.x86_64

Packages skipped because of dependency problems:
    freeipmi-1.5.6-1.fc26.x86_64 from updates
    nut-2.7.4-14.fc26.x86_64 from updates
[root@lenovo-pc ~]#

Comment 20 Andre Robatino 2017-09-29 13:19:01 UTC
Never mind, this F26 update requires the freeipmi update https://bodhi.fedoraproject.org/updates/FEDORA-2017-5f8e18be61 which is still in updates-testing. After installing that, I was able to install nut.

Comment 21 Fedora Update System 2017-09-30 06:29:03 UTC
nut-2.7.4-13.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.