Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1493505 - screen contents are preserved on terminal after detach
Summary: screen contents are preserved on terminal after detach
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: screen
Version: 26
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Josef Ridky
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-09-20 11:16 UTC by Vasiliy Glazov
Modified: 2017-11-21 23:28 UTC (History)
3 users (show)

Fixed In Version: screen-4.6.2-1.fc26 screen-4.6.2-1.fc27
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-15 20:17:53 UTC
Type: Bug


Attachments (Terms of Use)

Description Vasiliy Glazov 2017-09-20 11:16:32 UTC
Description of problem:
screen contents are preserved on terminal after detach or exit.

Version-Release number of selected component (if applicable):
screen-4.6.1-1.fc26.x86_64


How reproducible:
Always

Steps to Reproduce:
1. Run screen
2. Enter ls command
3. Detach screen

Actual results:
screen contents are preserved on terminal

Expected results:
screen contents mut be cleared.

Additional info:
I am found that problem caused by screen-4.5.1-xterm.patch applyed in screen.spec file.
Please remove this patch or correct it.

Comment 1 Josef Ridky 2017-11-08 08:28:34 UTC
Removed screen-4.5.1-xterm.patch

Comment 2 Fedora Update System 2017-11-08 09:32:41 UTC
screen-4.6.2-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-37aebfc224

Comment 3 Fedora Update System 2017-11-08 09:32:52 UTC
screen-4.6.2-1.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-fb018b7696

Comment 4 Fedora Update System 2017-11-08 09:33:04 UTC
screen-4.6.2-1.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-f5a511f3ba

Comment 5 Fedora Update System 2017-11-08 20:31:32 UTC
screen-4.6.2-1.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-f5a511f3ba

Comment 6 Fedora Update System 2017-11-08 23:57:56 UTC
screen-4.6.2-1.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-37aebfc224

Comment 7 Fedora Update System 2017-11-09 01:47:39 UTC
screen-4.6.2-1.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-fb018b7696

Comment 8 Vasiliy Glazov 2017-11-09 07:05:49 UTC
Thanks.

Comment 9 Fedora Update System 2017-11-15 20:17:53 UTC
screen-4.6.2-1.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2017-11-21 23:28:34 UTC
screen-4.6.2-1.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.