Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1497885 - gtk-recordMyDesktop not working on Fedora 26
Summary: gtk-recordMyDesktop not working on Fedora 26
Keywords:
Status: CLOSED DUPLICATE of bug 1146202
Alias: None
Product: Fedora
Classification: Fedora
Component: gtk-recordmydesktop
Version: 25
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Orphan Owner
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-10-03 03:04 UTC by ravindrapankaj
Modified: 2017-11-01 10:42 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-01 10:42:39 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description ravindrapankaj 2017-10-03 03:04:46 UTC
Traceback (most recent call last):
  File "/usr/bin/gtk-recordMyDesktop", line 43, in <module>
    main()
  File "/usr/bin/gtk-recordMyDesktop", line 40, in main
    tr=rmdSimple.simpleWidget()
  File "/usr/lib/python2.7/site-packages/recordMyDesktop/rmdSimple.py", line 477, in __init__
    self.__subWidgets__()
  File "/usr/lib/python2.7/site-packages/recordMyDesktop/rmdSimple.py", line 86, in __subWidgets__
    self.image=sT.GtkThumbSelector(self,self.values[5],self.hidden,2000)
  File "/usr/lib/python2.7/site-packages/recordMyDesktop/rmdSelectThumb.py", line 69, in __init__
    self.__subsample__(sroot,self.wwidth,self.wheight,self.root,self.factor)
  File "/usr/lib/python2.7/site-packages/recordMyDesktop/rmdSelectThumb.py", line 79, in __subsample__
    im2.put_pixel(k/stride,i/stride,im1.get_pixel(k,i))
AttributeError: 'NoneType' object has no attribute 'get_pixel'

Comment 1 Petr Pisar 2017-10-05 14:40:18 UTC
Could you tell us what gtk-recordmydesktop RPM package you use (rpm -q gtk-recordmydesktop)?

Comment 2 ravindrapankaj 2017-10-09 23:14:21 UTC
(In reply to Petr Pisar from comment #1)
> Could you tell us what gtk-recordmydesktop RPM package you use (rpm -q
> gtk-recordmydesktop)?

rpm -q gtk-recordmydesktop 
gtk-recordmydesktop-0.3.8-18.fc26.noarch

Comment 3 Miguel 2017-10-22 02:50:44 UTC
Hi, i have the same error in Fedora 25x64

rpm -q gtk-recordmydesktop
gtk-recordmydesktop-0.3.8-17.fc25.noarch

Traceback (most recent call last):
  File "/usr/bin/gtk-recordMyDesktop", line 43, in <module>
    main()
  File "/usr/bin/gtk-recordMyDesktop", line 40, in main
    tr=rmdSimple.simpleWidget()
  File "/usr/lib/python2.7/site-packages/recordMyDesktop/rmdSimple.py", line 477, in __init__
    self.__subWidgets__()
  File "/usr/lib/python2.7/site-packages/recordMyDesktop/rmdSimple.py", line 86, in __subWidgets__
    self.image=sT.GtkThumbSelector(self,self.values[5],self.hidden,2000)
  File "/usr/lib/python2.7/site-packages/recordMyDesktop/rmdSelectThumb.py", line 69, in __init__
    self.__subsample__(sroot,self.wwidth,self.wheight,self.root,self.factor)
  File "/usr/lib/python2.7/site-packages/recordMyDesktop/rmdSelectThumb.py", line 79, in __subsample__
    im2.put_pixel(k/stride,i/stride,im1.get_pixel(k,i))
AttributeError: 'NoneType' object has no attribute 'get_pixel'

Comment 4 Miguel 2017-10-22 03:58:07 UTC
This problems only ocurrs with Wayland! with Xorg nop

Comment 5 Petr Pisar 2017-11-01 10:42:39 UTC

*** This bug has been marked as a duplicate of bug 1146202 ***


Note You need to log in before you can comment on or make changes to this bug.