Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1505906 - Disable f27 updates testing repo for F27 final
Summary: Disable f27 updates testing repo for F27 final
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: fedora-repos
Version: 27
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Dennis Gilmore
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker
Depends On:
Blocks: F27FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2017-10-24 14:24 UTC by Mohan Boddu
Modified: 2017-10-30 01:53 UTC (History)
8 users (show)

Fixed In Version: fedora-repos-27-1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-10-30 01:53:11 UTC
Type: Bug


Attachments (Terms of Use)

Description Mohan Boddu 2017-10-24 14:24:39 UTC
Description of problem:
For final RC composes, updates-testing repo should be disabled.

Version-Release number of selected component (if applicable):


How reproducible: Everytime


Steps to Reproduce:
1. Just look at /etc/yum.repos.d/fedora-updates-testing.repo
2. enabled is set to 1 under [updates-testing] which should be set to 0
3.

Actual results:


Expected results:


Additional info:
https://pagure.io/fedora-repos/pull-request/52 and https://pagure.io/fedora-release/pull-request/116 should fix it once merged and build.

Comment 1 Fedora Blocker Bugs Application 2017-10-24 14:25:49 UTC
Proposed as a Blocker for 27-final by Fedora user mohanboddu using the blocker tracking app because:

 For final RC's updates-testing repo should be disabled.

Comment 2 Adam Williamson 2017-10-24 16:26:26 UTC
+1 blocker, criterion "A fedora-release package containing the correct names, information and repository configuration for a final Fedora release must be present on release-blocking images and the appropriately versioned Package-generic-release package must be available in the release repository."

please ensure all other requirements for fedora-release and generic-release are met in the builds too.

Comment 3 Fedora Update System 2017-10-24 17:45:49 UTC
fedora-release-27-1 fedora-repos-27-1 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-b365b0a636

Comment 4 Mohan Boddu 2017-10-24 17:57:07 UTC
Update for fedora-release, fedora-repos, generic-release is requested in bodhi: https://bodhi.fedoraproject.org/updates/fedora-release-27-1%20fedora-repos-27-1%20generic-release-27-1

Comment 5 Fedora Update System 2017-10-25 15:25:13 UTC
fedora-release-27-1, fedora-repos-27-1, generic-release-27-1 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-b365b0a636

Comment 6 Adam Williamson 2017-10-26 20:33:44 UTC
Discussed at 2017-10-26 Fedora 27 Final go/no-go meeting, acting as a blocker review meeting: https://meetbot-raw.fedoraproject.org/fedora-meeting-1/2017-10-26/f27-final-and-server-beta-go-no-go-meeting.2017-10-26-17.00.html . Accepted as a blocker as a clear violation of the criterion cited in #c2.

Comment 7 František Zatloukal 2017-10-27 08:23:22 UTC
Fixed in fedora-repos-27-1 .

Comment 8 Fedora Update System 2017-10-30 01:53:11 UTC
fedora-release-27-1, fedora-repos-27-1, generic-release-27-1 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.