Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1534724 - ntop crashes on start with symbol lookup error libntop undefined symbol gdbm_errno
Summary: ntop crashes on start with symbol lookup error libntop undefined symbol gdbm_...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: ntop
Version: 27
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Orphan Owner
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-01-15 19:51 UTC by Bob
Modified: 2018-01-19 04:20 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-01-18 21:31:10 UTC
Type: Bug


Attachments (Terms of Use)

Description Bob 2018-01-15 19:51:12 UTC
Description of problem:
ntop fails to start.  Displays error message undefined symbol gdbm_errno
This is occurring in both 32-bit and 64-bit versions of Fedora 27.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. (in Fedora 27, x86_64, as root) # ntop
2.
3.

Actual results:
ntop: symbol lookup error: /lib64/libntop-5.0.1.so: undefined symbol: gdbm_errno

Expected results:
ntop launches, displays trace output, localhost:3000 is accessible in browser.

Additional info:

Comment 1 Fedora Update System 2018-01-16 13:02:01 UTC
gdbm-1.13-6.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2018-ec4df5a741

Comment 2 Marek Skalický 2018-01-16 13:02:37 UTC
This problem is caused by gdbm update.

Comment 3 Fedora Update System 2018-01-16 13:02:56 UTC
gdbm-1.13-6.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2018-ec4df5a741

Comment 4 Fedora Update System 2018-01-17 06:46:44 UTC
gdbm-1.13-6.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-ec4df5a741

Comment 5 Fedora Update System 2018-01-18 21:31:10 UTC
gdbm-1.13-6.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.