Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1537864 - audit-libs-python2 does not "provide" audit-libs-python
Summary: audit-libs-python2 does not "provide" audit-libs-python
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: audit
Version: 28
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Steve Grubb
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-01-24 02:36 UTC by Matthew Harmsen
Modified: 2018-04-01 19:05 UTC (History)
3 users (show)

Fixed In Version: audit-2.8.3-1.fc27 audit-2.8.3-2.fc28
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-01 19:05:34 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Matthew Harmsen 2018-01-24 02:36:20 UTC
I have encountered the following problem when attempting to build pki-core on Fedora 28 (rawhide) using Koji:

DEBUG util.py:439:  Error: 
DEBUG util.py:439:   Problem: conflicting requests
DEBUG util.py:439:    - nothing provides audit-libs-python >= 2.1.3-4 needed by python2-policycoreutils-2.7-8.fc28.x86_64


I added the following two lines to the pki-core spec (which may or may not be necessary since it was not previously necessary in Fedora 27):

166a167,169
> %if 0%{?fedora} >= 28 || 0%{?rhel} > 7
> BuildRequires:    audit-libs-python2
> %endif
528a532,534
> %endif
> %if 0%{?fedora} >= 28 || 0%{?rhel} > 7
> Requires:         audit-libs-python2


# rpm -qp -requires ./python2-policycoreutils-2.7-8.fc28.x86_64.rpm 
/usr/bin/python
audit-libs-python >= 2.1.3-4
checkpolicy
libcgroup
libselinux-python
libsemanage-python >= 2.7-5
policycoreutils = 2.7-8.fc28
python(abi) = 2.7
python-IPy
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(FileDigests) <= 4.6.0-1
rpmlib(PartialHardlinkSets) <= 4.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(PayloadIsXz) <= 5.2-1
setools-python >= 4.1.1


# rpm -qp -provides ./python2-policycoreutils-2.7-8.fc28.x86_64.rpm 
policycoreutils-python = 2.7-8.fc28
policycoreutils-python(x86-64) = 2.7-8.fc28
python-policycoreutils = 2.7-8.fc28
python-policycoreutils(x86-64) = 2.7-8.fc28
python2-policycoreutils = 2.7-8.fc28
python2-policycoreutils(x86-64) = 2.7-8.fc28
python2.7dist(sepolicy) = 1.1
python2dist(sepolicy) = 1.1

I believe that the fix may be as simple as adding something like the following to the audit.spec file which builds 'audit-libs-pyton2':

    Provides:    audit-libs-python = %{version}-%{release}

Comment 1 Steve Grubb 2018-01-24 08:27:13 UTC
I added a Provides and rebuilt audit-2.8.2-3.

Comment 5 Miro Hrončok 2018-01-31 16:06:49 UTC
Also, obsoletes is missing. When renaming packages, make sure to add both.

https://fedoraproject.org/wiki/Packaging:Guidelines#Renaming.2FReplacing_Existing_Packages

Comment 6 Miro Hrončok 2018-01-31 16:09:25 UTC
Also, this commit is probably bogus https://src.fedoraproject.org/rpms/audit/c/703e377348cb59b4b7ff2d3ae4b6ca59749cbe68?branch=master

Comment 7 Steve Grubb 2018-02-05 21:01:28 UTC
Thanks for your patience, I was on travel.

After the initial python fixes, it looks like the problem was a missing tcp_wrappers-devel package. Strange. I've temporarily removed the BuildRequires for it until its back in the build root. audit-2.8.2-3 should be in rawhide shortly.

Comment 8 Fedora End Of Life 2018-02-20 15:31:57 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 28 development cycle.
Changing version to '28'.

Comment 9 Fedora Update System 2018-03-10 12:23:33 UTC
audit-2.8.3-1.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-2c1484e4cd

Comment 10 Fedora Update System 2018-03-10 12:23:51 UTC
audit-2.8.3-1.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2018-ea91f55218

Comment 11 Fedora Update System 2018-03-11 03:05:10 UTC
audit-2.8.3-1.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-2c1484e4cd

Comment 12 Fedora Update System 2018-03-11 20:59:56 UTC
audit-2.8.3-1.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-ea91f55218

Comment 13 Fedora Update System 2018-03-13 23:20:43 UTC
audit-2.8.3-1.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.

Comment 14 Rob Crittenden 2018-03-14 14:21:13 UTC
This is preventing upgrades from F-27 to F-28:

# dnf system-upgrade download --refresh --releasever=28
Before you continue ensure that your system is fully upgraded by running "dnf --refresh upgrade". Do you want to continue [y/N]: y
Last metadata expiration check: 0:00:00 ago on Wed 14 Mar 2018 02:19:33 PM UTC.
Error: 
 Problem: package audit-libs-python-2.8.3-1.fc27.x86_64 requires audit-libs(x86-64) = 2.8.3-1.fc27, but none of the providers can be installed
  - audit-libs-2.8.3-1.fc27.x86_64 does not belong to a distupgrade repository
  - problem with installed package audit-libs-python-2.8.3-1.fc27.x86_64

Comment 15 Steve Grubb 2018-03-14 17:55:00 UTC
The issue appears to be that the F28 package did not get any karma yet and is still in testing. When that reaches karma and gets pushed, this should be OK.

Comment 16 Rob Crittenden 2018-03-15 12:55:38 UTC
Ok, that sounds reasonable. Moving state back.

Comment 17 Fedora Update System 2018-03-26 21:31:41 UTC
audit-2.8.3-2.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-2c1484e4cd

Comment 18 Fedora Update System 2018-03-27 17:52:04 UTC
audit-2.8.3-2.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-2c1484e4cd

Comment 19 Fedora Update System 2018-04-01 19:05:34 UTC
audit-2.8.3-2.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.