Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1554760 - Don't send IP address as SNI TLS extension
Summary: Don't send IP address as SNI TLS extension
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: python2
Version: 28
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Charalampos Stratakis
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1554761 (view as bug list)
Depends On:
Blocks: 1555314
TreeView+ depends on / blocked
 
Reported: 2018-03-13 10:16 UTC by Christian Heimes
Modified: 2018-03-30 12:56 UTC (History)
10 users (show)

Fixed In Version: python2-2.7.14-7.fc26 python2-2.7.14-10.fc27 python2-2.7.14-15.fc28
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1555314 (view as bug list)
Environment:
Last Closed: 2018-03-20 17:34:05 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Python 32185 0 None None None 2018-03-13 10:16:46 UTC
Red Hat Bugzilla 1555081 0 unspecified CLOSED python2-2.7.14-14 breaks fedpkg build (_ssl.so: undefined symbol: Py_MAX) 2022-05-16 11:32:56 UTC

Internal Links: 1555081

Description Christian Heimes 2018-03-13 10:16:47 UTC
Description of problem:
Python's ssl module sends IP addresses in SNI TLS extension although the extension must only be used to send hostnames. Some servers simply ignore IP addresses in extensions while others seem to fail. Ansible has been hitting the issue, e.g. see https://github.com/shazow/urllib3/pull/1287#issuecomment-372611467

Version-Release number of selected component (if applicable):
python2-2.7.14-8.fc27.x86_64
python3-3.6.4-8.fc27.x86_64

How reproducible:
Always

Additional info:
Fixes for 2.7 and 3.6 are available in https://github.com/python/cpython/pull/5871
and https://github.com/python/cpython/pull/5865 .

Comment 1 Charalampos Stratakis 2018-03-13 10:47:16 UTC
Reassigning to the correct component as the python package was renamed to python2.

Comment 2 Fedora Update System 2018-03-14 16:22:34 UTC
python2-2.7.14-10.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2018-a9d2b42ad4

Comment 3 Fedora Update System 2018-03-14 16:25:57 UTC
python2-2.7.14-7.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2018-031d0ddaa3

Comment 4 Fedora Update System 2018-03-14 20:07:31 UTC
python2-2.7.14-7.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-031d0ddaa3

Comment 5 Fedora Update System 2018-03-14 20:45:01 UTC
python2-2.7.14-10.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-a9d2b42ad4

Comment 6 Fedora Update System 2018-03-15 10:06:33 UTC
python2-2.7.14-15.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-a84c91e538

Comment 7 Fedora Update System 2018-03-15 13:32:48 UTC
python2-2.7.14-15.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-a84c91e538

Comment 8 Charalampos Stratakis 2018-03-15 15:05:10 UTC
*** Bug 1554761 has been marked as a duplicate of this bug. ***

Comment 9 Fedora Update System 2018-03-20 17:34:05 UTC
python2-2.7.14-7.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2018-03-20 18:20:40 UTC
python2-2.7.14-10.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2018-03-30 12:56:35 UTC
python2-2.7.14-15.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.