Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1555728 - emacs: FTBFS in F28
Summary: emacs: FTBFS in F28
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: emacs
Version: 28
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jan Synacek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F28FTBFS
TreeView+ depends on / blocked
 
Reported: 2018-03-14 19:34 UTC by Fedora Release Engineering
Modified: 2018-05-01 15:38 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-01 15:38:19 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)

Description Fedora Release Engineering 2018-03-14 19:34:14 UTC
Your package emacs failed to build from source in current F28.

https://koji.fedoraproject.org/koji/taskinfo?taskID=24782676

For details on mass rebuild see https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild

Comment 1 Troy Dawson 2018-04-30 16:48:43 UTC
This is really weird.  I tried rebuilding the package again.
The first time, it built on everything but aarch64, with this error.

On aarch64 
https://kojipkgs.fedoraproject.org//work/tasks/3437/26623437/build.log
...
Checking /builddir/build/BUILD/emacs-25.3/lisp/leim/quail/thai.el ...
Backtrace:
../src/bootstrap-emacs[0x4f173c]
../src/bootstrap-emacs[0x4d91dc]
../src/bootstrap-emacs[0x4efd70]
../src/bootstrap-emacs[0x4eff60]
../src/bootstrap-emacs[0x4efff0]
linux-vdso.so.1(__kernel_rt_sigreturn+0x0)[0xffffaeb7066c]
../src/bootstrap-emacs(re_search_2+0x524)[0x524124]
../src/bootstrap-emacs(re_search+0x30)[0x524ad8]

<many more lines of ../src/bootstrap-emacs[<number>]

make[3]: *** [Makefile:134: ../../leim/../lisp/leim/leim-list.el] Segmentation fault (core dumped)
make[3]: Leaving directory '/builddir/build/BUILD/emacs-25.3/build-lucid/leim'
make[2]: Leaving directory '/builddir/build/BUILD/emacs-25.3/build-lucid/src'
make[2]: *** [Makefile:490: ../../lisp/leim/leim-list.el] Error 2
make[1]: *** [Makefile:398: src] Error 2
make[1]: Leaving directory '/builddir/build/BUILD/emacs-25.3/build-lucid'
make: *** [Makefile:1093: bootstrap] Error 2


The next time it built on everything, include aarch64, and failed on s390x, with this error.
https://kojipkgs.fedoraproject.org//work/tasks/9597/26679597/build.log

In toplevel form:
../../lisp/emacs-lisp/ewoc.el:501:1:Warning: Unused lexical variable `dll'
  ELC      emacs-lisp/find-func.elc
  ELC      emacs-lisp/generator.elc
  ELC      emacs-lisp/generic.elc
  ELC      emacs-lisp/gv.elc
  ELC      emacs-lisp/helper.elc
  ELC      emacs-lisp/inline.elc
  ELC      emacs-lisp/let-alist.elc
  ELC      emacs-lisp/lisp-mnt.elc
  ELC      emacs-lisp/map.elc
  ELC      emacs-lisp/package-x.elc
In toplevel form:
../../lisp/emacs-lisp/package-x.el:45:1:Error: Opening process input file: No such device or address, /dev/null
make[3]: Leaving directory '/builddir/build/BUILD/emacs-25.3/build-gtk/lisp'
make[3]: *** [Makefile:272: emacs-lisp/package-x.elc] Error 1
make[2]: *** [Makefile:295: compile-main] Error 2
make[2]: Leaving directory '/builddir/build/BUILD/emacs-25.3/build-gtk/lisp'
make[1]: *** [Makefile:385: lisp] Error 2
make[1]: Leaving directory '/builddir/build/BUILD/emacs-25.3/build-gtk'
make: *** [Makefile:1093: bootstrap] Error 2
error: Bad exit status from /var/tmp/rpm-tmp.hAxS9Y (%build)

Trying it again.

Comment 2 Troy Dawson 2018-05-01 15:38:19 UTC
Final rebuild worked.
Something flaky, but continual rebuilds gets it done eventually.


Note You need to log in before you can comment on or make changes to this bug.