Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1555752 - firmware-addon-dell: FTBFS in F28
Summary: firmware-addon-dell: FTBFS in F28
Keywords:
Status: CLOSED EOL
Alias: None
Product: Fedora
Classification: Fedora
Component: firmware-addon-dell
Version: 28
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Michael E Brown
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F28FTBFS
TreeView+ depends on / blocked
 
Reported: 2018-03-14 19:36 UTC by Fedora Release Engineering
Modified: 2022-01-14 19:37 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-05-28 21:59:40 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)

Description Fedora Release Engineering 2018-03-14 19:36:45 UTC
Your package firmware-addon-dell failed to build from source in current F28.

https://koji.fedoraproject.org/koji/taskinfo?taskID=24786261

For details on mass rebuild see https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild

Comment 1 Adam Williamson 2018-03-28 21:57:20 UTC
Welp, one obvious problem is that python-smbios became python3-smbios behind its back. Also, it needs `BuildRequires: perl`.

Before I go too far down the road of trying to port this thing to Python 3, does it even make sense to ship it any more? Neither it nor firmware-tools appears to have been touched upstream for 6 or 7 years, while Dell continues to work on libsmbios. And I think Dell is now supporting firmware updates via fwupd. Is this just abandoned and should be retired? WDYT, Peter?

Comment 2 Kamil Páral 2018-03-29 10:53:57 UTC
This package is part of Server DVD and breaks repoclosure of that medium. 

$ sudo mount -o loop Fedora-Server-dvd-x86_64-28_Beta-1.3.iso /mnt/test/
$ rpmdeplint check-repoclosure --repo tmp,/mnt/test/ /mnt/test/Packages/s/systemd-238-7.fc28.x86_64.rpm # the last argument is fake
2018-03-29 12:45:42,713 rpmdeplint WARNING Ignoring pre-existing repoclosure problem: nothing provides python-smbios needed by firmware-addon-dell-2.2.9-12.fc25.x86_64

A final blocker it seems:
"There must be no errors in any package on the release-blocking images which cause the package to fail to install. "
https://fedoraproject.org/wiki/Fedora_28_Final_Release_Criteria#no-broken-packages

Comment 3 Kamil Páral 2018-03-29 10:56:51 UTC
Turn out bug 1561768 is already proposed as blocker, so unproposing this one.

Comment 4 Zbigniew Jędrzejewski-Szmek 2018-07-09 04:18:29 UTC
Dear Maintainer,

your package has not been built successfully in F28. Action is required from you.

If you can fix your package to build, perform a build in koji, and either create
an update in bodhi, or close this bug without creating an update, if updating is
not appropriate [1]. If you are working on a fix, set the status to ASSIGNED to
acknowledge this. Following the latest policy for such packages [2], your package
will be orphaned if this bug remains in NEW state more than 8 weeks.

[1] https://fedoraproject.org/wiki/Updates_Policy
[2] https://fedoraproject.org/wiki/Fails_to_build_from_source#Package_Removal_for_Long-standing_FTBFS_bugs

Comment 5 Zbigniew Jędrzejewski-Szmek 2018-07-09 04:22:41 UTC
Dear Maintainer,

your package has not been built successfully in F28. Action is required from you.

If you can fix your package to build, perform a build in koji, and either create
an update in bodhi, or close this bug without creating an update, if updating is
not appropriate [1]. If you are working on a fix, set the status to ASSIGNED to acknowledge this. Following the latest policy for such packages [2], your package will be orphaned if this bug remains in NEW state more than 8 weeks.

[1] https://fedoraproject.org/wiki/Updates_Policy
[2] https://fedoraproject.org/wiki/Fails_to_build_from_source#Package_Removal_for_Long-standing_FTBFS_bugs

Comment 6 João Carlos Mendes Luís 2018-07-30 18:14:53 UTC
:-(

https://src.fedoraproject.org/rpms/firmware-addon-dell/c/23f8bab6e1a3dc30b6a49ed46e6b2b8c430ea4c0?branch=master


"The recommendation from Dell is to drop it. Other distros have dropped it too" -- Charles Rose, Dell

Comment 7 Ben Cotton 2019-05-02 21:14:13 UTC
This message is a reminder that Fedora 28 is nearing its end of life.
On 2019-May-28 Fedora will stop maintaining and issuing updates for
Fedora 28. It is Fedora's policy to close all bug reports from releases
that are no longer maintained. At that time this bug will be closed as
EOL if it remains open with a Fedora 'version' of '28'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 28 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

Comment 8 Ben Cotton 2019-05-28 21:59:40 UTC
Fedora 28 changed to end-of-life (EOL) status on 2019-05-28. Fedora 28 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.