Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1558569 - [abrt] meson: join(): posixpath.py:78:join:TypeError: expected str, bytes or os.PathLike object, not NoneType
Summary: [abrt] meson: join(): posixpath.py:78:join:TypeError: expected str, bytes or ...
Keywords:
Status: CLOSED DUPLICATE of bug 1560091
Alias: None
Product: Fedora
Classification: Fedora
Component: meson
Version: 28
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Igor Gnatenko
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:be8acad36bac3f848a00d346279...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-03-20 14:02 UTC by Stephen Gallagher
Modified: 2018-04-24 18:47 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-24 18:47:56 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (916 bytes, text/plain)
2018-03-20 14:02 UTC, Stephen Gallagher
no flags Details
File: cgroup (373 bytes, text/plain)
2018-03-20 14:02 UTC, Stephen Gallagher
no flags Details
File: cpuinfo (1.38 KB, text/plain)
2018-03-20 14:02 UTC, Stephen Gallagher
no flags Details
File: environ (74 bytes, text/plain)
2018-03-20 14:02 UTC, Stephen Gallagher
no flags Details
File: mountinfo (4.19 KB, text/plain)
2018-03-20 14:02 UTC, Stephen Gallagher
no flags Details
File: namespaces (129 bytes, text/plain)
2018-03-20 14:02 UTC, Stephen Gallagher
no flags Details
File: open_fds (236 bytes, text/plain)
2018-03-20 14:02 UTC, Stephen Gallagher
no flags Details

Description Stephen Gallagher 2018-03-20 14:02:09 UTC
Description of problem:
I launched GNOME Builder and opened a meson-based project.

Version-Release number of selected component:
meson-0.45.0-1.fc28

Additional info:
reporter:       libreport-2.9.3
cmdline:        /usr/bin/python3 -s /usr/bin/meson introspect --tests
crash_function: join
exception_type: TypeError
executable:     /usr/bin/meson
kernel:         4.16.0-0.rc4.git0.1.fc28.x86_64
runlevel:       N 5
type:           Python3
uid:            13041

Truncated backtrace:
posixpath.py:78:join:TypeError: expected str, bytes or os.PathLike object, not NoneType

Traceback (most recent call last):
  File "/usr/bin/meson", line 26, in <module>
    sys.exit(main())
  File "/usr/bin/meson", line 23, in main
    return mesonmain.run(sys.argv[1:], launcher)
  File "/usr/lib/python3.6/site-packages/mesonbuild/mesonmain.py", line 293, in run
    return mintro.run(remaining_args)
  File "/usr/lib/python3.6/site-packages/mesonbuild/mintro.py", line 212, in run
    coredata = cdata.load(options.builddir)
  File "/usr/lib/python3.6/site-packages/mesonbuild/coredata.py", line 344, in load
    filename = os.path.join(build_dir, 'meson-private', 'coredata.dat')
  File "/usr/lib64/python3.6/posixpath.py", line 78, in join
    a = os.fspath(a)
TypeError: expected str, bytes or os.PathLike object, not NoneType

Local variables in innermost frame:
p: ('meson-private', 'coredata.dat')
a: None

Comment 1 Stephen Gallagher 2018-03-20 14:02:13 UTC
Created attachment 1410503 [details]
File: backtrace

Comment 2 Stephen Gallagher 2018-03-20 14:02:14 UTC
Created attachment 1410504 [details]
File: cgroup

Comment 3 Stephen Gallagher 2018-03-20 14:02:15 UTC
Created attachment 1410505 [details]
File: cpuinfo

Comment 4 Stephen Gallagher 2018-03-20 14:02:16 UTC
Created attachment 1410506 [details]
File: environ

Comment 5 Stephen Gallagher 2018-03-20 14:02:18 UTC
Created attachment 1410507 [details]
File: mountinfo

Comment 6 Stephen Gallagher 2018-03-20 14:02:19 UTC
Created attachment 1410508 [details]
File: namespaces

Comment 7 Stephen Gallagher 2018-03-20 14:02:20 UTC
Created attachment 1410509 [details]
File: open_fds

Comment 8 Igor Gnatenko 2018-04-24 18:47:56 UTC

*** This bug has been marked as a duplicate of bug 1560091 ***


Note You need to log in before you can comment on or make changes to this bug.