Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1590592 - Need spamassassin release with patch for bug 7208 included
Summary: Need spamassassin release with patch for bug 7208 included
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: spamassassin
Version: 29
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Kevin Fenzi
QA Contact: Fedora Extras Quality Assurance
URL: https://svn.apache.org/viewvc?view=re...
Whiteboard:
: 1590591 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-06-13 01:02 UTC by Philip Prindeville
Modified: 2018-09-29 23:56 UTC (History)
6 users (show)

Fixed In Version: spamassassin-3.4.2-2.fc28 spamassassin-3.4.2-2.fc29 spamassassin-3.4.2-2.fc27
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-09-23 20:19:31 UTC
Type: Bug


Attachments (Terms of Use)

Description Philip Prindeville 2018-06-13 01:02:55 UTC
Description of problem:

Post update, I'm seeing:

Jun  3 16:19:50 localhost spamd[2530]: plugin: failed to parse plugin (from @INC): exists argument is not a HASH or ARRAY element or a subroutine at /usr/share/perl5/vendor_perl/Mail/SpamAssassin/Plugin/URILocalBL.pm line 376.
Jun  3 16:19:51 localhost spamd[2530]: plugin: failed to parse plugin (from @INC): Attempt to reload Mail/SpamAssassin/Plugin/URILocalBL.pm aborted.
Jun  3 16:20:22 localhost spamd[2540]: plugin: failed to parse plugin (from @INC): exists argument is not a HASH or ARRAY element or a subroutine at /usr/share/perl5/vendor_perl/Mail/SpamAssassin/Plugin/URILocalBL.pm line 405.
Jun  3 16:20:22 localhost spamd[2540]: plugin: failed to parse plugin (from @INC): Attempt to reload Mail/SpamAssassin/Plugin/URILocalBL.pm aborted.

which is a result in recent versions of Perl being fussier about references to hashes.

See https://bz.apache.org/SpamAssassin/show_bug.cgi?id=7208


Version-Release number of selected component (if applicable):

spamassassin-3.4.1-17.fc27.x86_64

How reproducible:

Below


Steps to Reproduce:
1. Install spamassassin.
2. echo "loadplugin Mail::SpamAssassin::Plugin::URILocalBL" >> /etc/mail/spamassassin/v341.pre
3. Start spamassassin with systemctl and look at /var/log/maillog

Actual results:

Jun  3 16:19:50 localhost spamd[2530]: plugin: failed to parse plugin (from @INC): exists argument is not a HASH or ARRAY element or a subroutine at /usr/share/perl5/vendor_perl/Mail/SpamAssassin/Plugin/URILocalBL.pm line 376.
Jun  3 16:19:51 localhost spamd[2530]: plugin: failed to parse plugin (from @INC): Attempt to reload Mail/SpamAssassin/Plugin/URILocalBL.pm aborted.
Jun  3 16:20:22 localhost spamd[2540]: plugin: failed to parse plugin (from @INC): exists argument is not a HASH or ARRAY element or a subroutine at /usr/share/perl5/vendor_perl/Mail/SpamAssassin/Plugin/URILocalBL.pm line 405.
Jun  3 16:20:22 localhost spamd[2540]: plugin: failed to parse plugin (from @INC): Attempt to reload Mail/SpamAssassin/Plugin/URILocalBL.pm aborted.

Expected results:

None of these errors.

Additional info:

Grab commit r1684653 from SVN and add it as a patch to the .spec file.

Comment 1 Philip Prindeville 2018-06-13 01:04:33 UTC
*** Bug 1590591 has been marked as a duplicate of this bug. ***

Comment 2 Jan Kurik 2018-08-14 10:55:48 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 29 development cycle.
Changing version to '29'.

Comment 3 Fedora Update System 2018-09-19 02:38:19 UTC
spamassassin-3.4.2-1.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2018-1bf4c5356f

Comment 4 Fedora Update System 2018-09-19 02:38:42 UTC
spamassassin-3.4.2-1.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2018-cfe3700eba

Comment 5 Fedora Update System 2018-09-19 02:39:06 UTC
spamassassin-3.4.2-1.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-d42addb489

Comment 6 Fedora Update System 2018-09-20 04:58:35 UTC
spamassassin-3.4.2-1.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-1bf4c5356f

Comment 7 Fedora Update System 2018-09-20 11:11:02 UTC
spamassassin-3.4.2-1.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-d42addb489

Comment 8 Fedora Update System 2018-09-20 16:18:10 UTC
spamassassin-3.4.2-1.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-cfe3700eba

Comment 9 Fedora Update System 2018-09-20 22:26:11 UTC
spamassassin-3.4.2-2.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2018-8f0df2c366

Comment 10 Fedora Update System 2018-09-20 22:26:37 UTC
spamassassin-3.4.2-2.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-46d7a7f63e

Comment 11 Fedora Update System 2018-09-20 22:27:02 UTC
spamassassin-3.4.2-2.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2018-6ed251c42b

Comment 12 Fedora Update System 2018-09-21 08:00:01 UTC
spamassassin-3.4.2-2.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-8f0df2c366

Comment 13 Fedora Update System 2018-09-21 08:34:09 UTC
spamassassin-3.4.2-2.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-6ed251c42b

Comment 14 Fedora Update System 2018-09-21 08:48:13 UTC
spamassassin-3.4.2-2.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-46d7a7f63e

Comment 15 Fedora Update System 2018-09-23 20:19:31 UTC
spamassassin-3.4.2-2.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.

Comment 16 Fedora Update System 2018-09-29 22:01:16 UTC
spamassassin-3.4.2-2.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.

Comment 17 Fedora Update System 2018-09-29 23:56:52 UTC
spamassassin-3.4.2-2.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.