Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1592492 - Fails at configure time because glibc does not provide un-versioned xdr_* symbols
Summary: Fails at configure time because glibc does not provide un-versioned xdr_* sym...
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: libdap
Version: 29
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Orion Poplawski
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1556035 (view as bug list)
Depends On:
Blocks: F28FTBFS
TreeView+ depends on / blocked
 
Reported: 2018-06-18 16:21 UTC by David Abdurachmanov
Modified: 2018-08-27 09:26 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-08-27 09:26:30 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description David Abdurachmanov 2018-06-18 16:21:39 UTC
Description of problem:

From configure:
[..]
checking for library containing xdr_void... no
BUILDSTDERR: configure: WARNING: Cannot locate library containing xdr functions.
checking for xdr_uint32_t in -lc... no
checking for xdr_u_int32_t in -lc... no
checking for xdr_uint in -lc... no
checking for xdr_u_int in -lc... no
[..]

This happens because glibc no more provides xdr_* symbols which would be un-versioned.

Fedora 27:

[root@fa1924fd64c0 x86_64]# readelf -W -s /lib64/libc.so.6 | grep xdr_void
   731: 0000000000127610     6 FUNC    GLOBAL DEFAULT   13 xdr_void@@GLIBC_2.2.5
  3437: 0000000000127610     6 FUNC    LOCAL  DEFAULT   13 __GI_xdr_void
  5536: 0000000000127610     6 FUNC    GLOBAL DEFAULT   13 xdr_void
[root@fa1924fd64c0 x86_64]# readelf -W -s /lib64/libc.so.6 | grep xdr_uint32_t
   146: 0000000000128200    39 FUNC    GLOBAL DEFAULT   13 xdr_uint32_t@@GLIBC_2.2.5
  5286: 0000000000128200    39 FUNC    LOCAL  DEFAULT   13 __GI_xdr_uint32_t
  6561: 0000000000128200    39 FUNC    GLOBAL DEFAULT   13 xdr_uint32_t


Fedora 27 + rebuilt glibc from Rawhide:

[root@fa1924fd64c0 x86_64]# readelf -W -s ./lib64/libc.so.6 | grep xdr_void
   751: 0000000000129870     6 FUNC    GLOBAL DEFAULT   13 xdr_void.5
  3506: 0000000000129870     6 FUNC    LOCAL  DEFAULT   13 __GI_xdr_void
  5114: 0000000000129870     6 FUNC    LOCAL  DEFAULT   13 __EI_xdr_void
  7842: 0000000000129870     6 FUNC    GLOBAL DEFAULT   13 xdr_void.5
[root@fa1924fd64c0 x86_64]# readelf -W -s ./lib64/libc.so.6 | grep xdr_uint32_t
   150: 000000000012a460    39 FUNC    GLOBAL DEFAULT   13 xdr_uint32_t.5
  3599: 000000000012a460    39 FUNC    LOCAL  DEFAULT   13 __EI_xdr_uint32_t
  5555: 000000000012a460    39 FUNC    LOCAL  DEFAULT   13 __GI_xdr_uint32_t
  7818: 000000000012a460    39 FUNC    GLOBAL DEFAULT   13 xdr_uint32_t.5

Linker fails with undefined references in conftests and then configure fails.

Version-Release number of selected component (if applicable):

Rawhide + whatever version of libdap is available.

Works in Fedora 27.

Does anyone know why this changed?

Comment 1 David Abdurachmanov 2018-06-18 16:39:23 UTC
I also built a master of glibc (not using SPEC):

[root@fa1924fd64c0 build]# readelf -W -s ./libc.so.6 | grep xdr_uint32_t
   150: 00000000001239d0    39 FUNC    GLOBAL DEFAULT   13 xdr_uint32_t.5
  3603: 00000000001239d0    39 FUNC    LOCAL  DEFAULT   13 __EI_xdr_uint32_t
  5559: 00000000001239d0    39 FUNC    LOCAL  DEFAULT   13 __GI_xdr_uint32_t
  7822: 00000000001239d0    39 FUNC    GLOBAL DEFAULT   13 xdr_uint32_t.5
[root@fa1924fd64c0 build]# readelf -W -s ./libc.so.6 | grep xdr_void    
   751: 0000000000122f50     6 FUNC    GLOBAL DEFAULT   13 xdr_void.5
  3510: 0000000000122f50     6 FUNC    LOCAL  DEFAULT   13 __GI_xdr_void
  5118: 0000000000122f50     6 FUNC    LOCAL  DEFAULT   13 __EI_xdr_void
  7846: 0000000000122f50     6 FUNC    GLOBAL DEFAULT   13 xdr_void.5

Same results, thus the change came from upstream.

Comment 2 David Abdurachmanov 2018-06-18 18:55:59 UTC
There is already a patch for Funtoo Linux: https://github.com/TemptorSent/overlay-science-geo-kit/blob/master/sci-libs/libdap/files/libdap-3.19.1-use-libtirpc.patch

Comment 4 Orion Poplawski 2018-06-20 03:49:27 UTC
Thanks, that was a good start.  Should have a final version shortly.

Comment 5 Orion Poplawski 2018-06-20 03:49:58 UTC
*** Bug 1556035 has been marked as a duplicate of this bug. ***

Comment 6 Jan Kurik 2018-08-14 11:06:06 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 29 development cycle.
Changing version to '29'.

Comment 7 Zbigniew Jędrzejewski-Szmek 2018-08-27 09:26:30 UTC
There has been a successful build, let's close this so it doesn't confuse automated scripts.


Note You need to log in before you can comment on or make changes to this bug.