Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1597151 - Dell Precision 7510 keyboard and touchpad lagging
Summary: Dell Precision 7510 keyboard and touchpad lagging
Keywords:
Status: CLOSED DUPLICATE of bug 1218402
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-libs
Version: 28
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Paul Howarth
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-07-02 07:14 UTC by Sean A. Fulop
Modified: 2018-08-08 08:15 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-07-12 08:22:59 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Sean A. Fulop 2018-07-02 07:14:37 UTC
Description of problem:
Touchpad cursor movement lags and freezes; keyboard input freezes at random and then enters numerous repeated characters from the last key pressed.

Version-Release number of selected component (if applicable):
I only selected a component because of the requirement for submitting the bug.  IN fact, there is no specific component to which this is applicable.

How reproducible:
Happens all the time in all software apps.

Steps to Reproduce:
1. Start Fedora
2. Run any app requiring use of the keyboard and touchpad.
3.

Actual results:
Keyboard randomly freezes briefly and enters repeated characters; 
Touchpad randomly freezes motion

Expected results:


Additional info:

Comment 1 Paul Howarth 2018-07-02 08:07:11 UTC
I don't know which component this should be either, but it's certainly not gnome-libs, which is part of the ancient Gnome version 1 stack.

Are you sure you don't have something causing heavy CPU load on your computer?

Comment 2 Sean A. Fulop 2018-07-02 08:14:06 UTC
(In reply to Paul Howarth from comment #1)
> I don't know which component this should be either, but it's certainly not
> gnome-libs, which is part of the ancient Gnome version 1 stack.
> 
> Are you sure you don't have something causing heavy CPU load on your
> computer?

I'm not running anything much, and system monitor doesn't show significant CPU usage at the moment but the problem is still ongoing.  I've run several versions of Fedora on this machine for the past year or so, only Fedora 28 has caused this to happen.  I have never seen this happen on this computer before Fedora 28 upgrade.

Comment 3 Paul Howarth 2018-07-02 08:47:40 UTC
Perhaps your issue is similar to Bug #1218402?

Comment 4 Sean A. Fulop 2018-07-10 05:12:39 UTC
It seems as if the main app with these problems is Mozilla Firefox.  Perhaps if they upgrade versions it will eventually help.  Emacs doesn't show the problem hardly at all, nor does the terminal window.

Comment 5 Sean A. Fulop 2018-07-10 05:14:25 UTC
Scratch that, it *does* happen in the terminal window.

Comment 6 Paul Howarth 2018-07-11 14:59:08 UTC
Would you be OK if I marked this as a duplicate of Bug #1218402? You'd get CC-ed on that ticket, which looks very similar and probably has the right component.

Comment 7 Sean A. Fulop 2018-07-12 04:21:26 UTC
Yes that's fine, apart from the fact that they don't mention the typing problems, I do have the similar problems with mouse lags.

Comment 8 Paul Howarth 2018-07-12 08:22:59 UTC

*** This bug has been marked as a duplicate of bug 1218402 ***

Comment 9 Sean A. Fulop 2018-08-08 08:15:01 UTC
(In reply to Paul Howarth from comment #8)
> 
> *** This bug has been marked as a duplicate of bug 1218402 ***

After recent updates to Fedora 28 system, the reported problem has seemingly gone away.  I still have no idea what actually was causing the behavior.


Note You need to log in before you can comment on or make changes to this bug.