Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1605559 - pymol: FTBFS in Fedora rawhide
Summary: pymol: FTBFS in Fedora rawhide
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: pymol
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Tim Fenn
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 1551327 PYTHON37 F29FTBFS
TreeView+ depends on / blocked
 
Reported: 2018-07-20 16:00 UTC by Mohan Boddu
Modified: 2023-09-12 01:30 UTC (History)
3 users (show)

Fixed In Version: pymol-2.1.0-3.20180321svn4187.fc29
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-08-06 12:34:44 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)
build.log (5.35 KB, text/plain)
2018-07-20 16:00 UTC, Mohan Boddu
no flags Details
root.log (32.00 KB, text/plain)
2018-07-20 16:00 UTC, Mohan Boddu
no flags Details
state.log (675 bytes, text/plain)
2018-07-20 16:00 UTC, Mohan Boddu
no flags Details

Description Mohan Boddu 2018-07-20 16:00:19 UTC
pymol failed to build from source in Fedora rawhide

https://koji.fedoraproject.org/koji/taskinfo?taskID=28219856


For details on the mass rebuild see:

https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
Please fix pymol at your earliest convenience and set the bug's status to
ASSIGNED when you start fixing it. If the bug remains in NEW state for 8 weeks,
pymol will be orphaned. Before branching of Fedora 30,
pymol will be retired, if it still fails to build.

For more details on the FTBFS policy, please visit:
https://fedoraproject.org/wiki/Fails_to_build_from_source

Comment 1 Mohan Boddu 2018-07-20 16:00:23 UTC
Created attachment 1465853 [details]
build.log

Comment 2 Mohan Boddu 2018-07-20 16:00:27 UTC
Created attachment 1465854 [details]
root.log

file root.log too big, will only attach last 32768 bytes

Comment 3 Mohan Boddu 2018-07-20 16:00:29 UTC
Created attachment 1465855 [details]
state.log

Comment 4 Miro Hrončok 2018-07-24 14:18:21 UTC
OK, I fixed the immediate issue, yet there is a gcc-c++ build failure on ppc64le.

https://koji.fedoraproject.org/koji/taskinfo?taskID=28564602

Comment 5 Tim Fenn 2018-07-24 15:02:45 UTC
(In reply to Miro Hrončok from comment #4)
> OK, I fixed the immediate issue, yet there is a gcc-c++ build failure on
> ppc64le.
> 
> https://koji.fedoraproject.org/koji/taskinfo?taskID=28564602

Yeah, this is where I've been stuck - the error isn't informative and I can't find a good ppc64le build system to test with?

Comment 6 Miro Hrončok 2018-07-24 15:06:40 UTC
CCing Dan, he might have something for you to debug this on.

Comment 7 Dan Horák 2018-07-24 15:15:46 UTC
(In reply to Tim Fenn from comment #5)
> (In reply to Miro Hrončok from comment #4)
> > OK, I fixed the immediate issue, yet there is a gcc-c++ build failure on
> > ppc64le.
> > 
> > https://koji.fedoraproject.org/koji/taskinfo?taskID=28564602
> 
> Yeah, this is where I've been stuck - the error isn't informative and I
> can't find a good ppc64le build system to test with?

all maintainers can use machines from
https://fedoraproject.org/wiki/Test_Machine_Resources_For_Package_Maintainers

the problem looks like a real problem in pymol (or its bundled libs)

Comment 8 Miro Hrončok 2018-07-25 09:24:51 UTC
(This is a mass bug update. Forgive me if things are not 100% accurate for this one.)

At this moment, your package still requires Python 3.6. This will cause broken upgrades to Fedora 29. Please prioritize this rebuild.

Let me know if you need help from the Python maintenance team figuring out why the package FTBFS.

Consider orphaning the package if you don't have time for it.

Consider retiring the package if upstream is dead and nothing depends on it in Fedora.

If you are blocked by other packages (I've recently tried to set the Bugzilla metadata to reflect that), consider helping there as well. Thank you.

Comment 9 Miro Hrončok 2018-07-29 18:30:17 UTC
Igor, this has been unblocked in comment #4.

Comment 10 Miro Hrončok 2018-08-06 10:21:54 UTC
This is another friendly reminder.

Please take action.

Comment 11 Dan Horák 2018-08-06 12:10:47 UTC
The problem is with the -std=c++0x compiler option. It causes the "unix" preprocessor symbol to be undefined which is them missing in <msgpack/v1/vrefbuffer.hpp> to include <sys/uio.h> that defines "struct iovec".

For the record pymol is FTBFS in F-28 too.

Comment 12 Miro Hrončok 2018-08-06 12:33:17 UTC
-std=c++11 doesn't help either

Comment 13 Dan Horák 2018-08-06 12:38:45 UTC
(In reply to Miro Hrončok from comment #12)
> -std=c++11 doesn't help either

-std=gnu++0x/gnu++11 helps, feel free to revert my workaround

Comment 14 Miro Hrončok 2018-08-06 12:40:28 UTC
Thanks Dan.

Comment 15 Red Hat Bugzilla 2023-09-12 01:30:36 UTC
The needinfo request[s] on this closed bug have been removed as they have been unresolved for 1000 days


Note You need to log in before you can comment on or make changes to this bug.