Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 1605936 - python-svgwrite: FTBFS in Fedora rawhide
Summary: python-svgwrite: FTBFS in Fedora rawhide
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: python-svgwrite
Version: 29
Hardware: Unspecified
OS: Unspecified
urgent
high
Target Milestone: ---
Assignee: Julien Enselme
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: PYTHON37 F29FTBFS
TreeView+ depends on / blocked
 
Reported: 2018-07-20 17:40 UTC by Mohan Boddu
Modified: 2018-08-17 22:50 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-08-17 15:40:51 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)
build.log (deleted)
2018-07-20 17:40 UTC, Mohan Boddu
no flags Details
root.log (deleted)
2018-07-20 17:40 UTC, Mohan Boddu
no flags Details
state.log (deleted)
2018-07-20 17:40 UTC, Mohan Boddu
no flags Details

Description Mohan Boddu 2018-07-20 17:40:31 UTC
python-svgwrite failed to build from source in Fedora rawhide

https://koji.fedoraproject.org/koji/taskinfo?taskID=28225381


For details on the mass rebuild see:

https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
Please fix python-svgwrite at your earliest convenience and set the bug's status to
ASSIGNED when you start fixing it. If the bug remains in NEW state for 8 weeks,
python-svgwrite will be orphaned. Before branching of Fedora 30,
python-svgwrite will be retired, if it still fails to build.

For more details on the FTBFS policy, please visit:
https://fedoraproject.org/wiki/Fails_to_build_from_source

Comment 1 Mohan Boddu 2018-07-20 17:40:37 UTC
Created attachment 1466889 [details]
build.log

file build.log too big, will only attach last 32768 bytes

Comment 2 Mohan Boddu 2018-07-20 17:40:42 UTC
Created attachment 1466890 [details]
root.log

file root.log too big, will only attach last 32768 bytes

Comment 3 Mohan Boddu 2018-07-20 17:40:47 UTC
Created attachment 1466891 [details]
state.log

Comment 4 Miro Hrončok 2018-07-25 09:26:46 UTC
(This is a mass bug update. Forgive me if things are not 100% accurate for this one.)

At this moment, your package still requires Python 3.6. This will cause broken upgrades to Fedora 29. Please prioritize this rebuild.

Let me know if you need help from the Python maintenance team figuring out why the package FTBFS.

Consider orphaning the package if you don't have time for it.

Consider retiring the package if upstream is dead and nothing depends on it in Fedora.

If you are blocked by other packages (I've recently tried to set the Bugzilla metadata to reflect that), consider helping there as well. Thank you.

Comment 5 Julien Enselme 2018-07-26 08:29:28 UTC
Tests fail on Python 3.7 for a reason I cannot figure. Since according to ` repoquery --whatrequires python2-svgwrite` and `repoquery --whatrequires python3-svgwrite` nothing uses it anymore and than I don't need it, I'll just orphan it.

Comment 6 Miro Hrončok 2018-07-26 08:35:45 UTC
Consider announcing it and retire it if nobody wants it. Even orphaned packages will make broken dependencies.

Comment 7 Robert Brown 2018-07-31 14:38:52 UTC
Elegantly written, Miro.

Comment 8 Jos de Kloe 2018-08-02 10:16:41 UTC
(In reply to Julien Enselme from comment #5)
> Tests fail on Python 3.7 for a reason I cannot figure. Since according to `
> repoquery --whatrequires python2-svgwrite` and `repoquery --whatrequires
> python3-svgwrite` nothing uses it anymore and than I don't need it, I'll
> just orphan it.

a good next step would be to open an issue upstream at github to see if they are willing to support python3.7 (as I see it nobody asked for it yet).
see: https://github.com/mozman/svgwrite

Comment 9 Miro Hrončok 2018-08-06 10:22:34 UTC
This is another friendly reminder.

Please take action.

Comment 10 Miro Hrončok 2018-08-10 13:47:30 UTC
Note that I requested an approval from FESCo to retire leaf packages that still require Python 3.6 at beta freeze and their bugs are in NEW state. (This package might not necessarily be leaf at this moment, but I'm updating all the bugs in case the dependencies change in the meantime.)

More info at https://pagure.io/fesco/issue/1965

Comment 11 Miro Hrončok 2018-08-13 11:59:42 UTC
Another bulk reminder. Please take action. Your package doesn't install on Fedora 29. Fix it or retire it.

Comment 12 Jan Kurik 2018-08-14 10:27:40 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 29 development cycle.
Changing version to '29'.

Comment 13 Miro Hrončok 2018-08-16 12:31:10 UTC
Do something now! (This is the unfriendly reminder.)

Comment 14 Miro Hrončok 2018-08-16 15:13:56 UTC
I apologize if my unfriendly reminder was too harsh. It was intended to be stronger than the previous friendly reminders, not to hurt anyone.

That said, this still needs to be taken care of.

Comment 15 Miro Hrončok 2018-08-17 11:49:38 UTC
Leaf packages that still require Python 3.6 one week before Fedora 29 Beta Freeze ([0]) and their FTBFS bug remains in NEW state, will be mass retired. Packages marked as blocked by non-FTBFS bug are excluded from this. [1]

[0] https://fedoraproject.org/wiki/Releases/29/Schedule
[1] https://pagure.io/fesco/issue/1965

Comment 16 Julien Enselme 2018-08-17 15:40:51 UTC
Package retired with `fedpkg retire "Doesn't build any more and nothing depends on it."` on branches master and f29. See https://src.fedoraproject.org/rpms/python-svgwrite/commits/master

Closing this.

Comment 17 Miro Hrončok 2018-08-17 17:51:02 UTC
Thank you.


Note You need to log in before you can comment on or make changes to this bug.